NES30 Pro : no cfg file created ?

Welcome Page Forums RetroPie Project Controller Configuration in RetroPie NES30 Pro : no cfg file created ?

This topic contains 8 replies, has 3 voices, and was last updated by Profile photo of echdareez echdareez 1 year, 5 months ago.

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #114691
    Profile photo of echdareez
    echdareez
    Participant

    Hi there,

    My NES30 Pro arrived yesterday and I followed this tutorial :
    NES30 Tutorial

    Everything worked fine, I paired the NES30 and deleted the es_input.cfg under .emulationstation so I could reconfigure it. Reconfigured the device, I am able to use the controller to browse through the menus but the controller isn’t working in the emulator(s).

    Had a look under this folder :
    /opt/retropie/configs/all/retroarch-joypads
    but there’s no corresponding CFG to be found?

    Any suggestions?
    thanks in advance!
    /dimi

    #114692
    Profile photo of petrockblog
    petrockblog
    Keymaster

    Deleting it wipes some needed config. Reinstall ES from menu 5 of retropie-setup and reconfigure pad

    #114795
    Profile photo of echdareez
    echdareez
    Participant

    Thanks a lot Buzz for your reply!
    I did as you said but that didn’t bring back that es_input.cfg / went with option #1 (binary-based installation) and the file was back. Had some pairing problems but solved that too with adding the lines into my /etc/init.d/rc.local file… But that was besides the initial problem.

    But I still can not use the NES30 Pro in any emulator(s) – the file 8BitdoNES30Pro.cfg gets created under /opt/retropie/configs/all/retroarch-joypads but only the D-PAD works and the START is acting as the A-button… That’s it…

    These are the relevant lines :

    input_device = "8Bitdo NES30 Pro"
    input_driver = "sdl2"
    input_start_btn = "11"
    input_a_btn = "0"
    input_b_btn = "1"
    input_x_btn = "3"
    input_y_btn = "4"
    

    Also added the contents of this cfg into the main retroarch.cfg (one level up) but no luck either…

    On to more reading ๐Ÿ™‚
    /dimi

    #114800
    Profile photo of petrockblog
    petrockblog
    Keymaster

    you have an old retroarch.cfg – change the input_joypad_driver to “udev” in configs/all/retroarch.cfg (it is currently set to sdl2). You can do this from “Edit RetroPie/RetroArch configurations” from retropie-setup. Once this is done, reconfigure your controller within emulationstation and try again.

    #114824
    Profile photo of hobbswon
    hobbswon
    Participant

    May I ask what install you are running?

    I ask because on my fresh 3.4 install I cannot get ES to detect the NES/FC30 Pro at all. When I rolled it back to 3.3 I had the same issue until I updated ES from the Retropie Setup menu. Then ES would detect the gamepads and they would be configured (even with the udev driver, no editing needed)

    So I had a hunch this was the issue in 3.4 as well. But when I did a fresh install of 3.4, uodated the setup script then uodated ES, it did not delete the input configuration. My USB gamepad was still configured and it still would not recognize the 8bitdo pads.

    #114835
    Profile photo of echdareez
    echdareez
    Participant

    @buzz : That was it! Thanks so much! Now works splendidly (except for the hotkeys for some reason). Have added this in my .cfg file :

    
    input_enable_hotkey_btn = "10"
    input_exit_emulator_btn = "11"
    

    and they’re not being triggered (if SELECT + START) are pressed. Will keep on looking ๐Ÿ™‚
    Small note though : I had looked in that retroarch.cfg before and tried the options as given :
    # Input device driver. (Valid: linuxraw, sdl, dinput)
    Confused as the udev option isn’t in that file but it’s present in the menu (which I didn’t know)
    What else : didn’t know you were the author so also my genuine thanks for a brilliant distro ๐Ÿ™‚

    @hobbswon : Absolutely and yes you can – started out initially with 3.2 and always updated my distro with the 1st option in the Retropie-Setup menu. And currently, the commit is 6b752d1f5cb162e96f519e74b26e70a803a94bae – so just one day old (and thus also 3.4 I think? )
    Well, I have had some problems too with my NES30 PRO and not sure if they are similar to your problem but here it goes : the NES30 PRO is finicky : to switch it completely off, I have to press B and POWERON for 3 SECS… Seems it gets sometimes in a “weird” state? After that, I use the NES30 PRO in the 1st ‘state’ (switching it on with just the POWERON button and no other keys are being pressed)
    I also updated my NES30 to the latest firmware (1.68 with WII option)
    And finally : I had also some problems with ES detecting the NES30 : fixed it with editing the /etc/init.d/rc.local and added this :

    
    . /lib/lsb/init-functions
    
    sudo bluez-test-device remove xx:xx:xx:xx:xx:xx
    sudo bluez-simple-agent hci0 xx:xx:xx:xx:xx:xx
    sudo bluez-test-device trusted xx:xx:xx:xx:xx:xx yes
    sudo bluez-test-input connect xx:xx:xx:xx:xx:xx
    
    do_start() {
            if [ -x /etc/rc.local ]; then
    

    Drastic to delete the device first but it does the trick…
    Hope it helps?
    /dimi

    #114851
    Profile photo of hobbswon
    hobbswon
    Participant

    I am able to get the NES30 Pro and the FC30 Pro to pair on boot just using

    bluez-test-input connect xx:xx:xx:xx

    The mapping is a mess though. The analog sticks just do nothing and save increment/decrement buttons are supposed to be autoconfig for top R/L and it LOOKS like they all map correctly but they do nothing in joypad mode or keyboard mode. Even when manually editing the .cfg

    #114870
    Profile photo of petrockblog
    petrockblog
    Keymaster

    you should use /etc/rc.local rather than /etc/init.d/rc.local btw – the init.d script isn’t meant to be modified

    #114874
    Profile photo of echdareez
    echdareez
    Participant

    @hobbswon : alas, wish I could help you out but the only thing I can suggest is to try the NES30 in the commandline? See if the analog sticks give an output ? But I think you must’ve tried that out already?

    @buzz : Oh? Another thing I didn’t know ๐Ÿ™‚ I’ll modify it right away / cheers!

Viewing 9 posts - 1 through 9 (of 9 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar