NES running slow + MAME saving??

This topic contains 3 replies, has 3 voices, and was last updated by Profile photo of bhilton5 bhilton5 2 years, 6 months ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #8564
    Profile photo of sewersurfer
    sewersurfer
    Participant

    Hello,
    I use the standard NES emulator and one problem I keep having is, that it is running painfully slow compared to most other emulators (SNES, Genesis etc).
    This is caused, I believe, by the resolution for NES beein higher than for the other emulators. The way I noticed this is, that when I save during gameplay in NES I can read the whole text of “Saved state to slot #0”. While e.g. playing SNES the text is much bigger to begin with, runs across the whole width of the screen and I can only read half the text.
    So, how can I change the resolution for the NES emulator? Or is there another way to fix this problem??

    And is there any way to save on Mame, using mame4allpi?? I googeld it but couldn´t come up with anything usefull.

    thank you

    #8591
    Profile photo of blaxzen
    blaxzen
    Participant

    Hey there.

    By default the config for NES is mode 4.
    # starttype==4: set video mode to 720p60
    Many of the other emulators are setup for VGA only mode which is starttype==1

    I haven’t actually tried adjusting this as my NES seems to run fine.

    The config file is located here: /home/pi/.emulationstation/es_systems.cfg
    Scroll down to this line – DESCNAME=Nintendo Entertainment System and you will find this line
    COMMAND=/home/pi/RetroPie/supplementary/runcommand/runcommand.sh 4 "/home/pi/RetroPie/emulators/RetroArch/installdir/bin/retroarch -L /home/pi/RetroPie/emulatorcores/fceu-next/fceumm-code/fceumm_libretro.so --config /home/pi/RetroPie/configs/all/retroarch.cfg --appendconfig /home/pi/RetroPie/configs/nes/retroarch.cfg %ROM%"

    If you change runcommand.sh 4 to runcommand.sh 1, I believe that will change the video output mode, although I have tested this, just a guess that it will work but I assume that the emulator supports 480p output.

    #9393
    Profile photo of sewersurfer
    sewersurfer
    Participant

    I just tried this and it works perfectly fine now. So much better than before!

    Thank you

    #83288
    Profile photo of bhilton5
    bhilton5
    Participant

    Hi that directory doesn’t seem to be there in v2.3… could you please help me locate the file?

    update:
    /etc/emulationstation/es_systems.cfg

Viewing 4 posts - 1 through 4 (of 4 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar