NeoGeo exit button not working

Welcome Page Forums RetroPie Project Controller Configuration in RetroPie NeoGeo exit button not working

This topic contains 28 replies, has 4 voices, and was last updated by Profile photo of cyborguk cyborguk 1 year, 7 months ago.

Viewing 29 posts - 1 through 29 (of 29 total)
  • Author
    Posts
  • #108961
    Profile photo of cyborguk
    cyborguk
    Participant

    I’m running the Neogeo emulator and gone into the retroarch menu and configured my settings and saved it, which create a new cfg in configs\neogeo\fba_libretro.cfg which I renamed retroarch.cfg

    All works apart from my exit button. I have chosen button 8 like below, why does it not wor?

    Retroarch ingame menu:
    main menu > input > input hotkey binds > Quite RetroArch = button 8 or Escape

    in the Retroarch.cfg
    input_exit_emulator = “escape”

    input_exit_emulator_btn = “8”

    Retropie 3.2.1

    #108963
    Profile photo of Floob
    Floob
    Member

    Maybe youve lost your hotkey enable button.
    input_enable_hotkey_btn =

    You may want to update your config in this cleaner way:

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #108969
    Profile photo of cyborguk
    cyborguk
    Participant

    I followed your very useful video and decided to try it on the Megadrive one, all works, but again if I hit my button 8 whilst playing a game it won’t quit back to the emulationstaion screen. This is my retroarch.cfg for the Megadrive:

    # Settings made here will only override settings in the global retroarch.cfg if placed above the #include line

    input_remapping_directory = /opt/retropie/configs/megadrive/
    # video_smooth = false
    video_shader = /opt/retropie/emulators/retroarch/shader/phosphor.glslp
    # video_shader_enable = true

    video_aspect_ratio_auto = “false”
    video_fullscreen = “true”
    aspect_ratio_index = “10”
    input_player1_select_btn = “7”
    input_player1_start_btn = “6”
    input_player2_select_btn = “7”
    input_player2_start_btn = “6”
    input_exit_emulator = “8”
    input_exit_emulator_btn = “8”

    #include “/opt/retropie/configs/all/retroarch.cfg”

    #108975
    Profile photo of Floob
    Floob
    Member

    All your controller buttons and the hotkeys should already be in the controller file here:
    /opt/retropie/configs/all/retroarch-joypads/{yourcontroller.cfg}

    What are you trying to override by adding them here? (I dont think you can get controller #2 to exit the emulator, I think that has to be controller #1).

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #108978
    Profile photo of cyborguk
    cyborguk
    Participant

    Oh I just thought the emulator specific controls where in the emulator retroarch.cfg?

    Isn’t the command

    input_exit_emulator_btn = “8”

    A generic command nsither associated with either player 1 or 2? If it has to be associated with player 1 how do I do this?

    Thanks

    #109024
    Profile photo of Floob
    Floob
    Member

    These should be in your controller file anyway.
    If you take out your lines referring to 6,7 and 8 what isnt working for you?

    Your hotkeys should all be in:
    /opt/retropie/configs/all/retroarch-joypads/{yourcontroller.cfg}
    Do you have 2 controllers the same?

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #109036
    Profile photo of cyborguk
    cyborguk
    Participant

    I have 2 controllers yes.

    In my /opt/retropie/configs/all/retroarch-joypads/DragonRiseInc.GenericUSBJoystick.cfg

    I have:

    input_device = “DragonRise Inc. Generic USB Joystick ”
    input_driver = “udev”
    input_start_btn = “3”
    input_exit_emulator_btn = “3”
    input_up_axis = “-1”
    input_a_btn = “0”
    input_b_btn = “1”
    input_reset_btn = “1”
    input_down_axis = “+1”
    input_right_axis = “+0”
    input_state_slot_increase_axis = “+0”
    input_x_btn = “5”
    input_menu_toggle_btn = “5”
    input_select_btn = “4”
    input_enable_hotkey_btn = “4”
    input_y_btn = “2”
    input_left_axis = “-0”
    input_state_slot_decrease_axis = “-0”

    If I add:

    input_player1_select_btn = “7”
    input_player1_start_btn = “6”
    input_player2_select_btn = “7”
    input_player2_start_btn = “6”
    input_exit_emulator = “8”
    input_exit_emulator_btn = “8”

    Go into the Megadrive emulator those buttons no longer work.

    The quit button from the Megadrive emulator back to ES has never worked. If I add the above to /opt/retropie/configs/megadrive/retroarch.cfg the select buttons work fine again for both players, quit doesn’t work still.

    #109104
    Profile photo of Floob
    Floob
    Member

    If you are saying that holding:

    input_select_btn = “4”
    input_enable_hotkey_btn = “4”

    and pressing

    input_start_btn = “3”
    input_exit_emulator_btn = “3”

    dont work for you, I would use the retropie setup script to re-create this retroarch controller file. (I’m assuming the odd quote marks are a result of pasting here – also assuming you have just the one config file in that directory)

    To re-create the file, just run “sudo /home/pi/RetroPie-Setup/retropie_setup.sh”
    and choose the option in the setup menu to create a retroarch controller file.

    You could backup the existing file before you do this just in case.

    You could manually check the correct button codes with jstest

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #109124
    Profile photo of cyborguk
    cyborguk
    Participant

    No those don’t work, hence adding them the way I did worked, but I like to follow best practice to be honest.

    Just used putty and ran sudo /home/pi/RetroPie-Setup/retropie_setup.sh but don’t see the option to create a retroarch controller file.

    #109128
    Profile photo of herbfargus
    herbfargus
    Member

    That option was removed as it is obsolete since the configuration input is created for retroarch when you configure a controller through emulationstation.

    #109153
    Profile photo of cyborguk
    cyborguk
    Participant

    I will start again I think. I have a bartop with 2 USB controllers for the 2 players, so when I first installed Retropie it asks me to set up the detected joysticks and buttons which I have done and I can successfully navigate through ES. So this is saved in opt/retropie/configs/all/retroarch-joypads/{yourcontroller.cfg}?

    I think my override of the retroarch.cfg file in the Megadrive folder and others for example works for me is that I require the select buttons and start buttons to be different as I have buttons with the player 1 symbol and start on them. I could be wrongwrong.

    On the bartop I have an exit button that has in the passed be used to instantly quit out of a game in emulator, it is seen as button 8 in my old configs and in retroarch when I press it, but I just can’t get it to exit games and back to ES.

    #109171
    Profile photo of Floob
    Floob
    Member

    Were you able to confirm the buttons identified when using the jstest tool shown in the video above?
    That should confirm which buttons are mapped to start and select.

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #109203
    Profile photo of cyborguk
    cyborguk
    Participant

    Sorry I didn’t see that video, open forum in Chrome and it appeared, really good too Floob.

    Well the button I want to exit emulators like the Megadrive, Neogeo etc does show as button 8 when pressed.

    So where should I configure this button 8 so I can exit straight back to ES?

    #109206
    Profile photo of Floob
    Floob
    Member

    Can you confirm what button number the Select reports as using jstest?

    I’m assuming your 2 controllers are the same?

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #109210
    Profile photo of g0nz0uk
    g0nz0uk
    Participant

    .

    #109212
    Profile photo of cyborguk
    cyborguk
    Participant

    sure it’s button 4.

    Both controllers are the same

    #109214
    Profile photo of Floob
    Floob
    Member

    Not quite what I’d expect, but try updating your controller file to read like this.
    (Do you have a link – amazon maybe? – to your controller?)

    input_device = "DragonRise Inc. Generic USB Joystick "
    input_driver = "udev"
    input_start_btn = "8"
    input_exit_emulator_btn = "8"
    input_up_axis = "-1"
    input_a_btn = "0"
    input_b_btn = "1"
    input_reset_btn = "1"
    input_down_axis = "+1"
    input_right_axis = "+0"
    input_state_slot_increase_axis = "+0"
    input_x_btn = "5"
    input_menu_toggle_btn = "5"
    input_select_btn = "4"
    input_enable_hotkey_btn = "4"
    input_y_btn = "2"
    input_left_axis = "-0"
    input_state_slot_decrease_axis = "-0"

    Then to exit a game, hold your select button and tap Start with your P1 controller.

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #109255
    Profile photo of cyborguk
    cyborguk
    Participant

    I use 2 Xin-Mo Xin-Mo USB Controllers

    My button 8 for exit is off the player 1 USB controller.

    If I copy my retroarch.cfg from my 2.6 retropie image (attached below) and put it into pi@retropie /opt/retropie/configs/megadrive $ my buttons are all good and the button 8 exits the emulator perfectly.

    As you say its a messy way of doing it why I don’t like, would be nice to know how to get this to work the cleaner way.

    Attachments:
    1. retroarch.zip
    #109259
    Profile photo of Floob
    Floob
    Member

    What happens if you put this in your /opt/retropie/configs/all/retroarch.cfg

    input_device = "Xin-Mo Xin-Mo Controller"
    input_driver = "udev"
    input_player1_joypad_index = "0"
    input_player1_a_btn = "1"
    input_player1_b_btn = "0"
    input_player1_y_btn = "3"
    input_player1_x_btn = "4"
    input_player1_start_btn = "6"
    input_player1_select_btn = "7"
    input_player1_l_btn = "5"
    input_player1_r_btn = "2"
    input_player1_left_axis = "-0"
    input_player1_right_axis = "+0"
    input_player1_up_axis = "-1"
    input_player1_down_axis = "+1"
    input_player2_joypad_index = "1"
    input_player2_a_btn = "1"
    input_player2_b_btn = "0"
    input_player2_y_btn = "3"
    input_player2_x_btn = "4"
    input_player2_start_btn = "6"
    input_player2_select_btn = "7"
    input_player2_l_btn = "5"
    input_player2_r_btn = "2"
    input_player2_left_axis = "-0"
    input_player2_right_axis = "+0"
    input_player2_up_axis = "-1"
    input_player2_down_axis = "+1"
    input_exit_emulator_btn = "8"

    Without a hotkey enable you wont be able to add other hotkeys though.

    Check some of the videos out linked in my sig to see how hotkeys and config files work.

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #109473
    Profile photo of cyborguk
    cyborguk
    Participant

    Sorry for the delay, but still no luck. I added your suggested config to the bottom of the retroarch.cfg at /opt/retropie/configs/all/retroarch.cfg and the exit button didn’t work.

    But yes if I add my above attached retroarch.cfg to my /opt/retropie/configs/megadrive it does work. The same process seems to work for the NeoGeo one too.

    Something it my file seems to make it work, but only when it’s in the /configs/emulator folder.

    #109481
    Profile photo of Floob
    Floob
    Member

    In your first post above, you say that you renamed a file to be retroarch.cfg

    If you follow this video, you will see exactly what that did – compare the before and after and you’ll only have a few lines difference – itll make things a lot clearer.

    NeoGeo exit button not working

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #109483
    Profile photo of cyborguk
    cyborguk
    Participant

    That’s really the reason for this post as I followed that nice video and copied the changes and you mentioned I’d put it in the wrong file.

    The only way to get the exit button to work is copy the 48k file over the Base one, if I compare there are too many changes.

    #109486
    Profile photo of Floob
    Floob
    Member

    If you start from a clean image, create the fba_libretro.cfg file, then make your changes and create another file fba_libretro-1.cfg, then compare the 2 there shouldnt be drastic changes.

    As you are using a Xin-Mo you may also find this thread interesting

    Autofire on the axis

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #109496
    Profile photo of cyborguk
    cyborguk
    Participant

    So I copied this below into the /configs/megadrive/retroarch.cfg

    and removed the # from the start of include “/opt/retropie/configs/all/retroarch.cfg”

    then all works in the Megadrive emulator and the exit (button 8 works), it then seems to merge both the /configs/all/retroarch.cfg into the /configs/megadrive/retroarch.cfg file

    # Settings made here will only override settings in the global retroarch.cfg if placed above the #include line

    input_remapping_directory = /opt/retropie/configs/megadrive/
    # video_smooth = false
    video_shader = /opt/retropie/emulators/retroarch/shader/phosphor.glslp
    # video_shader_enable = true

    video_aspect_ratio_auto = “false”
    video_fullscreen = “true”
    aspect_ratio_index = “10”

    input_device = “Xin-Mo Xin-Mo Controller”
    input_driver = “udev”
    input_player1_joypad_index = “0”
    input_player1_a_btn = “1”
    input_player1_b_btn = “0”
    input_player1_y_btn = “3”
    input_player1_x_btn = “4”
    input_player1_start_btn = “6”
    input_player1_select_btn = “7”
    input_player1_l_btn = “5”
    input_player1_r_btn = “2”
    input_player1_left_axis = “-0”
    input_player1_right_axis = “+0”
    input_player1_up_axis = “-1”
    input_player1_down_axis = “+1”
    input_player2_joypad_index = “1”
    input_player2_a_btn = “1”
    input_player2_b_btn = “0”
    input_player2_y_btn = “3”
    input_player2_x_btn = “4”
    input_player2_start_btn = “6”
    input_player2_select_btn = “7”
    input_player2_l_btn = “5”
    input_player2_r_btn = “2”
    input_player2_left_axis = “-0”
    input_player2_right_axis = “+0”
    input_player2_up_axis = “-1”
    input_player2_down_axis = “+1”
    input_exit_emulator_btn = “8”

    include “/opt/retropie/configs/all/retroarch.cfg”

    I will try the other emulators later, just means each retroarch.cfg for each emulator will be around 48k instead of 1k.

    #109500
    Profile photo of Floob
    Floob
    Member

    You need the # in front of the include “/opt/retropie/configs/all/retroarch.cfg”
    Its not a comment in this context, its an include.

    If it doesnt work when you put it there it means something is overriding your settings in the main retroarch.cfg – so you could go in there and comment out the offending lines, or just replace them with these if your going to use the same controller for all systems.

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #109501
    Profile photo of cyborguk
    cyborguk
    Participant

    That’s what I was doing and the quit button would not work, for some reason this does. This is a fresh 3.2.1 image too. My friend said to try it as it’s the method he has had to use too.

    #109792
    Profile photo of cyborguk
    cyborguk
    Participant

    Hmm I revisited this and it seems the combo of button 8 and 4 (x button) exits all emulators.

    I just need to find out why button 8 needs button 4 🙂

    #109799
    Profile photo of Floob
    Floob
    Member

    I would take the settings out of the system retroarch.cfg files and just allow the retroarch setup script to create it in the controller file – or just add it to the main retroarch.cfg – its hard for me to say as I dont have a Xin-Mo, but it worked for me with the Picade I recently tried. Using a clean install and letting ES set them should work, and if not use the retroarchsetup script to create the buttons.

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #109802
    Profile photo of cyborguk
    cyborguk
    Participant

    Yeah that was a good video you did for the picade.

    I’m just curious why this combos of buttons works and where this is likey to be configured, it’s like a hot key.

Viewing 29 posts - 1 through 29 (of 29 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar