NEO GEO not working (BLACK SCREEN ONLY)

Welcome Page Forums RetroPie Project Everything else related to the RetroPie Project NEO GEO not working (BLACK SCREEN ONLY)

This topic contains 22 replies, has 8 voices, and was last updated by  herbfargus 2 years, 9 months ago.

Viewing 23 posts - 1 through 23 (of 23 total)
  • Author
    Posts
  • #14002

    Haris1977

    Ok. I can play some emulators almost perfect (many nes, genesis, fba, pca emulators), but i havent managed to play any neo geo roms.

    I have put both fba and neogeo roms in the same roms/fba folder along with the neogeo.zip. Only black screen appears. I know i have to change smth but i need instructions. Can someone help?

    #14304

    Haris

    Ok fixed:)

    #14315

    aornn
    Participant

    how ?!
    i have the same problem plz ! 😀

    #14367

    Haris1977

    Just put your correct neogeo bios (neogeo.zip) to:

    1 – opt/retropie/emulators/gngeo-pi-0.85/gngeo AND

    2 – home/pi/RetroPie/roms

    (in both paths)

    #14414

    aornn
    Participant

    And do you know how tu use PS3 controller with USB on retromie for play with every emulators ?

    i have agin this probleme i put mu bios neogeo in /home/pi/retropie/roms/neogeo and in /opt/retropie/emulators/gngeo-pi-0.85/gngeo

    that’s right ?!

    #14422

    Haris

    I havent use a wired ps3 controller

    i use the wireless version (with the help of a usb bt dongle)

    Just go in retropie-setup, option 3 and then option 321. You just follow on screen instructions

    #14425

    Haris

    Oops sory , my mistake

    Correct Number 2 path is:

    /home/pi/RetroPie/roms/fba

    #14426

    aornn
    Participant

    i do :
    cd ~/RetroPie-Setup

    sudo ./retropie_setup.sh

    ?

    And have you edit any file for play in bluetooth with your controller ?

    #14446

    Haris1977

    cd RetroPie-Setup
    sudo ./retropie_setup.sh

    Press 4,5, 3 and then 321 option on that order. Follow on screen instructions for 321 option

    no need to edit files

    #14448

    aornn
    Participant

    i will try and after i post if it’s work

    #14482

    aornn
    Participant

    it’ worst with this my MAME rom doesn’t work ! and i still can’t play with neo geo … T-T

    #14772

    aornn
    Participant

    My Neo geo emuator work but a lot of game doesn’t work it’s normal ?

    #16997

    alfeus
    Participant

    Hi,
    I Have the same problem.
    Someone can publish a tutorial about MAME and NEOGEO?
    Thanks!

    #77854

    profitwarning
    Participant

    Hi,

    I had the same problem. You really need the right roms for the provided .drv files.(and bios)
    Look for this pack
    FB_Alpha_v0.2.97.08_Neo_Geo_ROM_Collection_(NeoGeo_ROMs)_by_Lovok

    Worked great for me.

    #81995

    sheggen
    Participant

    Hello,

    Please, could you tell me where to find the bios file neogeo? (neogeo.zip)
    I have one version of this file ( +-250k) but it doesn’t work with all roms. For example, metal slug 3 is not compatible with this bios version…
    Thanks in advance for your help!

    #82008

    Floob
    Member

    Does this help?

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #86160

    tupadre
    Participant

    I am having issues with FBA NeoGeo games all of a sudden. Alot of my games didn’t work because of the wrong file so I updated them via clrmamepro. Now they work yet they don’t. The graphics are all screwed up. Lines in them, missing sprite’s, etc. Even the opening startup screen that has the big NeoGeo logo on the white background is missing. Just the white background and the sound is still good to go. What is strange is even if I replace the files with an older copy that I know worked before, I still get the same thing. Anyone had this issue or have any suggestions? I thought maybe the BIOS got corrupted so I replaced it but that gave me no joy.

    #86162

    Floob
    Member

    I would be sorely tempted to download the set that profitwarning mentins above. It seems FBA is happiest with sets geared for portable devices. As I’m no mame / fba set expert I download the correct set rather than convert them.

    Maybe we could keep track of what works here:

    MAME romset versions?

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #95068

    phfuks
    Participant

    hey, i have many problems, i’m a new user linux.
    can you help me?

    1- When i execute a rom in Emulation Station -> NEO-GEO, some files load (.bin files) and appears the black screen, the game don’t run.

    2- My neogeo bios file (neogeo.zip) are pasted in “home/pi/RetroPie/roms”, but i can’t access “opt/retropie/emulators/gngeo-pi-0.85/gngeo” through XFCE.

    3- my folder “opt/retropie/emulators/gngeo-pi-0.85/gngeo” don’t exist, but exist a similar folder (“opt/retropie/emulators/gngeopi/neogeobios”)

    Information:
    RaspBerry Pi B
    Pipplware 4.0

    #95069

    herbfargus
    Member
    #95071

    phfuks
    Participant

    I tried use PiFBA too, i copied the roms files to home/pi/RetroPie/roms/fba, and appears the same error:
    some files load (.bin files) and appears the black screen, the game don’t run

    I don’t found any BIOS file to fba, i need a BIOS file?

    #95072

    phfuks
    Participant

    the error can be the rooms files?
    the load screen show:Final Burn Alpha

    #95073

    herbfargus
    Member

    For neo geo games you need the neogeo.zip file in the same folder as your ROMs. What is required is laid out clearly in the aforementioned posts. Floob has some videos on it as well. The answers are all on the forum, a little searching will get you what you need.

Viewing 23 posts - 1 through 23 (of 23 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

PLEASE NOTE: All orders that are placed between January 14th and January 28th will be shipped on January 29th. Dismiss