Need to swap buttons, emulator specific config file does nothing.

Welcome Page Forums RetroPie Project Controller Configuration in RetroPie Need to swap buttons, emulator specific config file does nothing.

This topic contains 1 reply, has 1 voice, and was last updated by  sudodaemon 1 year, 12 months ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #114548

    sudodaemon
    Participant

    Brand new RetroPie installation, 3.3. I was able to easily set up my PS3 controller over bluetooth, all buttons mapped… One issue though. When I launch ANY game the X and O buttons are reversed. So in emulation station everything is mapped properly, the A button is mapped as the X button on the controller, and O (circle) is the B button… But when I go into a Playstation, NeoGeo, NES game, any game the X button and O button get reversed. I have tried adding inputs into opt/retropie/configs/psx/retroarch.cfg to start … but it seems to ignore this file or I’m doing something wrong. Anything I edit with that file, it all goes BEFORE the #include… so… What am I doing wrong here?

    Are there config files for the emulators that I’m not seeing? Any reason it would ignore the edits I’m making?

    #114550

    sudodaemon
    Participant

    Well, I may have just solved my problem… I edited the following file.

    /opt/retropie/configs/all/autoconf.cfg

    I changed the following line from 0 to 1.

    es_swap_a_b = 1

    I then configured the controller in ES, and mapped A (X) and B (O) backwards.

    Now the controller is mapped properly in the games, and ES is now mapped properly once it does the swap…

    Weird, but seems to be all figured out… Wanted to post this in case anybody else runs into this issue like I did.

Viewing 2 posts - 1 through 2 (of 2 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

PLEASE NOTE: All orders that are placed between January 14th and January 28th will be shipped on January 29th. Dismiss