n64 ROMs show up, but won't play

Home Forums RetroPie Project Everything else related to the RetroPie Project n64 ROMs show up, but won't play

This topic contains 36 replies, has 16 voices, and was last updated by Profile photo of lpurchase lpurchase 2 years, 6 months ago.

Viewing 35 posts - 1 through 35 (of 37 total)
  • Author
    Posts
  • #18962
    Profile photo of mrsteven2
    mrsteven2
    Participant

    N64 games doesn’t start. I can see the roms start to load, and everything seems ok, the resolution changes, but then it quits and goes back to Emulator station. The following lines are there:

    Core: Starting emulation 1332
    Core: Starting R3400 emulator: Dynamic Recompiler
    Core: Init new dynarec
    Core Status: Stopping emulation.
    Core: R4300 emulator finished.
    Core: Stopping emulation at 2650
    Core Status: Rom closed.
    Powering on HDMI with preferred settings
    ondemand

    Im not sure what to do about this. I’m running a high overclocked b+ with stock RetroPie on it. I haven’t been able to update from the version 2.3 because I cannot get the internet set up at the moment in my house, but I have downloaded the most recent image on the retropie download site (aka I did it 3 days ago).

    #19003
    Profile photo of dizzycrosby
    dizzycrosby

    Same issue here. Also, is there a quick way to see what version of retropie i’m running? Like a help, about?

    #19123

    Conway6288

    I am having a similar issue. I can load games from SNES, Genesis etc but if I try and load anything from N64 I get the usual terminal view (Albeit in a much lower resolution, which I cannot read, haven’t messed around with the config files at all yet) and then it spits me straight back to emulation station.

    Any ideas?

    #19202
    Profile photo of hanfen
    hanfen
    Participant

    Conway i’m having the same issue. If you press quit the emulationstation it still displays the log and probably the error. (It’s a segmentation fault in line 23 for me).

    #19363
    Profile photo of mrsteven2
    mrsteven2
    Participant

    I also have the sementation fault in line 23 of the runcommand.sh!
    I just must have missed copying that line over.
    Anyone know how to fix this?

    #20236
    Profile photo of deaftolight
    deaftolight
    Participant

    Me too! I hope someone figures it out.

    #20600
    Profile photo of mr9v9
    mr9v9
    Participant

    What about the old config files not being removed for Mupen64 from the folder migration since 2.1? If you remove all the old config files, and uninstall Mupen64>
    $ make
    Mupen64Plus makefile.
    Targets:
    all == Build Mupen64Plus and all plugins
    clean == remove object files
    rebuild == clean and re-build all
    install == Install Mupen64Plus and all plugins
    uninstall == Uninstall Mupen64Plus and all plugins
    Then try a source based installation using 16mb shared ram setting in raspi-config, and try building without the RetroPie-Setup Script it might build properly with the config files going into the correct folders.
    I don’t know I’m no longer running RetroPie 2.3 image to test right now.

    #44879
    Profile photo of borlandoflorida
    borlandoflorida
    Participant

    What about the old config files not being removed for Mupen64 from the folder migration since 2.1? If you remove all the old config files, and uninstall Mupen64>
    $ make
    Mupen64Plus makefile…….

    Like you guys, I’m having the same issue. I get the same error as mrsteven2 stated at the start. I’d like to have a go at what mr9v9 is proposing, but I’m not sure what he means (I’m still learning).

    Would it be possible to explain this using the command line steps to follow?

    #47345
    Profile photo of charger1369
    Nathan

    Im having the same problem too, and its a fresh install, just yesterday from the latest image download. Everything else works fine (Great work devs, seriously) but the n64, when I try to run a game it goes to a terminal screen, then the resolution decreases to a much smaller looking terminal screen, then it gets big again, then goes right back to the rom list for the n64. This is basicly the only problem that im having with the system right now. Everything else works pretty steller, my dad is excited. Hope this problem can be solved soon.

    #47442
    Profile photo of dirtbagx
    dirtbagx
    Participant

    In order for me to get it to work I had to replace this file:

    libmupen64plus.so.2.0.0

    in /opt/retropie/emulators/mupen64plus/test/

    I replaced it with the same file that i got from a friend, it was from an older version of retropie, it worked (games still don’t run great, but they run). I was getting a segmentation fault every time I tried to run mupen64plus.

    If you send me a message with your email, I can send you the same file.

    #50245

    tounch

    I’ve the same problem.
    Can you upload the file ?
    thx

    #62699

    Nacao

    Exact same problem here.
    I have the last version of RetroPie and a B+ pi.

    Goes to terminal screen, resolution decreases, screen is big again, and then goes back to the game list of n64.

    #64008

    ladyceleste

    I’m having the same issue! It was playing games just fine. Today I tried to load Pokémon Stadium and it loaded only for a few seconds and then it closed and went back to the ROM list. I tried to uninstall and reinstall. It did nothing. I tried re-downloading the ROM. That also did nothing. I tried loading another ROM to see if it would play. Nothing. I hope this gets fixed. I really need something to keep me entertained at work lol. Pokémon Stadium/Pokémon Stadium 2 have been keeping me occupied. I ended up uninstalling the emulator and deleting the ROMs.

    #66366

    JT Amberg

    Same thing

    #66971
    Profile photo of nekojita
    nekojita
    Participant

    Same problem, I tried with Super Mario 64, which is the most compatible ROM but it get back to the games menu when I try to launch it…

    #67070

    Arnaud

    The problem is the version of libretro so file in mupen64/test folder that doesn’t work. Someone posted the old version on a topic in this forum and that solved the problem for me. However, games are slow and the only game that sort of work is Mario 64. I guess I need to change the overclock settings but I don’t know how.

    #67076
    Profile photo of brooksyx
    brooksyx
    Participant

    Can you re attach the file for everyone in this thread?

    Also, to change OC settings type sudo raspi-config in the terminal and a settings menu will pop up with some config options, one is to change the overclock settings.

    #67078

    Arnaud

    Hi I will do it when I get home in a few hours (in France). I remember someone posted this from a dropbox like server coming from a 1.x distro.

    What do you recommend for the overclock ? I fear corrupting my SD card.

    #67080

    Arnaud

    I got it

    I hope the link still works


    Here is Link for file
    https://www.mydrive.ch
    User Name
    Xboxclassic
    Password
    AccessGranted
    only one at a time please its a free FTP server

    #67084
    Profile photo of brooksyx
    brooksyx
    Participant

    Hi I will do it when I get home in a few hours (in France). I remember someone posted this from a dropbox like server coming from a 1.x distro.

    What do you recommend for the overclock ? I fear corrupting my SD card.

    I have mine set on HIGH but I might bump it to turbo soon. I do have heatsinks on my chips and a 60mm fan blowing on top of the PI. I think corruption issues have been fixed in newer releases of raspbian. You can always make a backup image of your SD card with win32diskimager in case anything happens. I suggest starting with a medium OC and work your way up until better/desired results are achieved.

    Also, here is the Zip locally.

    #67128

    Arnaud

    Thanks, I’ll give it a shot.

    Last thing is mapping an exit button on the joypad but that’s another story.

    I wonder if I will be able to run Zelda smoothly, last time I tried It greatly lagged especially during the video sequences.

    #83072
    Profile photo of wjk0303
    wjk0303
    Participant

    Ok, after a long time – I have finally managed to fix mine.

    First you need the file that brooksyx posted. I used WINSCP to transfer the files as it is easy to use. You must replace the file in the destination “/opt/retropie/emulators/mupen64plus-rpi/test/libmupen64plus.so.2.0.0” with the file posted. Restart the PI and start up the rom.

    It will run BUT with a lot of lag. You must overclock this to speed it up. You can do this by accessing the pi command input (I don’t know what it is called.) I accesed it by pressing f4, as I am on emulation station. Type “sudo raspi-config” and scroll down to the 7th option – Overclock. Choose an overclock level then restart the pi. Start up the game and it shouldn’t lag too much.

    #83073
    Profile photo of proxycell
    proxycell
    Participant

    which other games did you get working besides mario64?

    #83075
    Profile photo of wjk0303
    wjk0303
    Participant

    I have tried Goldeneye but that went blackscreen when I launched it. I am going to test,

    1. Zelda Ocarina of Time
    2. Banjo Kazooie
    3. Mario Kart 64

    If you want any more games then just post and I will test and post back. http://blog.petrockblock.com/forums/topic/mupen64plus-testing-game-roms/
    (check that for results)

    #83119
    Profile photo of 14corman
    14corman
    Participant

    __ __ __ _ _ ____ _
    | \/ |_ _ _ __ ___ _ __ / /_ | || | | _ \| |_ _ ___
    | |\/| | | | | ‘_ \ / _ \ ‘_ \| ‘_ \| || |_| |_) | | | | / __|
    | | | | |_| | |_) | __/ | | | (_) |__ _| __/| | |_| \__ \
    |_| |_|\__,_| .__/ \___|_| |_|\___/ |_| |_| |_|\__,_|___/
    |_| http://code.google.com/p/mupen64plus/
    Mupen64Plus Console User-Interface Version 2.0.0

    UI-Console Error: dlopen(‘./libmupen64plus.so.2’) failed: ./libmupen64plus.so.2:
    UI-Console Error: AttachCoreLib() Error: failed to find Mupen64Plus Core library

    I am getting this error code every time I try and launch a game. anyone got any ideas what could be wrong?

    #83120
    Profile photo of 14corman
    14corman
    Participant

    __ __ __ _ _ ____ _
    | \/ |_ _ _ __ ___ _ __ / /_ | || | | _ \| |_ _ ___
    | |\/| | | | | ‘_ \ / _ \ ‘_ \| ‘_ \| || |_| |_) | | | | / __|
    | | | | |_| | |_) | __/ | | | (_) |__ _| __/| | |_| \__ \
    |_| |_|\__,_| .__/ \___|_| |_|\___/ |_| |_| |_|\__,_|___/
    |_| http://code.google.com/p/mupen64plus/
    Mupen64Plus Console User-Interface Version 2.0.0

    UI-Console Error: dlopen(‘./libmupen64plus.so.2’) failed: ./libmupen64plus.so.2: cannot open shared object file: No such file or directory
    UI-Console Error: AttachCoreLib() Error: failed to find Mupen64Plus Core library

    Sorry here is the full log.

    #83121
    Profile photo of 14corman
    14corman
    Participant

    ok I fixed the problem I had 2 libmupen64plus.so.2 in the test directory. Now my problem is when I try run a game it keeps coming up with audio warnings.

    #83122
    Profile photo of 14corman
    14corman
    Participant

    it stops when it hits R4300: dynamic re-compiler, or at least after that is when it forces the emulator to shut down.

    #83160
    Profile photo of wjk0303
    wjk0303
    Participant

    Perhaps you should replace your “libmupen64plus.so.2” file with another one and check if that works?

    #83363
    Profile photo of wocketpatch
    wocketpatch
    Participant

    I’m fairly new to retropie (and emulation in general) but is this considered a universal issue, by which I mean, everyone is having the same problem? I’m just wondering because if each raspberry pi is the same (or at least every B+ model, which is what I have) and my installation is basically stock (I did do update binaries), then it stands to reason that anyone else trying to run N64 rons via retropie will encounter the same problem and that there is nothing unique about my installation that is causing the issue… yeah?

    It looks like a few of you have found a workaround by downgrading libmupen64plus to an older, slower version. Has this solution been a decent one for those who have done it? Thanks

    #83368
    Profile photo of gizmo98
    gizmo98
    Participant

    The included n64 emulator of RetroPie 2.3 SD-card image seems to be broken. There are there n64 emulators at the moment. mupen64plus-rpi (deprecated), a newer mupen64plus fork from ricrpi and a mupen64plus-libretro core.

    It’s necessary to update RetroPie-Setup to build and install the newer emulators.

    Just disable emulationstation with “F4″, update RetroPie-Setup and install one emulator with RetroPie-Setup:

    Press F4
    cd RetroPie-Setup
    sudo git pull
    sudo ./retropie_setup.sh

    Select Experimental Packages

    #83392
    Profile photo of powerpoint45
    powerpoint45
    Participant

    The included n64 emulator of RetroPie 2.3 SD-card image seems to be broken. There are there n64 emulators at the moment. mupen64plus-rpi (deprecated), a newer mupen64plus fork from ricrpi and a mupen64plus-libretro core.

    It’s necessary to update RetroPie-Setup to build and install the newer emulators.

    Just disable emulationstation with “F4″, update RetroPie-Setup and install one emulator with RetroPie-Setup:
    Press F4
    cd RetroPie-Setup
    sudo git pull
    sudo ./retropie_setup.sh

    Select Experimental Packages

    Does this allow it to work through emulation station? My problem is it all works fine if I run the game via terminal but it does not start in emulationstation

    Sent from my KFARWI using Tapatalk

    #83393
    Profile photo of gizmo98
    gizmo98
    Participant

    Both can be started from emulationstation. But you can only exit mupen64plus-libretro with escape. See also –> http://blog.petrockblock.com/forums/topic/mupen64plus-ricrpi-branch/page/2/

    #83398
    Profile photo of powerpoint45
    powerpoint45
    Participant

    Both can be started from emulationstation. But you can only exit mupen64plus-libretro with escape. See also –> http://blog.petrockblock.com/forums/topic/mupen64plus-ricrpi-branch/page/2/

    OK I did get it to run via emulation station but controlling the game via keyboard does not work. Does it only work with a USB game controller? I’m ordering one so I can’t test right now.

    #83441
    Profile photo of gizmo98
    gizmo98
    Participant

    mupen64plus-libretro uses retroarch.cfg and should run with any setup keyboard or gamepad. mupen64plus (ricrpi) standalone emulator should run with any gamepad that is listed here:
    https://github.com/ricrpi/mupen64plus-input-sdl/blob/master/data/InputAutoCfg.ini

Viewing 35 posts - 1 through 35 (of 37 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar