N64 problem starting ROMs: file or directory not found

Welcome Page Forums RetroPie Project Everything else related to the RetroPie Project N64 problem starting ROMs: file or directory not found


This topic contains 12 replies, has 3 voices, and was last updated by  dizzycrosby 3 years, 4 months ago.

Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
  • #39973


    Hey guys,

    I’m new to RetroPie and at the moment I’m trying to get everything startet. I’ve got to work SNES, PSX and GBC, everything with 2 controllers, but I’m stuck with N64 now.

    When I launch a ROM, the resolution changes, but then it falls back to EmulationStation. Following line is printed in the console:
    /opt/retropie/supplementary/runcommand/runcommand.sh: line 23: ./mupen64plus: file or directory not found
    I got a German locale, so this is just my translation into English. The words could be different for people with an English locale.

    The error looks similar to the one with the Segmentation fault (same path, same line) but I guess it’s not the same.
    Could it be that I lack the file mupen64plus? Where should it be and where can I get this from? I use the 2.3-image provided here.

    Thanks for your help!



    I’ve read elsewhere that 2.3 might be the problem. I am having the same issue (new build).



    Yes, I read that there are lots of problems with mupen64 in the 2.3 build. One of them is the segmentation fault, but this can be fixed with the exchange of the libmupen64plus.so.2.0.0 file. But I don’t have this file at all in my directory, so guess there is more wrong.



    Okay, now I tried to “reinstall” mupen with the RetroPie-Setup Script. I ran the script, chose Source-based installation, and unchecked every package except the one for for mupen64. At the end of the installation the following error-message occured:
    Could not successfully compile Mupen 64 Plus RPi. See debug.log for more details.
    So there is a generel problem with the installation I guess. Which debug.log do I have to check?? Where can I find it?



    that Topic still open?

    i have the same problem :/
    i also tried to change the libmupen64plus.so.2.0.0 from an 2.2 build, but even that did not work for me :/ hope someone is soon coming upu with a solution for that, because N64 was the biggest reason to switch to RetroPI, in overall still an awesome Project. thanks for all the time and effort you guys are putting in 🙂 (reference: . )




    Topic is still open, I could not resolve the error yet!
    In the meantime I could find out how to read the log-file from the installation, but that didn’t help either. I couldn’t find any error-message at all in it…



    I’ve the same problem 🙁



    for me, the exchange of the libmupen64plus.so.2.0.0 which i could find here in the forum did not work :/
    i know you do your best and i hope with the new release or an update it will work soon.

    so long my retropie will remain in a corner of my room 😀



    where did you find the libmupen64plus.so.2.0.0 file ?




    I got it from this post

    N64: Segmentation fault



    same here, but for me it did not work :/
    maybe lack of linux skills, but the file acutally was exchanged



    Changing the libmupen64plus.so.2.0.0 file did not help me. Same issue. I can get it to run from the command line but not from Emulationstation.



    Has anyone ever tried to get M64Py to run on Raspberry Pi? It’s a Mupen64Plus frontend GUI. I played around with it on a PC. Its an easy way to see what settings work the best.


Viewing 13 posts - 1 through 13 (of 13 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

PLEASE NOTE: All orders that are placed between January 14th and January 28th will be shipped on January 29th. Dismiss