N64 Mario Kart

This topic contains 19 replies, has 4 voices, and was last updated by Profile photo of g0nz0uk g0nz0uk 1 year, 7 months ago.

Viewing 20 posts - 1 through 20 (of 20 total)
  • Author
    Posts
  • #109679
    Profile photo of g0nz0uk
    g0nz0uk
    Participant

    Hello,

    I’m just installed Retropie 3.2.1 and started Mario Kart, but the Menu is all a mess, however the text is fine, if I continue through the menus they are a mess, but the actual game runs fine.

    Super Mario 64 is fine though.

    I’m using Ir-Mupen64plus as the other can run the game.

    Any advise would be great.

    #109681
    Profile photo of herbfargus
    herbfargus
    Member

    Use gles2n64: you won’t get satisfactory results with libretro

    #109683
    Profile photo of g0nz0uk
    g0nz0uk
    Participant

    Is that using a hotkey, if so can you remind me of the keyboard command?

    #109684
    Profile photo of g0nz0uk
    g0nz0uk
    Participant

    in \\RETROPIE\configs\all\retroarch.cfg

    I see

    input_enable_hotkey = nul

    I guess I can just set this to for example space?

    #109685
    Profile photo of rdhanded2
    rdhanded2
    Participant

    when you select the game, hit x on a keyboard as it is loading and you can choose the emulator.

    #109686
    Profile photo of g0nz0uk
    g0nz0uk
    Participant

    Hmm that didn’t work, where can I set this x key please?

    #109690
    Profile photo of rdhanded2
    rdhanded2
    Participant

    when you pick a game the screen goes black and there is writing on the top. This says to hit x to make changes. That is what you need to do on a keyboard

    #109691
    Profile photo of g0nz0uk
    g0nz0uk
    Participant

    I’m not in front of it as of now, but you mean that blue config menu I think. There are 4 emulators, I think the first one is the default one called ir-mupen64, if I try the others (rice etc) it says it can’t run the rom.

    #109692
    Profile photo of rdhanded2
    rdhanded2
    Participant

    when you are in front of it try Use gles2n64. I don’t use n64 yet because of such bad playability but that is how you choose the emulator for each system.

    #109694
    Profile photo of g0nz0uk
    g0nz0uk
    Participant

    I don’t think that emulator worked when I tried it, you are talking about that menu that pops up with the blue background after hitting x?

    #109695
    Profile photo of rdhanded2
    rdhanded2
    Participant

    yes

    #109696
    Profile photo of g0nz0uk
    g0nz0uk
    Participant

    Says it can’t run the rom under that emulator.

    #109699
    Profile photo of rdhanded2
    rdhanded2
    Participant

    Have to check with someone else then, sorry

    #109726
    Profile photo of herbfargus
    herbfargus
    Member

    Update your setup script and reinstall mupen64plus binaries.

    See this page for updating:

    https://github.com/RetroPie/RetroPie-Setup/wiki/Updating-RetroPie

    And this page for info about the runcommand menu:

    https://github.com/RetroPie/RetroPie-Setup/wiki/runcommand

    #109892
    Profile photo of g0nz0uk
    g0nz0uk
    Participant

    Hi herbfargus,

    I’ve updated my Pi as per your instructions and attached are screenshots

    Attachments:
    1. screenshots.zip
    #109900
    Profile photo of gizmo98
    gizmo98
    Participant

    I don’t know if mupen64plus “standalone” supports zip files. Please unzip file and report again.

    #109909
    Profile photo of g0nz0uk
    g0nz0uk
    Participant

    Yes! wow as simple s that thanks so much.

    One thing is the controls don’t work, well the joystick does but not all buttons, I can’t seem to bring up the retroarch menu to configure the input controls, any ideas?

    #109917
    Profile photo of herbfargus
    herbfargus
    Member

    It’s not a retroarch emulator so there is no rgui.

    Read the documentation

    https://github.com/RetroPie/RetroPie-Setup/wiki/Nintendo-64

    #109949
    Profile photo of herbfargus
    herbfargus
    Member

    See this post as it explains it very clearly

    Change controller config for specific system in Retropie 3.2.1

    #109961
    Profile photo of g0nz0uk
    g0nz0uk
    Participant

    Fixed and doesn’t mario kart 64 run well too!

Viewing 20 posts - 1 through 20 (of 20 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar