N64 Issues

This topic contains 10 replies, has 5 voices, and was last updated by Profile photo of dankcushions dankcushions 1 year, 8 months ago.

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #107192
    Profile photo of deadherring
    deadherring
    Participant

    Hi all,

    I’m running retropie 3.0 on a raspberry pi 2 in an arcade cabinet setup. I originally had issues with SNES games not loading, but fixed that by downloading the updated emulator from the menu.

    Now, I’m having issues with N64 games. Many (like NFL Blitz) load with messed up menus and audio, others load to the opening screen then go to black (like Mario Tennis). I’ve tried updating to the latest emulators, then when the game loaded I pressed a button and switched the n64 emulator to a different one (I beleive n64 emu plus?) but now nfl blitz loads to the open screen and freezes and I have to unplug power to reboot. Also, some have suggested moving the roms from the n64 folder to the N64-mupen64plus folder, but I only have an n64 folder in my roms folder.

    I tried downloading the experimental version but I’m having the same experience, although I don’t know if you have to change to the experimental emulator by pressing a key when I load the game–now pressing a key when the game is loading doesn’t seem to bring up the emulator select anymore. Is there a different way to do this on the system? Do I need to select the experimental emulator to load n64 games?

    I’ve read that there are issues running n64 on the pi2 but I’ve also seen videos on youtube of people running n64 games flawlessly.

    Any help is appreciated.

    Nathan

    #107193
    Profile photo of deadherring
    deadherring
    Participant

    Also, I should add that when I am booting using the n64mupenplus emulator I noticed it mentions an audio buffer under run error, not sure if it’s related.

    Thanks,

    Nathan

    #107219
    Profile photo of dankcushions
    dankcushions
    Participant

    there’s 2 main n64 emulators – the default: lr-mupen64plus, is outdated and seems to have many issues. the second: mupen64plus is better for me. are you using that one?

    also, mupen64plus has two renderer plugins: rice and gles. the latter is normally the best, but the former can sometimes be better.

    finally, n64 emulation is pretty flakey on the pi. some games work nearly perfectly, but others are a mess, or don’t work at all. there might not be a solution for playing some games.

    you can check to see if anyone’s tested these games, and what setup to use here: https://docs.google.com/spreadsheets/d/1Wjzbu90l6eCEW1w6ar9NtfyDBQrSPILQL5MbRSpYSzw/edit?usp=sharing

    #107235
    Profile photo of mikpj
    mikpj
    Participant

    I have the same problem.

    New here.

    I dont have the mupen folders installed.

    I will search the forum a little

    #107236
    Profile photo of herbfargus
    herbfargus
    Member

    There is only one n64 folder- read the wiki:

    https://github.com/RetroPie/RetroPie-Setup/wiki/Nintendo-64

    There used to be separate folders but now emulators can be switched dynamically with the runcommand menu as mentioned above.

    #107237
    Profile photo of herbfargus
    herbfargus
    Member

    I added a wiki page to eliminate any confusion:

    https://github.com/RetroPie/RetroPie-Setup/wiki/runcommand

    #107281
    Profile photo of deadherring
    deadherring
    Participant

    Thanks for the info. I’ve tried both emulators as well as the experimental ones. I’m just confused about why some on youtube seem to be able to run many of the games without issues?

    Is supporting n64 games something that could be addressed with future software updates or is it a limitation of the hardware?

    Thanks,

    Nathan

    #107285
    Profile photo of herbfargus
    herbfargus
    Member

    its a limitation of the hardware. ive never got satisfactory results on my rpi. it takes a lot of tweaking to get things barely functional but it just depends on the game and the settings. i usually just stick with the pc for n64 emulation. some people have also overclocked to get it to work.

    #107334
    Profile photo of gizmo98
    gizmo98
    Participant

    Try the experimental mupen64plus-testing emulator. After installation select experimental emulator at game start. Press x or m and select mupen64plus-testing-rice.

    @deadherring
    There is “no plugin for all games”. Some games run flawless with rice, some with gles2n64. Gles2n64 is most of the time faster but there are major stability issues with games like zelda OoT. Some games are not playable at all.

    #107563
    Profile photo of deadherring
    deadherring
    Participant

    Thanks, I tried that, it works for some of the games! For some games (for example, NFL Blitz) they now open, but it says press start and none of the buttons seems to work to start the game.

    Is there a special configuration I need to do in terms of buttons for the n64? According to the wiki,n64 uses retroarch?

    I am using the xarcade joystick and buttons, here is my retroarch:

    input_player1_a = z
    input_player1_b = shift
    input_player1_y = ctrl
    input_player1_x = alt
    input_player1_start = num5
    input_player1_select = c
    input_player1_l = space
    input_player1_r = x
    input_player1_left = left
    input_player1_right = right
    input_player1_up = up
    input_player1_down = down
    # input_player1_l2 =
    # input_player1_r2 =
    # input_player1_l3 =
    # input_player1_r3 =

    input_player2_a = e
    input_player2_b = w
    input_player2_y = q
    input_player2_x = s
    input_player2_start = num6
    input_player2_select = ]
    input_player2_l = a
    input_player2_r = [
    input_player2_left = d
    input_player2_right = g
    input_player2_up = r
    input_player2_down = f

    Also, I noticed some of the games don’t recognize a 2nd player–for example, mario tennis. Is there anything I can do about that?

    Thanks,

    Nathan

    #107571
    Profile photo of dankcushions
    dankcushions
    Participant

    mupen64plus-testing is not retroarch, only lr-mupen64plus is (lr = libretro = retroarch)

    the control settings you need are located:

    /opt/retropie/configs/n64/mupen64plus.cfg
    and
    /opt/retropie/configs/n64/InputAutoCfg.ini

Viewing 11 posts - 1 through 11 (of 11 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar