N64 Emulator Problems after Image 3.0

Welcome Page Forums RetroPie Project Everything else related to the RetroPie Project N64 Emulator Problems after Image 3.0

This topic contains 3 replies, has 4 voices, and was last updated by  muriani 2 years, 7 months ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
  • #93258


    Hola! I was running Retropie 2.6, and decided to upgrade to the beta image. I flashed a fresh image onto my sd card and decided to start from the ground up in reconfiguring my setup. I’ve run into a slew of problems, and was hoping for some help.
    1) I have 2 Retrolink N64 controllers which used to work flawlessly, and now the button mapping is all screwed up. I can’t find the source of their errors.
    2) I can’t exit the emulator anymore, where do I write the exit emulator line?
    3) Some games, like Mario kart 64 for example, bug out hardcore. The Nintendo logo renders fine, the sound works, but the graphics past that are all distorted and unviewable. It worked like a champ in 2.6 with the experimental package running.
    4) My GBA emulator won’t run anymore. I’ve placed the BIOS both in the BIOS folder, and at the gpsp location (which is no longer the Gba_bios.bin home?) but the games will start and then return to Emulation station after a few seconds. This also worked pre-3.0.

    Any help in this matter is greatly appreciated! Thanks in advance!



    1) I had the same issue with my controllers. All the button configs were messed up. Turns out the system detected my controller and used a predefined config file for it. Problem was solved editing retroarch.cfg and changing “input_autodetect_enable = true” to false. Other solution is simply removing the config file that the system is autodetecting ( /opt/retropie/emulators/retroarch/configs). Don’t know if it’s the problem you’re having, but it’s worth a try.

    2) If the solution above worked, it should fix that issue as well. The predefined config file had rewritten the exit emulator buttons (in my case ESC key didn’t work).

    3) Also tried Maro Kart 64 and I didn’t have any of the issues you had (using default emulator) and not configuring anything else

    4) With 3.0 GBA emulator works fine for me (default emulator, not onfiguring anything). I just put the gba_bios.bin in home/pi/RetrOpie/BIOS and nothing more.
    3 and 4 are not solutions, but just to let you know how it was for me.



    When you choose a game press x or m before the game starts and choose a different plug-in. I think the rice and gles get the control configuration from the .ini file that has the retrolink controllers already pre configured.

    if you choose the -lb one then you would need to edit the retroarch.cfg file.



    I’ve got the same issue with Mario Kart and some other games that display 2D graphics (paper mario, tetrisphere, etc)
    It’s just completely garbled, like the texture offset is wrong when it’s reading.

Viewing 4 posts - 1 through 4 (of 4 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/