N64 Audio and Visual Problems

This topic contains 2 replies, has 2 voices, and was last updated by Profile photo of sparklydeath sparklydeath 2 years, 1 month ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #98255
    Profile photo of sparklydeath
    sparklydeath
    Participant

    I just started running N64 games on my Raspberry Pi 2 RetroPie. They run alright, kind of. Except, when for instance I run Windwaker or Mario Kart the audio continually skips. The music just cuts out over and over, and the sound effects are really distorted. Also, in the mario kart 64 menus all of the text and images are distorted and blurred to the point that you can’t read them. Finally, when I run something like pokemon snap there are all sorts of weird rendering problems. Any ideas or tweaks on how to fix that? I’ve already tried multiple roms. Thanks!

    #98410
    Profile photo of link2803
    link2803
    Participant

    No faces on characters in SSB, unreadable text in Banjo-Kazooie, stuttering images in Mario Kart… the list goes on. For some reason, N64 emulation has never really be cracked and there will always be small glitches with N64 roms that just come as part of the emulation experience 😉

    That said, audio glitches can normally be improved by overclocking the CPU or increasing the video memory allocated.

    P.S. Windwaker on the N64? Thought that was a Gamecube release?

    #98446
    Profile photo of sparklydeath
    sparklydeath
    Participant

    Thanks so much. I might start another topic for this, but I figured I might as well ask you: What are the risks of overclocking the CPU, and how does one go about allocating more video memory?
    Thanks again.

    PS. Silly me. I meant ocarina of time.

Viewing 3 posts - 1 through 3 (of 3 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar