My first Pi project: a noob discovers Retropie

Welcome Page Forums RetroPie Project Everything else related to the RetroPie Project My first Pi project: a noob discovers Retropie

This topic contains 3 replies, has 2 voices, and was last updated by Profile photo of sselph sselph 2 years, 4 months ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #88969
    Profile photo of dobbie
    dobbie
    Participant

    I feel I must preface this post: This is more of an experience dissertation that I had through the process of creating an emulator using RetroPie, and I would NOT consider myself on the same technical level as MOST people that can help you solve problems in this forum. I am sure I will have screwed up semantics, codex, and actual cause/effect of the OS, applications and system configurations below. In any case, do not use this as a post to help fix your problem….instead think of it as an advocacy that even a noob can have an emulator working in just a few days.

    Spent Money On:
    Raspberry Pi 2 Model B
    iPazzport keypad

    Found laying around the house:
    MicroSD Class Four 4GB
    HDMI Cable
    Vendor Swag thumb drive

    I started with the newest retropie image and was having some initial issues getting it to load on my 16GB micro SD. After research (on this site) I found the card was class 2 (yuck) and a class 4+ is required. So I “upgraded” to a class 4, 4GB microSD card and it loaded.

    I followed directions to expand the memory, and since I was going to be using a MadCatz xbox controller I got the xbox drivers, and set them up based on some forum suggestions (from this site). I went ahead and setup locale info and all the other settings in the raspi-config.

    I started simply, and registered an account with a website that seemed to have the lowest “virus threat” from other ROM sites. I threw the thumb in the pi, booted up, and emulation station found a game. I went to play it and none of the controls were working.

    After researching some forums (here), I went through the RetroArch configuration, and now emulation station was detecting two controller profiles. I went back into the driver code for the xbox, and deleted the one that looked “less complex” and rebooted. It worked!

    I played my first game and thought, I used to be way better at this game. Didn’t think much of it, so I then loaded up some other NES games. It was when playing a twitch-fest boxing game that I found that there was some latency from when I pushed the button to when it appeared on screen.

    This happens apparently with HD TV’s heavy hz, 1080p and you have to set the TV to game mode. I setup my HDMI 4 input to default to game mode (and did the same for my Xbox, which I hadn’t noticed any latency with…weird) and got to Soda Popinski. I was happier.

    I am still not liking the xbox controller though for NES, so I’m going to see about getting some old controllers online. I feel like the D-pad on the 360 is superior in function for NES (than the stick), but poorly placed on the controller.

    I then had to work on getting Sega going. I was having some major issues getting the .smd files in the right folder (they don’t go in the ‘genesis’ folder they go in ‘megadrive’, DUH!). But I still couldn’t get them going. I did research and nothing was helping. I looked at the file and there was some parenthesis and brackets in the filename and thought….I wonder if I simplify the names if that will fix it. BAM – next thing I know I’m playing Star Control.

    Next on my list of things to do with the project is to test out Star Fox and see if the Pi 2 model B fixes issues others were having with choppy play on ‘FX’ games. If it’s choppy, I will overclock and see if that fixes it. If it does, I’ll shove some heat sinks on the chips (more for show and fun than function). Alternately, I plan to buy a 32GB class 10 microSD and see if that helps with choppiness more than overclocking. It will certainly help with storage issues.

    I have read about the scripts you can shove in your directory to auto-scrape images and metadata for the ROMS and emulation station. This would include using a tool like Filezilla so I’ll probably wait and do that AFTER I upgrade the SD card.

    Either way, I wanted to thank the community and the creator for all the fun. This project has kick-started a new hobby of “making” junk and stuff. I got my daughter hooked now as well, and she is saving her money up for her first project.

    Thanks

    #88996
    Profile photo of sselph
    sselph
    Participant

    Great to see you got everything working, that is half the fun. Well more than half the fun for me since I end up writing more code to make it “quicker” to setup and maintain my retropie than I do actually playing.

    I write the script that does the scraping. An easier method that doesn’t involve filezilla is probably to just download it directly to the pi. This will get the current version for the rpi2 and extract it to the path.

    $ wget https://github.com/sselph/scraper/releases/download/v0.6.3-beta/scraper_rpi2.zip
    $ sudo unzip scraper_rpi2.zip scraper -d /usr/local/bin/

    Then you can just cd to the rom folder and run scraper:

    $ cd ~/RetroPie/roms/snes
    $ scraper -thumb_only

    Auto-scraper: https://github.com/sselph/scraper

    #89056
    Profile photo of dobbie
    dobbie
    Participant

    Super. I’ll give that a go. You are hashing the local ROMs and finding a match, then?

    #89069
    Profile photo of sselph
    sselph
    Participant

    Basically. I sha1 hash the local rom data after extracting it from the rom files. Not as simple as a hash of the entire file for some systems like nes which has headers and megadrive/n64 which have byte swapping going on. That hash is looked up in a csv I maintain of hash to ID in thegamesdb.

    Auto-scraper: https://github.com/sselph/scraper

Viewing 4 posts - 1 through 4 (of 4 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar