Mupen64plus rpi2 audio buffer under run error

Welcome Page Forums RetroPie Project Everything else related to the RetroPie Project Mupen64plus rpi2 audio buffer under run error

This topic contains 10 replies, has 6 voices, and was last updated by Profile photo of shadowfox7x shadowfox7x 1 year, 8 months ago.

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #87944
    Profile photo of rednas32
    rednas32
    Participant

    Hey all,

    I can’t get the Mupen64plus emulator to work. Everytime I try to load a rom it says the following:

    audio warning: audio buffer under run(0)
    audio warning: audio buffer under run(1)

    And the emulator freezes.

    I can still inject a reboot command through SSH but the keyboard and controller are both unresponsive at this point.
    I am using the latest 2.6 image for the rpi2 with a clean install, overclockt to pi2 settings and the memory split is at 192.

    Tried using older builds and differences in the memory split but nothing seems to work.

    Have tried different setting for the audio plugin but just can’t get it to work.

    When I change the config for Mupen64plus to run rice as a video plugin(so not changing anything about the audio plugin) the game does run and i have sound, but some screens don’t show. For example: playing zelda, MM or OoT, the start menu doesn’t show and the screen freezes. At this point I actually am in the start menu since i can hear the sounds in there, and when i exit the start menu the game continues like normal.

    Do you guys have a fix for either of these problems so i can play these wonderfull games again?

    Tnx!

    #87946
    Profile photo of Roo
    Roo
    Participant

    Not all games are working. I am able to play Super Mario 64 and Mario Kart 64 perfectly with both stock 2.5.0 and 2.6.0 images. 007 works too, but has slowdowns. Zelda games don’t work. That’s all I’ve tested so far.

    I know Floob has some videos about playing with the different video plugins, but I haven’t done any testing with that yet. The way I look at it, I’ll just wait for a better optimized build of RetroPie – I got enough other stuff to mess with that I’m not interested in tweaking Mupen64 settings.

    I have my Pi 2 set to “Pi2” overclock with a memory split of 384.

    #87953
    Profile photo of gizmo98
    gizmo98
    Participant

    Zelda is working with rice plugin if ScreenUpdateSetting=5 (/opt/retropie/configs/n64/mupen64plus.cfg). But it is slow.

    #95725
    Profile photo of phrazelle
    phrazelle
    Participant

    I’m having the same issue with the Buffer Underrun errors, but getting (0), (1) and (2). The system works, buttons are mapped correctly, just no audio.

    I am running audio through this USB device (http://www.adafruit.com/products/1475) using this tutorial (https://learn.adafruit.com/usb-audio-cards-with-a-raspberry-pi/updating-alsa-config) without issue on everything except for Mupen64Plus.

    My guess is that the OUTPUT_PORT setting in mupen64plus.cfg is trying to send the audio through either the HDMI or the 3.5mm jack and not through the USB.

    Thoughts?

    #95860
    Profile photo of algi
    algi
    Participant

    Did we get anywhere with this ??

    I can’t for the life of me get some games to work properly because of this Audio Warning: Audio Buffer under run(1-infinity) error..

    Should be doable..

    #107069
    Profile photo of shadowfox7x
    shadowfox7x
    Participant

    I am running into the exact same issue of audio warning: audio buffer under run. Did anyone find a plugin or a setting to fix this in the config?

    #107076
    Profile photo of gizmo98
    gizmo98
    Participant

    Increase audio output buffer size. (mupen64plus.cfg)

    #107136
    Profile photo of shadowfox7x
    shadowfox7x
    Participant

    I messed with audio latency and the output buffer size. at 4096 and 300ms its decent but still choppy audio at times and when I close out I still get the same audio warning.

    Also I have a slight shader issue. When playing Diddy Kong Racing it has a darker glow around my character on the ground. I looked through all the config settings and dont see anything. Is there an optimized config I can compare with and confirm i’m in the optimal settings. (i’m using rpi2)

    #107750
    Profile photo of shadowfox7x
    shadowfox7x
    Participant

    I did the upgrade to 3.1, now N64 games are basically unplayable with the installed emulators. The sound is worse than before. I did a binary reinstall of the emulators and still have major issues. I did try the beta versions as well and continue to see sound problems. I’ll wait for some updated emulators for N64 down the road in hopes of this being corrected.

    #107767
    Profile photo of gizmo98
    gizmo98
    Participant

    Please update your retropie-setup script and install mupen64plus from source. For best performance use RPI2 Overclocking, VGA resolution and a good power supply.

    #107807
    Profile photo of shadowfox7x
    shadowfox7x
    Participant

    I did an overclock to 1000 and increased the sdram_freq=450 core_freq=450. I did not include an overvolt as i’ve had issues with that before. After all that I did a Mupen64Plus from source install and now the games are playable again. I still see audio issues but no where near where they were before. Thanks everyone for the ideas and help.

Viewing 11 posts - 1 through 11 (of 11 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar