Mupen64plus (ricrpi branch)

Welcome Page Forums RetroPie Project Ideas for Further Enhancements Mupen64plus (ricrpi branch)

This topic contains 124 replies, has 32 voices, and was last updated by  puck6t9 2 years, 6 months ago.

Viewing 35 posts - 71 through 105 (of 125 total)
  • Author
  • #88951



    I saw that you had a pull request for the vanilla Mupen to test.
    What happened with that?

    Reason i ask is because i recently started to test out some games and mess with the rice settings but i dont want to get some progress with the testing and then the core changes.

    Should i just keep testing or should i wait till the core gets updated?



    I will it push later again.



    I just saw it merged. Awesome!
    Do i just sudo ./ update the script then download the experimental version of it?



    That is all you need to do. I need to test more games to maintain rom specific settings here:

    If you have good working for any game please tell me. I will add these settings.



    I was looking at that earlier.

    Why don’t you make the ScreenUpdateSetting = 7 as default since it fixes lots of games.

    I’m currently testing it out with that as the default then changing them.

    It’ll clear up the .ini file too.



    I will definitely keep you updated.



    The below settings were used for banjo kazooie in the below video. I use these settings globally with gles2rice, and have had a lot of games run just fine that way, though gles2n64 still feels more responsive, so I use it when I can. Games which also use the below rice settings on my system include Mario Kart 64 (for multiplayer), Banjo Tooie, Paper Mario, Perfect Dark, Castlevania, OOT, Majora’s Mask, Pilotwings 64, and Mario Tennis.

    When gles2n64 was used (Mario Kart 64, Super Mario 64) in the below video, the default config was used.

    Click here for video

    # Frame Buffer Emulation (0=ROM default, 1=disable)
    FrameBufferSetting = 0
    # Frequency to write back the frame buffer (0=every frame, 1=every other frame, etc)
    FrameBufferWriteBackControl = 1
    # Render-to-texture emulation (0=none, 1=ignore, 2=normal, 3=write back, 4=write back and reload)
    RenderToTexture = 0
    # Control when the screen will be updated (0=ROM default, 1=VI origin update, 2=VI origin change, 3=CI change, 4=first CI change, 5=first primitive draw, 6=before screen clear, 7=after screen drawn)
    ScreenUpdateSetting = 7
    # Force to use normal alpha blender
    NormalAlphaBlender = False
    # Use a faster algorithm to speed up texture loading and CRC computation
    FastTextureLoading = False
    # Use different texture coordinate clamping code
    AccurateTextureMapping = True
    # Force emulated frame buffers to be in N64 native resolution
    InN64Resolution = False
    # Try to reduce Video RAM usage (should never be used)
    SaveVRAM = False
    # Enable this option to have better render-to-texture quality
    DoubleSizeForSmallTxtrBuf = False
    # Force to use normal color combiner
    DefaultCombinerDisable = False
    # Enable game-specific settings from INI file
    EnableHacks = True
    # If enabled, graphics will be drawn in WinFrame mode instead of solid and texture mode
    WinFrameMode = False
    # N64 Texture Memory Full Emulation (may fix some games, may break others)
    FullTMEMEmulation = False
    # Enable vertex clipper for fog operations
    OpenGLVertexClipper = False
    # Enable/Disable SSE optimizations for capable CPUs
    EnableSSE = False
    # Use GPU vertex shader
    EnableVertexShader = True
    # If this option is enabled, the plugin will skip every other frame
    SkipFrame = False
    # If this option is enabled, the plugin will only draw every other screen update
    SkipScreenUpdate = True
    # If enabled, texture enhancement will be done only for TxtRect ucode
    TexRectOnly = False
    # If enabled, texture enhancement will be done only for textures width+height<=128
    SmallTextureOnly = False
    # Select hi-resolution textures based only on the CRC and ignore format+size information (Glide64 compatibility)
    LoadHiResCRCOnly = True
    # Enable hi-resolution texture file loading
    LoadHiResTextures = False
    # Enable texture dumping
    DumpTexturesToFiles = False
    # Display On-screen FPS
    ShowFPS = True
    # Use Mipmapping? 0=no, 1=nearest, 2=bilinear, 3=trilinear
    Mipmapping = 2
    # Enable, Disable or Force fog generation (0=Disable, 1=Enable n64 choose, 2=Force Fog)
    FogMethod = 0
    # Force to use texture filtering or not (0=auto: n64 choose, 1=force no filtering, 2=force filtering)
    ForceTextureFilter = 2
    # Primary texture enhancement filter (0=None, 1=2X, 2=2XSAI, 3=HQ2X, 4=LQ2X, 5=HQ4X, 6=Sharpen, 7=Sharpen More, 8=External, 9=Mirrored)
    TextureEnhancement = 6
    # Secondary texture enhancement filter (0 = none, 1-4 = filtered)
    TextureEnhancementControl = 0
    # Color bit depth to use for textures (0=default, 1=32 bits, 2=16 bits)
    TextureQuality = 0
    # Z-buffer depth (only 16 or 32)
    OpenGLDepthBufferSetting = 32
    # Enable/Disable MultiSampling (0=off, 2,4,8,16=quality)
    MultiSampling = 0
    # Color bit depth for rendering window (0=32 bits, 1=16 bits)
    ColorQuality = 0
    # OpenGL level to support (0=auto, 1=OGL_1.1, 2=OGL_1.2, 3=OGL_1.3, 4=OGL_1.4, 5=OGL_1.4_V2, 6=OGL_TNT2, 7=NVIDIA_OGL, 8=OGL_FRAGMENT_PROGRAM)
    OpenGLRenderSetting = 0
    # Enable/Disable Anisotropic Filtering for Mipmapping (0=no filtering, 2-16=quality). This is uneffective if Mipmapping is 0. If the given value is to high to be supported by your graphic card, the value will
    be the highest value your graphic card can support. Better result with Trilinear filtering
    AnisotropicFiltering = 0


    Gles2n64 needs some loving and i haven’t enabled default ScreenUpdateSetting=7 because Mario64 had some glitchs.

    I have already added all other settings.

    Edit: don’t use DepthBuffer=32 or there will be a create context error with the latest builds.



    Thanks, @gizmo98

    Note that without ScreenUpdateSetting=7 I can’t get two player to work in mario kart 64. So I guess for me getting that to work was the bigger priority since I just use the other plugin for mario 64.



    I can add mk64 with ScreenUpdateSettings=7 in RiceVideoLinux.ini. RiceVideoLinux.ini overrides global settings.



    If i need to add a game onto the RiceVideoLinux.ini do i just add the ROM # inside new “{ROM # Here}” then make up a relevant name for it under that for the “name” description?

    Im guessing you can get the Rom # from the black screen before the game loads right?

    Does the name of the game matter in the way i name them as opposed to using Lower or Upper case letters?



    If you start a game once it will be added to RiceVideoConfig.ini. Then you can add game specific settings there.



    MK64 splitscreen should work now with gles2n64. Recompile and try again.



    @gizmo98 – Nice, can’t wait to try this! Thank you!

    Edit: can you walk me through enabling neon optimizations while using the packages (as opposed to setup) script?



    If you use a pi2 and RetroPie-Setup neon optimizations are enabled default.



    Ok, thanks. I’m still on 2.5, so do I just update the setup script from within the setup script, or do a pull, or is that step not even necessary?



    Update the setup script and do a source based installation of mupen64plus or a experimental of mupen64plus-testing.



    Has anyone found a way to enable a hotkey for exiting the the emulator?



    Has anyone found a way to enable a hotkey for exiting the the emulator?

    Anyone? The testing one in setup is a lot better on rpi2



    The only way to exit is by assigning one button only.
    It doesn’t support hot keys at the moment.
    I have it setup to exit using the “L” Button since its hardly used on games and if it is used it is usually mimicking the “R” Button.



    I use the select button myself.



    Just to clarify. At least mupen64plus-testing supports a joypad exit button. Open /opt/retropie/configs/n64/mupen64plus.cfg and add your joypad. If you have a PS3 controller the assignement for the PS button is for example “J0B16” (Joystick 0, Button 16).



    Bueller? Anyone?




    I’m having some trouble with my audio, and was wondering if anyone had any advice. I can confirm that it is the emulator, as my others (SNES, GBA, GB, GBC etc.) all sound fine. I have the experimental package of mupen64plus, and the emulators run at full speed, with no hiccups, but my Mario Kart 64 for example has wonky sound. It’s not the only rom with broken up sound. Anything under mupen64plus.cfg that i can modify to correct that?
    Turns out it was a power problem, my pi wasn’t getting enough power, and the sound was going awry.



    Update: If you set 1080p now gles2n64 keeps aspect now. There is also a video stretch option now.



    Is there any way to put those emulators together? I haven’t tried them yet, but I’m not quite satisfied with the thought that I have two N64 Emulators in my Emulationstation just to start different games. It’s just not so pretty if you know what I mean. 😀



    Technically it’s one emulator with 2 different plugins but I know what you mean. I envision some way to add into the main mupen64plus config file a list of roms and which plugin each uses.



    There are already thoughts getting rid of the multiple rom folder mess. But the main target of the last weeks was get all emus running on a rpi2.




    I have an rpi2 with retropie 2.6. I just installed the experimental mupen64plus-testing and am having issues with games using the n64-gles2n64 directory. I have tried Super Mario 64 and Mario Kart 64 and so far both come up with only black screens but still have sound. Are there any settings I can modify in order to fix this issue? Thank you for your time.



    Is your RetroPie-Setup script up to date?



    Yes sir, I updated the script yesterday afternoon.



    Don’t know. Can you tell me your screen resolution? You could also disable fullscreen and enable stretch under /opt/retropie/configs/n64/gles2n64.cfg.



    Thanks, gizmo98! That worked. So I disabled fullscreen and enabled stretch…then it started working again! I’m currently working at the default resolution on my 720p TV…so I’m not sure if that created an issue. Either way, I appreciate you taking the time to help. 🙂



    Please also test fullscreen on and stretch on. I need to know if the use screen resolution or keep aspect ratio function is broken.




    every time i try to start a rom from within gles2n64, gles2rice and glide64mk2 i got the following error:
    UI-Console Error: Specified Video plugin not found:

    i set up the emulationstation the retropie setup from github, from binary, but in the setup the muppen64plus-testing from source..

    can u please help me?

Viewing 35 posts - 71 through 105 (of 125 total)

Forums are currently read only - please visit the new RetroPie forums at