Mupen64plus load save state exits to ES

Home Forums RetroPie Project Everything else related to the RetroPie Project Mupen64plus load save state exits to ES

This topic contains 8 replies, has 5 voices, and was last updated by Profile photo of zogzoghakita zogzoghakita 1 year, 7 months ago.

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #89314
    Profile photo of joelones
    joelones
    Participant

    Hi,

    Great project!
    I’ve configured mupen64plus and it seems to work fine however, I’m struggling to get the load save state working.

    I can confirm that the save state shortcut does indeed create a file in ~/.local. When I attempt to load the saved state I see mupen64plus restart itself and then exit back to ES.

    I think I notice an error, “Bus error…” but I can’t be sure ’cause it’s there for a split second and then quits to ES. Not sure where the log is for mupen64plus…

    I’m using the retro 2.6 img for RPi2.

    Thanks

    #89556
    Profile photo of cakelol
    cakelol
    Participant

    I experience the same issue. All I could see as well was some sort of Bus error.
    Also on 2.6 IMG on the Pi 2. Saving appears to work fine – I don’t see any message about it ingame, but I see the files that are created (in my case on a mounted NFS share so I can continue to play in another room on another device).

    I was thinking about permissions of the savestates…but they are fine imo.

    #89576
    Profile photo of joelones
    joelones
    Participant

    Thanks for the reply, at least I know it’s not only me.

    Hopefully someone will post a solution.

    #89851
    Profile photo of cakelol
    cakelol
    Participant

    Hey mate,
    I just succeeded in this problem.
    I just made a complete binary update yesterday and, after completely reconfiguring my controllers for mupen64plus, I can now successfully save and load. Maybe give that a try. Takes a few hours, but totally worth it.
    Oh, and maybe back up your mupen64 .cfg and input-file before you do that.

    #89952
    Profile photo of joelones
    joelones
    Participant

    Thanks for the reply, going to do a binary update and hopefully fixes it for me as well.

    Edit: seems like I still get the same bus error ;(

    The error seems to be coming from”

    /opt/retropie/supplementary/runcommand/runcommand.sh Bus Error

    #90075
    Profile photo of joelones
    joelones
    Participant

    Thoughts?

    #92410
    Profile photo of trumad
    trumad
    Participant

    I’m also struggling with this. Let us know if there’s any solution!

    #94374
    Profile photo of robofruit
    robofruit
    Participant

    I am having this problem too, tried a binary install and it didn’t help :o(

    Hate the game not the player !

    #109364
    Profile photo of zogzoghakita
    zogzoghakita
    Participant

    Did anyone found a way to load state with Mupen64plus ?

    Emulator also crashes on my side (Retropie 3.1) when trying to load state (by pressing F7 for instance)

Viewing 9 posts - 1 through 9 (of 9 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar