Multiple controllers problem (?)

This topic contains 3 replies, has 2 voices, and was last updated by  herbfargus 2 years, 9 months ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #92843

    jolny
    Participant

    Hey people!
    I’ve had this strange problem on two different setups now.
    One RPi2 with 2x iBuffalo Famicom-style controllers, and one RPi (B) with 2x noname SNES style controllers. In both cases, USB.
    I configured one of them with “Register RetroArch controller” from RetroPie-Setup so I presume they’re configured automatically.

    What happens is the second controller won’t work in some games unless I hold down a button on the first controller. Both controllers worked fine with Chip n’ Dale for NES, and TMNT tournament fighters for SNES, but not on Donkey Kong Country.

    Has anyone experienced this? How do I fix it? Would manual controller setup fix it? :O 🙂

    #92889

    herbfargus
    Member

    if you are using the default snes emulator (pocketsnes) for retropie 2.6 it has known issues with multiplayer games. try a different emulator such as snes9x-next

    #92892

    jolny
    Participant

    Never mind me, browsed the “controller” posts for a while and found this:

    Multiple Controller issues in certain SNES games

    Works fine with pisnes.
    But are the button configuration separate for it? Maybe it’s just me but som of the buttons seem off.

    #92898

    herbfargus
    Member

    snes9x.cfg in the folder opt/retropie/emulators/pisnes

Viewing 4 posts - 1 through 4 (of 4 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

PLEASE NOTE: All orders that are placed between January 14th and January 28th will be shipped on January 29th. Dismiss