Multiple 8bitdo Bluetooth Controllers

Welcome Page Forums RetroPie Project Controller Configuration in RetroPie Multiple 8bitdo Bluetooth Controllers

This topic contains 5 replies, has 2 voices, and was last updated by Profile photo of bryansbusiness bryansbusiness 1 year, 11 months ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #98306
    Profile photo of nablametal
    nablametal
    Participant

    After several hours to work out this issue, I post here hoping someone will help me :

    I have an issue with my controllers on retropie 2.6 : once the two gamepads are paired and fully recognized by the emulationstation main menu, when I launch playsation roms, the first gamepad is controlling both player 1 and player 2 and the second is’nt controlling anything…

    Maybe you can help me on this.

    My controllers are 8bitdo NES30 bluetooth controllers (connected with bluetooth)

    When the rom stars I get the little message :
    Joypad #0 “Bluetooth Gamepad” succesfully configured
    and then the same thing for Joypad #1

    Any clue ?

    Thanks,

    NablaMetal

    #102630
    Profile photo of bryansbusiness
    bryansbusiness
    Participant

    Did you ever get help with this? I have an RPI 2 with v3.x Beta. I have gotten as far as manually connecting both controllers but am having issues with the second controller.

    1. I have the first controller set up and working thanks to this post: http://forum.8bitdo.com/thread-328-1-1.html
    2. I can manually connect (via bluez-) the second controller but have to run the same command every time I restart retropie or that controller
    3. I cannot seem to be able to configure input for the second controller. The above post says it should act the same but it does not.

    Any help would be appreciated. I feel I’m so close!

    #102634
    Profile photo of nablametal
    nablametal
    Participant

    Yes I managed to get it work some months ago.

    I do not use bluez. I managed to get it work on retropie 2.6, don’t know for 3.x but I think it work the same way.

    I don’t remember eveything I did exactly but be sure to :
    – Get you controllers firmware up to date (important)
    – Configure correctly your retroarch.cfg (in the general conficg section or in the specific emulator depending what you want)
    – Start your controllers with Start + R buttons (if not the mapping is different)
    – I do not use the configuration tool of emulationstation.

    I found a post very useful on the web, I hope you understand french or you know how to use google.translate :

    http://www.open-consoles-news.com/2014/10/raspberry-pi-realiser-une-retro-gaming.html

    Tell me if you’re still stuck I will take a look at my specific conf files.

    NablaMetal

    #102635
    Profile photo of bryansbusiness
    bryansbusiness
    Participant

    I could not find btService for one. Did you use that?

    #102637
    Profile photo of nablametal
    nablametal
    Participant

    Nope I don’t think. Only hcitools and hidd.

    #102664
    Profile photo of bryansbusiness
    bryansbusiness
    Participant

    OK, I did get as far as properly configuring the controllers. See my notes in this post: http://forum.8bitdo.com/forum.php?mod=viewthread&tid=328&page=4&extra=#pid1694

    …but still having connectivity issues with the P2 controller. Any help would be appreciated.

Viewing 6 posts - 1 through 6 (of 6 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar