MSX keyboard controls help

This topic contains 6 replies, has 5 voices, and was last updated by  romainp 2 years, 4 months ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
  • #103138


    I have a weird issue with keyboard controls for MSX games, the directional buttons, space button, and F1 buttons work, all the rest of the buttons on the keyboard don’t work! How do i set it up? please help.

    Using Retropie 3 Beta 4 on Raspberry Pi 2



    lr-fmsx or ? try bluemsx – I believe fmsx has some limitations with control input.



    Ya i think fmsx, the one that comes default with the retropie image. Do i have to install bluemsx? is there a guide for that? sorry i’m a noob at this.



    Yeah I made a quick video on how/where to install new emulators:

    In the video I think its in experimental but it was just moved to the stable emulators. Its called lr-bluemsx.



    THANKS! i tried Bluemsx and it’s working with keyboard and joypad, but i encountered another problem.. it changed the keyboard button layout and i lost the pause button (F1), some games use that button as a menu, how can i activate this button?



    THANKS! i tried Bluemsx and it’s working with keyboard and joypad

    Strange, I still have the same problem on RetroPie 3.0 Final with lr-bluemsx: none of the F1-F12 functionkeys, numeric keys or letter keys are working. THis is annoying as some games require pressing the F1 or 1 key to start.

    lr-fmsx gives me the same problem. My keyboard only works in OpenMSX.



    I use the latest retropie 3 image and bluemsx and my keyboard is not working at all…

Viewing 7 posts - 1 through 7 (of 7 total)

Forums are currently read only - please visit the new RetroPie forums at

PLEASE NOTE: All orders that are placed between January 14th and January 28th will be shipped on January 29th. Dismiss