Mario Kart 64 slower on Pi3

Welcome Page Forums RetroPie Project Video Output on RetroPie Mario Kart 64 slower on Pi3

This topic contains 9 replies, has 4 voices, and was last updated by Profile photo of dankcushions dankcushions 1 year, 3 months ago.

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #122031
    Profile photo of g0nz0uk
    g0nz0uk
    Participant

    Hello,

    On my Pi2 I have Mario Kart 64 running very well, I’m using GLideN64 on mupen64plus.

    Today I put it on my Pi3 and it runs so slowly, what should I try next? My pi2 was overclocked to pi2 settings, my pi3 is stock, is it that?

    Thanks

    #122055
    Profile photo of auswear
    auswear
    Participant

    I’ve noticed the same with MarioKart64 with the following overclock settings on the Pi 2:

    gpu_mem=256
    initial_turbo=30
    arm_freq=950
    core_freq=500
    sdram_freq=500
    over_voltage=2

    However on a stock Pi 3 it’s a tad laggy. unfortunately it seems there are some limitations with overclocking the Pi 3 which you can read more about here – https://www.raspberrypi.org/forums/viewtopic.php?f=72&t=138563&p=919875&hilit=pi+3+core+uart

    #122066
    Profile photo of g0nz0uk
    g0nz0uk
    Participant

    The Pi 2 works well for me in terms for N64, I was surprised how bad it is on the Pi3 especially with the extra power.

    #122071
    Profile photo of dankcushions
    dankcushions
    Participant

    gliden64 is the slowest (but most accurate and compatible) plugin and runs at your displays resolution by default which no pi GPU can cope with. change the display mode to CEA1 for n64 using the runcommand menu.

    #122074
    Profile photo of g0nz0uk
    g0nz0uk
    Participant

    Dankcushions thanks for the reply can you explain in a bit more detail on how to achieve this?

    #122075
    Profile photo of dankcushions
    dankcushions
    Participant

    https://github.com/retropie/retropie-setup/wiki/runcommand

    select the default videomode for mupen64plus-GlideN64 – choose CEA1 (640×480)

    #122086
    Profile photo of g0nz0uk
    g0nz0uk
    Participant

    I will try this, how does your Pi3/N64 run at this setting?

    #122090
    Profile photo of dankcushions
    dankcushions
    Participant

    seems about full speed but i haven’t tested 4 player. with my pi 2 i was able to run 4 player at 1080p with only a little bit of slowdown using gles2n64, so i might use that for MK64.

    #122316
    Profile photo of ssimplemind
    ssimplemind
    Participant

    Hi guys. I’m also trying to get Mario Kart 64 to work at full speed for multiplayer games. I have a 40′ FullHD TV as a display, but I don’t mind if I need a lower resolution for the game to work at full speed.

    I’d love to play this game in 4 player multiplayer at full speed. However, right now I cant’t get it to workat full speed constantly even with two players. From what I understand, the N64 video emulators use the display’s default resolution to render the game, and I can see that in the game, because everything which is made out of polygons looks pretty crisp.

    I tried using all the emulators (RICE dowsn’t work, GlideN64 is slower, glesN64 is the best but still a bit slow), changing to (CEA-1) 640×480 but apart from messing with my aspect ratio (it stretched the game to fit 16:9), the polygons looked just as crisp and the game feels slow in some areas. On the fisrt track, Luigi’s Raceway it’s stuttering ever so slightly everywhere, except in the tunnels. I get a boost in display speed every time I go through them. 🙂

    My question, @dankcushions, is how did you manage to make the game playable at 1080p. Where are the settings that you changed, and what should I change if I value playability instead of resolution?

    Thanks in advance.

    #122335
    Profile photo of dankcushions
    dankcushions
    Participant

    are you talking about a raspberry pi 2 or 3? i’m going to assume you mean a 3, although i played mario kart 64 at 1080p on the 2 in 4 player, although it is fairly choppy on some tracks, and has a lot of sound distortion.

    it sounds like yours is already playable at 1080p? i didn’t say it was 100% full speed! right now i’m running it with gles2n64 at 1080p and it is pretty choppy in 4 player but playable, if you don’t mind the sound distortion. in 2 player it only has very minor sound distortion and small amounts of hitches. it seems fine to me.

    interestingly, i tried lower resolutions in gles2n64 and it didn’t seem to make any difference. i’m not sure what causes the choppiness there but it’s evidently not the fillrate or CPU (i checked CPU usage throughout and it was pretty low)

Viewing 10 posts - 1 through 10 (of 10 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar