Mapping Keyboard to universal MAME settings for all emulators

Welcome Page Forums RetroPie Project Everything else related to the RetroPie Project Mapping Keyboard to universal MAME settings for all emulators

This topic contains 4 replies, has 3 voices, and was last updated by Profile photo of ekdor ekdor 2 years, 2 months ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #86247
    Profile photo of stpcore
    stpcore
    Participant

    I’ve spent a good part of the last week trying to troubleshoot this and I thought I would ask this community for some help if possible? Let me start by saying I ONLY want to use keyboard strokes for controls and NOT with a controller.

    First, I am using a USB KADE device connected to an 8 way arcade joystick and arcade buttons. I have the KADE preconfigured to MAME input settings (joystick with 6 button layout). What I’m trying to accomplish is to map the button settings in each emulator around my preset MAME button settings.
    AME is running just fine with my current button layout. NES works OK as NES controller buttons B and A are coincidentally mapped to MAME buttons 5 and 6 (keyboard strokes Z and X) on my arcade control panel. But everything else is all over the place.

    The problem is I cannot for the life of me get my keystrokes to be recognized when I hit the F1 key (to enter Retroarch) and select the input setting. When I select an individual button to be mapped it asks me to press the key for that particular button but when I press an arcade button (or keyboard button) nothing happens and I have to press enter to skip. It’s as if the keystrokes are not registering in the input setting setup screen in Retroarch but they do register while playing games.

    So I guess I’m wondering if anyone has mapped their current emulators around a MAME 6 button setup/configuration? Secondly, is there anyway to get my keyboard to be recognized during the controller configuration that Retroarch offers? Believe me, I’ve been trying to get this going for over a week and I think I’ve maxed out on my own potential at this point.

    Because I am so new to this (Raspberry Pi, Linux, RetroPie, etc.) I feel like I’m missing a step in the process but I’m not quite sure where to go next.

    Thanks in advance for any help or suggestions on this. I hope that I can return the favor at some point!

    #94721
    Profile photo of daronthomas
    daronthomas
    Participant

    Have the same exact problem with my ipac, I wish someone would answer this.

    #94722
    Profile photo of ekdor
    ekdor
    Participant

    Yea seems to be happening to me. I tried to make a post earlier but it vanished into the either. I’ve noticed that, for me, it seems to be only the 4 direction slots that refuse to map. Works perfect for Keyboard but the controllers just won’t take. Tried other connectors and micros. It seems to be software related.

    #94723
    Profile photo of ekdor
    ekdor
    Participant

    I’d like to add. Not sure if there is a connection. But some games where I can use my stick, it tends to move with little pauses. So if I push left and hold it there. The character moves, pauses, moves, pauses etc. The game itself is running smooth.

    Using Hardware:
    – RPi2b.
    http://www.ultracabs.co.uk/ekmps/shops/ultracabs/images/arcade-usb-interface-%5B2%5D-71-p.jpg

    Tried Using Software:
    – retropie-v2.6.0-rpi2
    – retropie-v3.0beta2-rpi2

    I’d add logs but I don’t yet know how to extract them from this architecture. New to this one.

    #94831
    Profile photo of ekdor
    ekdor
    Participant

    I just discovered something. It looks as though the extremely fast repeat rate is causing the input to be ignored. A really really quick tap on the stick yields results.

Viewing 5 posts - 1 through 5 (of 5 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar