MAME4all screen resolution issue

Welcome Page Forums RetroPie Project Video Output on RetroPie MAME4all screen resolution issue

This topic contains 2 replies, has 2 voices, and was last updated by Profile photo of drokkster drokkster 1 year, 8 months ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #108189
    Profile photo of drokkster
    drokkster
    Participant

    Hi All

    I’m sure this is a simple one.

    I’m using a 12.1″ 4:3 LCD screen for retropie. The screen has a resolution of 1024×768.

    Initially emu’s were showing as 4:3 but not full screen. I went into the retropie menu in Emulation station and ‘retroarch/retropie configurations’ and set the ‘common/all’ config to be forced as 1024 x and 768 y

    Now SNES, Megadrive etc all populate the full screen.

    However this has not affected Mame(mame4allpi) or Neo-Geo so there is a large black border on the left/right of the screen.

    I assume this is because the ‘all’ option is just for retroarch configs?

    I went into the individual config for mame4all and neogeo and set it as 1024 x 768 y and rebooted.

    Still not showing in full screen on these emus.

    Any help would be appreciated.

    Thanks

    #108227
    Profile photo of dankcushions
    dankcushions
    Participant

    there’s probably a way to resolve this for those emulators, but one alternative is to press X when launching the game and change the default emulator for both those systems to the retroarch equivalent:
    mame4all-pi to lr-imame4all
    gngeo to lr-fba or lr-fba-next

    the compatibility and performance should be about the same. you will need the neogeo.zip in the neogeo roms folder if you haven’t already.

    #108527
    Profile photo of drokkster
    drokkster
    Participant

    Thanks

    I Managed to get full screen on most MAME roms by editing the screen res in the emulator by pressing x on launch as you stated.

    MAME is using mame4allpi and Neogeo is using LR-fba-next

    Obviously certain roms will never be full screen as they were never designed that way (commando etc)

    Thanks for the tip. Pressing x before the emulator starts is extremely useful.

Viewing 3 posts - 1 through 3 (of 3 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar