mame4all "required files are missing"

Welcome Page Forums RetroPie Project Everything else related to the RetroPie Project mame4all "required files are missing"

Tagged: ,

This topic contains 19 replies, has 7 voices, and was last updated by  arnold 2 years, 9 months ago.

Viewing 20 posts - 1 through 20 (of 20 total)
  • Author
    Posts
  • #20459

    keninem
    Participant

    Hi all. I’ve seen this topic posted a few times in different places, but never a solid resolution. I’m running RetroPie 2.2 (updated to 2.3 though), and I have a full 0.37b5 romset, verified by clrmamepro with no missing/errors. I’ve tried a few different roms (nbajam and kof94) with no luck, same error on both. I’ve tried keeping my roms in /home/pi/RetroPie/roms/mame and I’ve tried putting them in /opt/retropie/emulators/mame4all-pi/roms (and changing the es_systems.cfg file to reflect that) and gotten the same thing.

    Whether I launch a game from EmulationStation or from “./mame <romname>”, I get the screen resolution change and then a list of files and the error “ERROR: required files are missing, the game cannot be run.” It flashes pretty fast, but some that I’m seeing are (these files were from KOF94.. the question marks represent letters that were off my screen and I’m sure there were more missing above what I was able to see):

    kof94_s1.rom NOT FOUND
    ?g-sfix.rom NOT FOUND
    neo-geo.rom NOT FOUND
    ?g-sm1.rom NOT FOUND
    kof94_m1.rom NOT FOUND
    kof94_v1.rom NOT FOUND
    kof94_v2.rom NOT FOUND
    kof94_v3.rom NOT FOUND
    kof94_c1.rom NOT FOUND
    kof94_c2.rom NOT FOUND
    kof94_c3.rom NOT FOUND
    kof94_c4.rom NOT FOUND
    kof94_c5.rom NOT FOUND
    kof94_c6.rom NOT FOUND
    kof94_c7.rom NOT FOUND
    kof94_c8.rom NOT FOUND

    I tried extracting the zip file, since I see all of those files in there, but no luck there either. Am I missing something simple? Appreciate any help.

    #20469

    trimmtrabb
    Participant

    Try copying es_systems.cfg to /home/pi/.emulationstation/ and edit rom location in there to /opt/retropie/emulators/mame4all-pi/roms

    If you have found the solution to your problem please mark the topic as resolved.

    #20493

    keninem
    Participant

    Thanks for the reply, gave that a shot (didn’t have to modify the es_systems.cfg file since I already have ROMs pointing at that dir) and restarted ES and still got the same errors.

    #20519

    trimmtrabb
    Participant

    I don’t know what to suggest apart from double checking the path in es_systems.

    If you have found the solution to your problem please mark the topic as resolved.

    #20523

    keninem
    Participant

    Thanks anyway, appreciate the attempt. I would think the paths would have to be good because otherwise they wouldn’t show up in ES at all, right?

    #20891

    trimmtrabb
    Participant

    Yes good point! Try this:

    sudo chown -R pi:pi /opt/retropie/emulators/

    If you have found the solution to your problem please mark the topic as resolved.

    #20967

    keninem
    Participant

    Did the permissions change and still get the same “not found” errors. 🙁

    #21722

    trimmtrabb
    Participant

    I’ve been trying to reproduce the errors loading roms, when roms are placed in the home/RetroPie/roms/mame/ they won’t load. But if you place the roms in the mame4all-pi/roms/ directory and edit es_systems.cfg accordingly they load fine. I would say the actual roms could be the problem, can you try one from another source?

    If you have found the solution to your problem please mark the topic as resolved.

    #22197

    kesasepi
    Participant

    I have same problem. Some of the roms works but many them says that Required Files are missing error.

    #23575

    keninem
    Participant

    Ok I’ve gotten some resolution on this, but I’m still not 100% where I want it to be. There’s also a mame.cfg file located at /opt/retropie/emulators/mame4all-pi/ that has a line marked “rompath”. By default it’s looking in /home/pi/RetroPie/roms/mame so I think that’s why it’s showing “missing files” when I try to launch a game from ES.

    If I put a game in the /home path it doesn’t show up in ES (even if I change es_systems.cfg to look in the /home path like every other emulator). If I put a game in the /opt path, i get the file not found errors. If I put the game in BOTH paths, it works fine. Anyone know of yet another config file I might be missing that’s conflicting with one of these and causing this? Really would rather keep all my games in the /home path since I have a higher capacity USB stick mounted there.

    #32440

    Wilson

    I have the same problem with retropie.
    Resolution changes and says..
    “Error: Required files are missing”

    Mame is the only reason I started this project ;-(

    #32444

    keninem
    Participant

    Did you follow the steps I did in my last post to at least get the games to run?

    #32521

    Wilson

    Heya Keninem,

    Yes, I put the Mame roms in both directories;
    /home/pi/RetroPie/roms/mame
    /opt/retropie/emulators/mame4all-pi/roms

    NOTE: I put them in the roms directory for opt path.

    inside mame.cfg file;
    rompath=/home/pi/RetroPie/roms/mame
    samplepath=samples

    #32523

    keninem
    Participant

    And you still don’t get the roms to work even when they’re in both directories? That’s new to me.. worked right away when I did it. 🙁

    #33665

    Wilson

    Was that the correct directories?

    #33667

    Wilson

    and case?

    #34314

    wilstorm
    Participant

    You shouldn’t need the ROMs in both locations. I just loaded RetroPie 2.3 from a fresh image download and mame4all-pi works perfectly. I did NOT need to modify any files (i.e. – es_systems.cfg and mame.cfg are now configured correctly to dump ROMs into /home/pi/RetroPie/roms/mame/ and just go!

    What has been missing from mame4all-pi directory in the RetroPie builds is several folders. I just download mame4all-pi from the original website and move the missing folders into /opt/retropie/emulators/mame4all-pi/. I don’t think that is the problem though. It’s nice to do as they don’t even have the artwork or samples folders (samples are nice for games like Donkey Kong, etc.) Maybe they will correct all the missing directories in a future build.

    When you used ClrMamePro to verify your sets did you use split-merge, non-merged or merged? From the list of ROMs in your original post you’re still missing kof94_p1.rom in the zip. I still don’t think that’s your problem as it’s not finding ANY of the ROMs in that list and it is almost the complete list of ROMs needed for that game. They all show missing. It’s also a parent/master game so no additional files would be required to run it.

    Here’s the list with file size, CRC and ROMset name:

    kof94_c1.rom | 2097152 | b96ef460 | kof94 |
    | kof94_c2.rom | 2097152 | 15e096a7 | kof94 |
    | kof94_c3.rom | 2097152 | 54f66254 | kof94 |
    | kof94_c4.rom | 2097152 | 0b01765f | kof94 |
    | kof94_c5.rom | 2097152 | ee759363 | kof94 |
    | kof94_c6.rom | 2097152 | 498da52c | kof94 |
    | kof94_c7.rom | 2097152 | 62f66888 | kof94 |
    | kof94_c8.rom | 2097152 | fe0a235d | kof94 |
    | kof94_m1.rom | 131072 | f6e77cf5 | kof94 |
    | kof94_p1.rom | 2097152 | f10a2042 | kof94 |
    | kof94_s1.rom | 131072 | 825976c1 | kof94 |
    | kof94_v1.rom | 2097152 | 8889596d | kof94 |
    | kof94_v2.rom | 2097152 | 25022b27 | kof94 |
    | kof94_v3.rom | 2097152 | 83cf32c0 | kof94 |

    #87759

    gv0000
    Participant

    I’m in the same boat. ROMs in both locations and still getting the same “Missing Files” error. At this point I’m thinking it’s best to just flash and start over. What I don’t get is that I started with the SD image which was supposed to take care of all these issues.

    #87766

    Roo
    Participant

    This is a really old thread. Probably best to start a new thread and explain your problem there.

    #92947

    arnold
    Participant

    sudo chown -R pi ~/Retropie/roms/mame
    This worked for me.

Viewing 20 posts - 1 through 20 (of 20 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

PLEASE NOTE: All orders that are placed between January 14th and January 28th will be shipped on January 29th. Dismiss