Arcade cabinet video output (overscan problems)

Welcome Page Forums RetroPie Project Everything else related to the RetroPie Project Arcade cabinet video output (overscan problems)

This topic contains 4 replies, has 2 voices, and was last updated by Profile photo of pmurch pmurch 2 years, 4 months ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #86486
    Profile photo of pmurch
    pmurch
    Participant

    I have searched the forum and haven’t found this exact scenario, so hopefully someone has some ideas.

    I gutted an old (non functional) arcade cabinet, complete with CRT driven through an ntsc adapter board off of composite out. I’ve got everything working, and tuned the overscan for the CRT using the usual config lines, plus the newer option overscan_scale=1, which forces all video output to respect the overscan settings, allowing me to get a properly sized image in most emulators.

    This has worked great for all the RetroArch emus and FBA, giving me video that fits the screen exactly. However in mame4all-pi the results are less consistent. Most games are stretched vertically.

    For example, double dragon stretches off the top and bottom of the screen, and has inch thick black bars on the sides. Most of the games are stretched like this to some degree, most coming out with a more or less square image, rather than 4:3.

    Has anyone seen this behaviour? I’m wondering if mame4all-pi uses the overscan settings to size its own screen, but that the additional overscan_scale option then further resizes it, as the geometry of that makes sense to me.

    Is there an option to configure RetroArch/fba overscan so that I can turn off the overscan_scale option?

    Any options in mame4all-pi to change this behaviour, seeing as its the only one that’s wrong right now? I’ve tried the border option with a negative value there, but it adjusts border in all directions equally, so it doesn’t really solve the issue.

    Thoughts?

    Thanks!

    #86493
    Profile photo of Floob
    Floob
    Member

    Does changing the display_border value help in the mame4all config?

    Using overscan in RetroPie to fit video to your display

    Some config options mentioned here:
    https://code.google.com/p/mame4all-pi/

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #86497
    Profile photo of pmurch
    pmurch
    Participant

    Unfortunately that’s one of the things I tried. Because the image geometry is already misshapen, it essentially just zooms the incorrectly shaped image.

    The overscan options referred to there are the ones I have already set in config, but like I said, the addition of that overscan_scale option may be changing mame4all-pi’s expectations of what is being output.

    #86498
    Profile photo of Floob
    Floob
    Member

    hmm, I’ll take a look later.
    I know that mame4all is looking good on my 26″ LCD, I havent changed any options from the default in /boot/config.txt, just tweaked the display_border value in the mame4all cfg.
    Could it be worth trying a different display/tv on the off chance that affects it?

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #86500
    Profile photo of pmurch
    pmurch
    Participant

    Well, I’m married to this display because it’s the one built into the arcade cabinet. I have no doubt another display would be better. That’s sort of the crux of my issue, I need to figure out how to get it working nicely on this one!

Viewing 5 posts - 1 through 5 (of 5 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar