MAME (mame4all-pi) Xbox 360 Wireless controller D-Pad not assignable

Welcome Page Forums RetroPie Project Everything else related to the RetroPie Project MAME (mame4all-pi) Xbox 360 Wireless controller D-Pad not assignable

This topic contains 8 replies, has 6 voices, and was last updated by Profile photo of retrocam retrocam 2 years, 3 months ago.

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #39718
    Profile photo of retrocam
    retrocam
    Participant

    When I press TAB and go to assign controls in MAME I can’t choose the D-Pad for UP, DOWN, LEFT and RIGHT. Other buttons and the analog sticks seem to be fine. Anyone know how to fix this please?

    I noticed someone mentioned after they added the exit hot key and joystick button in retroarch.cfg that they lost D-Pad in MAME (this doesn’t fully make sense to me as MAME doesn’t use Retroarch. Just to make sure I tried removing it from retroarch.cfg with no change.

    #81605
    Profile photo of ryo99
    ryo99
    Participant

    Same here. All buttons work in MAME besides D-PAD. Wired XBOX360 controller.

    #83420
    Profile photo of aceisback
    aceisback
    Participant

    Any fix for this yet? I have the same issue and have found nothing to fix it in the forums and google.

    #87019
    Profile photo of labelwhore
    labelwhore
    Participant

    I’d like to get the D-Pad working in MAME as well. Like the other posters, I haven’t found a fix.

    http://www.th3rdwave.com/tracks/
    ^^ my other hobby

    #87024
    Profile photo of Jassen Payen
    Jassen Payen
    Participant

    I’ve had this problem as well on my RPi 2, which I think is due to the D-Pad configured as ‘h0’ (hat up, down left or right).

    When the xbox wireless controller was configured without the specific settings to load in the driver, and set the LED on startup, the D-Pad would work, however and the analogue stick was actually recognized as having an axis, so this stopped working.

    I find that to exit mame, I just hold the ‘back’ button, and press the left shoulder button. This gets me out of most of the retroarch emulators. I will try this out again later today.

    #87025
    Profile photo of labelwhore
    labelwhore
    Participant

    If I could replace the analog stick functionality with the D-Pad in MAME, that would actually work for me. What I’m trying to do is get a custom arcade stick I made from a couple Xbox 360 controllers to work in MAME. (I wired the sticks to the D-Pad.) I’ve configured all other emulators to use the D-Pad, MAME is the only one I have left to set up the same way.

    http://www.th3rdwave.com/tracks/
    ^^ my other hobby

    #87031
    Profile photo of labelwhore
    labelwhore
    Participant

    Hmmm… Question, are you guys using option 1 from here?
    https://github.com/retropie/RetroPie-Setup/wiki/Setting-up-the-XBox360-controller

    At first glance, option 3 looks like it may make the D-Pads work better than the other two options. I’m currently using option 1. Any thoughts?

    http://www.th3rdwave.com/tracks/
    ^^ my other hobby

    #87038
    Profile photo of retrofredde
    retrofredde
    Participant

    I had trouble getting my arcade stick working too, which could be similar to the Dpad since they’re basically the same, and the fix for me was adding these lines to the xboxdrv line in /etc/rc.local
    –detach-kernel-driver
    –dpad-as-button
    Then I just had to remap the controls in Mame4allpi by pressing TAB and edit the general input and all games could be controlled with the stick.

    #89657
    Profile photo of retrocam
    retrocam
    Participant

    Hmmm… Question, are you guys using option 1 from here?
    https://github.com/retropie/RetroPie-Setup/wiki/Setting-up-the-XBox360-controller

    At first glance, option 3 looks like it may make the D-Pads work better than the other two options. I’m currently using option 1. Any thoughts?

    I have installed the xbox 360 wireless drivers from the script retropie_setup.sh. Then etc/rc.local has:

    xboxdrv --daemon --id 0 --led 2 --deadzone 4000 --silent --trigger-as-button --next-controller --id 1 --led 3 --deadzone 4000 --silent --trigger-as-button --dbus disabled --detach-kernel-driver &
    exit 0
    xboxdrv --trigger-as-button --wid 0 --led 2 --deadzone 4000 --silent &
    sleep 1

    I’m not exactly sure if I added that or it did it with the script. I also blacklisted xpad in /etc/modprobe.d/raspi-blacklist.conf as I was trying to fix up the constant chasing/blinking LED’s on my controller. This also removes the green text that appears when you start a RetroArch emulator which was annoying me.

    I had trouble getting my arcade stick working too, which could be similar to the Dpad since they’re basically the same, and the fix for me was adding these lines to the xboxdrv line in /etc/rc.local
    –detach-kernel-driver
    –dpad-as-button
    Then I just had to remap the controls in Mame4allpi by pressing TAB and edit the general input and all games could be controlled with the stick.

    I attempted to add -dpad-as-button. Can’t seem to get it to work. I noticed that all the other settings are — so I tried –-dpad-as-button in various places with no luck.

Viewing 9 posts - 1 through 9 (of 9 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar