Mame-Libretro Coins and Mame4all Controls

Welcome Page Forums RetroPie Project Everything else related to the RetroPie Project Mame-Libretro Coins and Mame4all Controls

This topic contains 4 replies, has 3 voices, and was last updated by Profile photo of d8thstar d8thstar 2 years, 3 months ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #92228
    Profile photo of scaryevilguy
    scaryevilguy
    Participant

    I’m have a few problems that I could use some help with.
    For starters, I’m running Retropie 2.6 from the image on a RPi 2 with my arcade controls directly wired to the GPIO pins which works really well (mostly).

    My first issue is that in the Retroarch Mame (Mame libretro) some games (eg Donkey Kong) work completely fine, but others (eg PacMan) work, but the select button doesn’t add coins requiring me to use the keyboard. I’m using the 0.37b5 romset most load fine, its just that some work with the select button for coins, others don’t

    This leads to my second problem, where I tried Mame4all instead, same romset seeing as thats the one it needs. However in the config menu it won’t detect the button presses, although once I add coins and press start on the keyboard, the arcade controls still work in the game. Is there an editable controller config file for it? I looked and couldn’t find one on the pi.

    I find the retroarch mame runs and looks better, although it has a few other issues, like in Star Wars and Asteroids (I guess because they’re vector based) the right side of the screen is missing, which doesn’t happen in mame4all.

    EDIT: Ok now I have the controls configured in mame4all just using the tab menu. Don’t know why it didn’t work before. That being said, The libretro mame runs so much better for me and has the start + select to escape so I would prefer to get that one working.

    #92296
    Profile photo of killer101
    killer101
    Participant

    Maybe it is the same problem like with the PS3 Controller. Normally the emulator exit function sits on select + start. Using this button setup some FBA and Mame titles won’t insert coins. Just change the emulator exit function to an other button. For my PS3 Controller I use left trigger + start. Now coins works like a charm. Maybe this will help!

    #92346
    Profile photo of scaryevilguy
    scaryevilguy
    Participant

    I’ll give that a go tomorrow when I get a chance. I got a couple of usb snes controllers today so if they work better I’ll wire them to my buttons instead of the gpio, but if i can avoid soldering it would be nice.

    #92443
    Profile photo of scaryevilguy
    scaryevilguy
    Participant

    That fixed it. I changed the hotkey to start and the exit to L. Thanks for the help

    #92447
    Profile photo of d8thstar
    d8thstar
    Participant

    can you please post your cfg file (and which cfg file) you did for start + L to exit? i have tried changing the hot key combo and it simply does not work.

    any help is appreciated, thanks

Viewing 5 posts - 1 through 5 (of 5 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar