MAME Controller Woes :(

This topic contains 1 reply, has 1 voice, and was last updated by  dakree 4 years, 2 months ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
  • #3015


    First, let me add a disclaimer that I have searched pretty extensively for a solution before posting here. If there is a good solution thread out there, please forgive me and post it here 🙂

    I have gotten most all the features to work on my Pi running RetroPie (latest image, 1.8.1). But for whatever reason, I cannot get a controller to work with MAME. The keyboard registers, but not my controller. I have tried configuring the retroarch controls through the graphical interface, and I have also gone into the command line (sudo retroarch-joyconfig). In both cases, my controller registers and seems like it will work fine, but once I run MAME only the keyboard works (I have so far tried running KOF 94 and 95, as well as Final Fight). Is there an extra step in the process that I am missing that is particular to MAME?

    Any help would be hugely appreciated! I really want to get my SNK on.

    Oh, and my controller has worked so far for SNES and Genesis, so I am disinclined to believe that it is an issue with the controller itself.



    I am sorry all, I take it back. This thread should be titled “general controller woes.”

    While my controller worked for SNES and genesis in image 1.7, apparently it is having issues with this latest version. I can navigate through the retropie overlay with my controller, but as soon as I open an emulator it ceases to function.

    Again, any help would be very welcome!

Viewing 2 posts - 1 through 2 (of 2 total)

Forums are currently read only - please visit the new RetroPie forums at

PLEASE NOTE: All orders that are placed between January 14th and January 28th will be shipped on January 29th. Dismiss