Mame control input reset to standard

Welcome Page Forums RetroPie Project Everything else related to the RetroPie Project Mame control input reset to standard

This topic contains 10 replies, has 2 voices, and was last updated by Profile photo of Floob Floob 2 years, 5 months ago.

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #85715
    Profile photo of noobaphile
    noobaphile
    Participant

    Hi, I wonder if someone can help me, I have made a mess of my controller input settings in mame(accessed using Tab) is there a way to reset them to original ??
    Thanks

    #85723
    Profile photo of Floob
    Floob
    Member

    Which version of RetroPie are you running?

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #85726
    Profile photo of noobaphile
    noobaphile
    Participant

    Hi Floob. Its 2.4.1 i beleive, when i was configuring inputs , by accident i wiped the button for select, so now i cant select anything to rectify it. I know im an idiot, thanks for the quick reply Floob.

    #85736
    Profile photo of Floob
    Floob
    Member

    I guess you could try deleting (or just rename it):
    /opt/retropie/configs/mame4all/cfg/default.cfg

    I’ve attached my copy (you need to rename it to .cfg).

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    Attachments:
    1. default.txt
    #85739
    Profile photo of noobaphile
    noobaphile
    Participant

    Thanks Floob, I was hoping there was an easier way

    #85741
    Profile photo of noobaphile
    noobaphile
    Participant

    Hi Floob, Im using a windows based pc, should this txt file look like jibberish on my pc ?. if i navigate to this file using ssh, can i just delete then replace with your copy, I dont want to have to go through reflashing an image of retropie and tranfering all my roms. Thanks agian Floob.

    #85742
    Profile photo of Floob
    Floob
    Member

    Yes, it should look jibberish as its not a text file. But please backup yours in case there is an issue.
    I’m not sure of the approved clean way of resetting the config besides this sort of approach (or rebuild the image/emulator)

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #85780
    Profile photo of noobaphile
    noobaphile
    Participant

    Hi Floob. sry i have taken so long to reply, i transfered all my roms using usb so this was my first time using filezilla to view the directories. I cant seem to find this location that i need to alter the default.cfg. I have attached a pic of my directories, could you point me in the right direction, Once again thanks, your help is really apreciatted!

    Attachments:
    #85786
    Profile photo of noobaphile
    noobaphile
    Participant

    Never mind I found it, but now none of my Mame roms start after editing this file

    #85788
    Profile photo of noobaphile
    noobaphile
    Participant

    I think I’ll go down the fresh image route, I have multiple duplicate roms, so this time I will take my time and do it right, Thanks Floob, I’m going to follow your video for configuring Mame controls. Your a gentleman if your ever in Glasgow I’ll buy you a pint.

    #85808
    Profile photo of Floob
    Floob
    Member

    Sorry it didnt work – I’ll see if I can get it to work on my setup.
    But yes, updating to the latest image would be a good idea to get the latest benefits.

    I’ll look out for you here:
    http://www.playblackpool.com/

    🙂

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

Viewing 11 posts - 1 through 11 (of 11 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar