Logitech F310 Configuration Issues

Welcome Page Forums RetroPie Project Controller Configuration in RetroPie Logitech F310 Configuration Issues

Tagged: , ,

This topic contains 2 replies, has 2 voices, and was last updated by Profile photo of drake999 drake999 1 year, 10 months ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #103908
    Profile photo of drake999
    drake999
    Participant

    Hello. First let me apologize if this issue has been covered. I was unable to locate a satisfactory answer to my question, but I realize that doesn’t mean it doesn’t exist. I’ve been tinkering with RetroPie for a few months now. I have created RetroPie consoles from 1st and 2nd generation Pi boards. The issue I’m having as far as controller configuration on my Pi2 is a bit of a head scratcher though. For my first gen board, I just used a pair of SNES imitation pads which connected via USB and they worked without issue. However, since the Pi2 is more powerful, emulation of 3D capable systems is far more practical, and I therefor opted to use the Logitech F310 pads which have joysticks and the same amount of buttons as a PSX controller. The issue is when I go to program the buttons in the EmulationStation GUI, it doesn’t correctly recognize the analog triggers. It seems to interpret pressing the trigger and releasing the trigger as separate button presses, so I therefor cannot complete the configuration of the controllers correctly. When I use the RetroPie-Setup script, the button order turns out wrong when I launch a game in EmulationStation. For example when I use the PSX emulator, the button mappings don’t match the layout of an actual PSX pad. I did find that the Logitech Dual Action pad (basically a previous version of the F310) works great, but they are nolonger manufactured and typically go for ridiculous prices new. I’m hoping there is a quick and easy solution to this problem but any help will be greatly appreciated. Thanks for any assistance you can offer.

    #103947
    Profile photo of MRKane
    MRKane
    Participant

    Gidday Drake,

    There are a LOT of posts regarding issues with the F310…

    I’ve been using both the dual action and the F310, but am only setting up at present. I’ve hit a few issues with the controller config too and found that the different settings options on the F310 (direct toggle switch underneath and the mode toggle on top) will radically change the input the controller is sending.

    How comfortable are you with the terminal side of emulation station? I was setting up mainly for SNES and N64, and had to use jstest (ie “jstest /dev/input/js0” where “js0”) is the first controller to figure out what input was being sent through, and fiddled with the different controller settings until I found something that worked. It’s slow, and arduous, but was about the only way.

    Also I’ll apologise if it appears as though I’m speaking down to you, I’m just trying to cover all bases!

    There's always one.

    #104132
    Profile photo of drake999
    drake999
    Participant

    Hello MRKane. Thanks for the reply. No worries, I didn’t feel as though you were talking down to me. I’m what you call a Linux noob, I know enough to be dangerous, but wouldn’t say I’m comfortable with the command line. It’s a shame that a discontinued controller seems to be the only one I can get to work flawlessly. I’m hoping that trigger detection issue might be fixed in a later version of EmulationStation/RetroPie. I can get the controllers to work if I configure via the setup script but the button layout is always wrong. I’m hoping I can find a solution soon.

Viewing 3 posts - 1 through 3 (of 3 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar