Loading ROMs from a USB stick

Welcome Page Forums RetroPie Project New to RetroPie? Start Here! Loading ROMs from a USB stick

This topic contains 15 replies, has 6 voices, and was last updated by Profile photo of shoothere shoothere 1 year, 4 months ago.

Viewing 16 posts - 1 through 16 (of 16 total)
  • Author
    Posts
  • #109381
    Profile photo of shoothere
    shoothere
    Participant

    Hi all,

    I recently purchased a 32gb USB stick to store my roms on.

    Copied everything I wanted to the stick, make a symlink with the following command (as somebody else suggested in the forums):

    ln -s /media/usb/roms/ ~/RetroPie/roms

    After a reboot the roms were seen and all was well…exceeeeept:

    NES/SNES/Megadrive/gba just will not load. runcommand.log is empty.
    I expected at this point that none of the emulators would work but much to my surprise FBA and the PSX roms loaded fine.

    Also it seems the Selph’s Scraper has the path hardcoded into it and it will not fall for the symlink trick.

    Any ideas on the matter?

    Thanx!

    #109389
    Profile photo of shoothere
    shoothere
    Participant

    Perhaps some additional info after some searching:

    The stick is FAT32 formatted, although it should not matter, perhaps it does?

    The stick is mounted as read only and I cannot get it to mount as read/write. Yet again I would not expect this to matter but again: perhaps it does?

    Is the symlink approach the wrong one? I could not find where to set the path where retroarch looks for its files as it seems online guides apply to 2.6 and not 3.X.

    #109444
    Profile photo of fvargasfrank
    fvargasfrank
    Participant

    I’m new to this as-well, i tried what someone else suggested, editing the emulationstation/es_systems.cfg
    by pointing it to my USB folder

    But that is not working either. i have formatted my usb to EXT4 and the emulation I’m trying is FBA

    Its working when i put the roms on the SD, but not of the USB

    #109449
    Profile photo of gonzothegreat
    gonzothegreat
    Participant

    yup gettin the same problem

    #109452
    Profile photo of momaw27
    momaw27
    Participant

    Hello all!

    I have all of my ROMS on a 128GB thumbdrive with the es_systems.cfg for all systems pointing directly to my USB drive, and it works great.

    A few things I discovered in the process:

    1. I had to get rid of the tilde “~” in the roms path when pointing to my USB stick. This is Linuxese for ‘go to root’.

    2. I had to be sure where Retropie saw my stick. In my case it was USB0.

    So my roms path for SNES looks like this:

    /media/usb0/retropie/SNES

    This works well for me, but I am looking into using symlinks in the future because every time I update my systems I have to re-edit my es_systems.cfg file… which is a pain.

    #109456
    Profile photo of gonzothegreat
    gonzothegreat
    Participant

    o, so how can i change the permissions so i can set the drive to read/write so i can add files via filezilla mac.

    oh, symlinks i’d be interested in using those too, but have no idea how

    thanks

    #109467
    Profile photo of shoothere
    shoothere
    Participant

    Changing the paths in /etc/emulationstation/es_systems.cfg did not work for me.

    @momaw27: are you running 2.6 or 3.X?

    #109479
    Profile photo of fvargasfrank
    fvargasfrank
    Participant

    So this is what i did to get my to work retropie 3.1

    I went to /home/pi/RetroPie/roms
    Deleted my rom folder (fba)

    and created a symlink like this
    ln -s /mount/usb0/fba /home/pi/RetroPie/roms

    now all my roms from my usb are showing
    as well as all my images from using the scraper

    now i need to look into deleting the gambles games from my list and racing games

    #109482
    Profile photo of shoothere
    shoothere
    Participant

    @fvargasfrank: the ones that were already scraped will show properly, running a new scrape will result in an error. And oddly, FBA works with the symlink, just not other emulators.

    Happy it works for you but, sadly, does not solve our problem haha!

    oh and PS: gambling games ok but racing?! Come on! 😛

    #109678
    Profile photo of fvargasfrank
    fvargasfrank
    Participant

    Just tried the snes rom super mario, I created a hyperlink just as before and then i change the emulator to snes9x and the rom loaded

    #109963
    Profile photo of shoothere
    shoothere
    Participant

    So it seems emulator related. I will have a look at the different emulators although I would like the Libretro ones to work as they seem to work best.

    Is this an issue that is perhaps being adressed? As it seems some people manage to run them off external drives without any troubles.

    Thanx for the tip!

    #109976
    Profile photo of jedimaster666
    jedimaster666
    Participant

    I’d recommend making links one system at a time. Aside from that, check for case sensitivity and emulator file type compatibility.

    #109998
    Profile photo of dankcushions
    dankcushions
    Participant

    symlinks should work fine. i use them with all the systems, and the sselph scraper. if your symlink is set correctly, the rom file structure should look exactly the same to anything accessing it, as if it was in the normal place.

    the only problem i had was making sure the usb auto-mounted each boot, and with the right permissions. i can’t remember how i did this, but as a linux newbie i just googled until i found something to copy 🙂 it was something to do with fstab and fat32 permissions. my /etc/fstab looks like this:

    proc            /proc           proc    defaults                0       0
    /dev/mmcblk0p1  /boot           vfat    defaults                0       2
    /dev/mmcblk0p2  /               ext4    defaults,noatime        0       1
    # a swapfile is not a swap partition, so no using swapon|off from here on, use $
    UUID=E44B-FC4E  /media/usb      vfat    nofail,user,umask=0000  0       2

    (last line is the usb)

    #110019
    Profile photo of shoothere
    shoothere
    Participant

    @jedimaster666: unfortunately per system links do not work either. As stated above not all systems are affected, strangely enough. It seems more emulator related than anything else as switching to some other emulators for, say, SNES work (although these are not the emulators of choice, as one would prefer the libretro ones).

    @dankcushions: did you symlink the roms folder in its entirety? I take it you are running 3.X? So I take it your USB stick is read write? The USB stick mounts fine each boot, just as read only. I altered the SRM directory to reside on the SD as the size is not that big of a problem

    #110104
    Profile photo of dankcushions
    dankcushions
    Participant

    @shoothere
    i’d previously manually set up the symlinks for each rom folder, but i’ve just done a re-build and attempted to do it with one link of the whole folder (i copied the contents of the stock roms directory to my stick beforehand), and it worked fine. saves time, cheers!

    my USB stick is read/write (thanks to that fstab line) and i’m running 3.2.1 (although it worked fine before)

    #116422
    Profile photo of shoothere
    shoothere
    Participant

    Well with version 3.5 it works! Pretty much out of the box working!

    Only thing that still requires a manual run is Sselph’s scraper, which is easily downloaded and run from inside the new USB directory as per this documentation:

    https://github.com/sselph/scraper

Viewing 16 posts - 1 through 16 (of 16 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar