little issues

This topic contains 9 replies, has 3 voices, and was last updated by Profile photo of  Anonymous 4 years, 2 months ago.

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #1522
    Profile photo of
    Anonymous

    today i got my gpio Adapter 😀 it is really amazing. Emulators work fine the snes pads too. Still i have a few minor issues to be completely satisfied.

     

    1. the snes pads don’t seem to work properly in the selection screen. D-pad works fine but i cant start a game by pressing A or any other button (need to use keyboard). In game everything works fine

     

    2. to navigate through the selection screen i need to use my second controller.  First controller does nothing.

     

    3. I can not find any way to set the button on the gpio adapter (reboot button would be awesome)

     

    kyodu

    #1533
    Profile photo of petrockblog
    petrockblog
    Keymaster

    1. + 2. It sounds as is data 1 and data 2 have to be swapped. You need to delete ~/.emulationstation/es_input.cfg to make ES ask you again for mapping joypad buttons.

    3. to use the button I recommend using SNESDev. You can configure it via the setup menu from the RetroPie Script.

    Hope that helps!

    #1534
    Profile photo of
    Anonymous

    thanks for the help i fixed problem 1 i now can use the snes pad to navigate through the emulationstation and start games. But it works only with one adapter. If i connect my controller to the other adapter i can´t set the buttons (second adapter works fine ingame). When i start up a game the controller is set as second player and i have to switch the controller .

    3. i cant find any setup for the button in the script am i missing something?

     

    kyodu

    #1535
    Profile photo of jbaker1225
    jbaker1225
    Participant

    I believe only first player can navigate Emulation Station.

    As for your controllers being switched in game, open up the ReroArch.cfg file and make sure that input_player1_joypad_index = “0″ and input_player2_joypad_index = “1″.

    Sometimes the 1 and 0 get flipped which screws it up.

    #1536
    Profile photo of
    Anonymous

    Hey in the RetrArch.cfg  everything was set the way you said so i tried the other way around still does not work for me any other ideas?

    #1537
    Profile photo of petrockblog
    petrockblog
    Keymaster

    Just to make sure: You need to edit /home/pi/RetroPie/configs/all/retroarch.cfg.

    The menu entry Setup > SNESDev allows you to configure SNESDev such that it only polls the button. Currently, it is not possible to customize the button configuration, which is described in detail at https://github.com/petrockblog/SNESDev-RPi#button-polling.

    #1543
    Profile photo of
    Anonymous

    thanks i changed the wrong retroarch.cfg now the controller work fine 🙂 still there is one problem the restart with the button does not work properly. The raspberry tries to restart but the resolution now is set really low and emulationstation does not start up :/

    #1545
    Profile photo of
    Anonymous

    i figured it out everything works now 🙂

    #1546
    Profile photo of petrockblog
    petrockblog
    Keymaster

    Glad to hear!
    How did you solve your problem?

    #1562
    Profile photo of
    Anonymous

    i wasnt sure what should happen after 5 pressese i thought it would be a reboot ^^ my foult 🙂

Viewing 10 posts - 1 through 10 (of 10 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar