libretro-fuse won't install

This topic contains 6 replies, has 2 voices, and was last updated by Profile photo of vretro vretro 1 year, 11 months ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #100643
    Profile photo of vretro
    vretro
    Participant

    Using a Pi B+ I tried several times to install the new experimental package “libretro-fuse” but the build ends with the error:

    “Could not successfully build lr-fuse” …
    “/home/pi/RetroPie-Setup/tmp/build/lr-fuse/fuse_libretro.so not found

    I updated the RetroPie Setup script first before trying. Has anyone had any success with installing this new libretro core or know a work around?

    Thank you

    #100661
    Profile photo of petrockblog
    petrockblog
    Keymaster

    May be changes upstream that has broken compilation – you can post a logfile from the logs directory to a site like pastebin and I can look more (Or open a ticket on github and I’ll check when I next have a moment)

    #100662
    Profile photo of vretro
    vretro
    Participant

    Hi Buzz, I found the log containing the error and added it to Pastebin for you:
    http://pastebin.com/pJMU70rN

    #100665
    Profile photo of petrockblog
    petrockblog
    Keymaster

    Looks like you may have run out of memory when compiling. You may need to lower gpu allocated ram via /boot/config.txt and try again – I’ll check on my 256MB pi and perhaps add some virtual memory for this module.

    #100812
    Profile photo of vretro
    vretro
    Participant

    Thanks Buzz. I lowered the GPU allocation to 16MB and attempted the build again, but it didn’t work.

    A while back I disabled and uninstalled the swap feature from my RetroPie build (to reduce chance of corruption due to power loss) so I will have to look about reinstalling that, or making new temporary swap file and attempt the build again.

    Did you have any success trying on your 256MB Pi?

    #101549
    Profile photo of petrockblog
    petrockblog
    Keymaster

    I have built it yeh – you will need to re-enable the swap I guess.

    #101592
    Profile photo of vretro
    vretro
    Participant

    Thank you Buzz.

    I can confirm I was able to install Libretro Fuse by enabling Swap first with the following commands:

    dd if=/dev/zero of=/root/swap bs=1M count=512
    chmod 600 /root/swap
    mkswap /root/swap
    swapon /root/swap

    It seems like a really good emulator and I have set it as default as it runs perfectly and supports joypads and has a handy overlay for key presses (found by pressing Select)

Viewing 7 posts - 1 through 7 (of 7 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar