LED buttons switching within Retropie

Welcome Page Forums RetroPie Project Everything else related to the RetroPie Project LED buttons switching within Retropie

This topic contains 2 replies, has 2 voices, and was last updated by  burauzaa 2 years, 4 months ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #106417

    burauzaa
    Participant

    I’m working on a build using arcade controls connected to the GPIO pins direectly. The buttons and stick I am using have LEDs that I currently just have wired up to the 3.3v and ground on the GPIO. This works fine, but I’d like to have a software switch to turn them on and off.
    I looked into some simple tutorials and used a simple python script to turn them on, and another to turn them off.
    I can run these from the console and everything works but I’d really like to have something in the menus in the GUI for RetroPie to turn them on and off. I created a couple of .sh files called on.sh and off.sh containing the python string and put them in the ports folder and they showed up, but when I tried to run them it said they didn’t have permission to run.
    Can anyone point me in the right direction?

    #106425

    tipoto
    Participant

    You need to change the permission settings of your bash scripts. From the terminal, go to the folder where your scripts are located and use this command:
    sudo chmod 777 on.sh
    sudo chmod 777 off.sh

    You can do it through fileZilla as well, if you use it to manipulate and upload your files on you rpi, to change the permission settings, just right click on the file and select “permission”, then you can modify the permissions the way you want.

    #106432

    burauzaa
    Participant

    That worked! Thank you very much.

Viewing 3 posts - 1 through 3 (of 3 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

PLEASE NOTE: All orders that are placed between January 14th and January 28th will be shipped on January 29th. Dismiss