Kodi 15 update

This topic contains 4 replies, has 2 voices, and was last updated by Profile photo of epe9686518 epe9686518 1 year, 6 months ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #111535
    Profile photo of atimmins
    atimmins
    Participant

    I installed Kodi from the experimental menu and was having problems exiting out of Kodi back to emulationstation. It would freeze on a black screen. From what I read online, that is a common problem with Kodi 14 and there wasn’t a good solution for it. So, I followed the instructions here https://github.com/RetroPie/RetroPie-Setup/wiki/KODI and installed Kodi 15 instead. This fixed the exit bug, but now I have a more annoying problem. Whenever I play a video, the video seems to play at three or four times the normal speed, but the audio plays at normal speed. The audio and video quickly get out of sync and it makes movies un-watchable. Has anyone else experienced this? Is there anything I can do to fix it? Thanks.

    #111572
    Profile photo of atimmins
    atimmins
    Participant

    Anybody?

    #111619
    Profile photo of epe9686518
    epe9686518
    Participant

    Go to the settings… “Playback”… Make sure “adjust displays refresh rate” is set to always.. Go to “Acceleration”… make sure both “allow hardware acceleration OMXPlayer and MMAL” are checked…

    Try that, let me know what happens

    #111638
    Profile photo of atimmins
    atimmins
    Participant

    I had hoped it was something as simple as xbmc settings so those were the first things I tried. No luck. I think something about the kodi installation got messed up or something.

    #111643
    Profile photo of epe9686518
    epe9686518
    Participant

    I had the same issue back in the summer when I first added Kodi to my Pi, but I can’t remember what it was that I changed… It might have been changing the memory split… I not sure what I am currently using, but it’s around 320. Go into the pi settings and set gpu_mem=320… You might not be giving the gpu enough ram. I really wish I could remember what it was that I did to fix it, but I had that issue back in July and I simply can’t remember for the life of me what it was nor off the top of my head anything else to try.

    If your running Kodi on Pi, you should give the GPU around 320 mb of memory anyway, as it needs it to properly run, hopefully that might fix your video issues as well.

Viewing 5 posts - 1 through 5 (of 5 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar