Kinks from Wheezy to Jessie

This topic contains 6 replies, has 3 voices, and was last updated by Profile photo of elib55 elib55 1 year, 4 months ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #115670
    Profile photo of elib55
    elib55
    Participant

    A few days ago I received a Matricom Bluetooth Controller from Amazon to use with the RetroPie(To my knowledge I couldn’t find anyone else who has used this controller for RetroPie). When I tried pairing it I ran into all sorts of problems which I spent about two nights on and tried everything on the
    https://github.com/retropie/RetroPie-Setup/wiki/Setting-up-a-PS3-controller site. Eventually I gave up on Wheezy which meant giving up a lot of data. Jessie worked fine on first boot and with a little tinkering I have the controller setup, but when I use the same USB storage device to move roms it stopped after the atari2600. I looked in the filemanager and all of the roms are there in the RetroPie>Roms>”emulator” but the emulators themselves don’t show up on emulation station. I have made sure to expand the file system but I don’t think that is the issue since all the files are where they should be. Am I missing something? Do I have to download the emulators individually now from the setup script?

    #115672
    Profile photo of labelwhore
    labelwhore
    Participant

    How did you format the usb storage device? Is it a flash drive? or HDD?

    Actually, let me back up. You say all of the roms were copied from usb to the rom folder on the sd card? Have you restarted the pi, and the the emulators still don’t show up?

    http://www.th3rdwave.com/tracks/
    ^^ my other hobby

    #115677
    Profile photo of elib55
    elib55
    Participant

    Yeah, I restarted emulation station even rebooted and they still don’t show up. The emulators don’t show up but it shows the roms in the correct folders in file manager.

    The usb was formatted with sdformatter and it is a flash drive. It was unchanged from the last time I put roms on Wheezy Retropie.

    #115688
    Profile photo of elib55
    elib55
    Participant

    Just a quick update. I’ve been trying to figure this out all morning. I expanded the file system and in file manager it acknowledged that there was 29gigs (32gig microsd). At the bottom it said 26G/29G which is about the amount of data on the usb, but when I open some of the rom folders there will be folders with the name of the rom but when i open them they are empty. It took all the folders but none of the files with in the folders. Somehow it still says 26G/29G even though i know those empty folders aren’t taking up that kind of space. Which makes me think the file system didn’t get expanded right, even though it says the system was successfully expanded.
    Also when i copied a rom from usb>retropie>roms>psx to /pi/retropie/roms/psx using the file manager manually it worked just fine. I only did this for one file but i thought it was worth.

    #115703
    Profile photo of petrockblog
    petrockblog
    Keymaster

    the space must be used up somewhere.

    install “ncdu” and use that from a terminal to see where the space is used. Maybe you copied something to the wrong location?

    #115711
    Profile photo of elib55
    elib55
    Participant

    Thank you buzz. I wasn’t aware of that tool. It comes with retropie too no need to install. I had 3.6gb actually on the card and 104500 items (which seems like alot).
    I don’t know why it won’t automatically copy those files but it seems to work fine when I do it manually via file manager.

    #115726
    Profile photo of elib55
    elib55
    Participant

    I ran into some bluetooth troubles again bc I was stupid and pretty much tried starting from scratch reformatting the microsd and re-writing the OS. btw I could only connect the bluetooth controller when i added
    sudo hciconfig hci0 up
    sudo bluez-test-input connect 58:2D:89:2E:00:01 (XX:XX:XX:XX:XX:XX)
    to the rc.local between fi and exit0.
    I don’t know if that a Matricom thing but that took a good portion of my saturday lol.
    That being said i’ll just take the long way and do this manually via file manager for now. The only thing i didn’t try was reformatting the usb and putting all those roms back on it (which I have backed up somewhere). although if it were a bad usb flashdrive then why would it manually let me copy files with file manager?

Viewing 7 posts - 1 through 7 (of 7 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar