King Of Fighters 2003 issue (neo geo)

Home Forums RetroPie Project Everything else related to the RetroPie Project King Of Fighters 2003 issue (neo geo)

This topic contains 13 replies, has 9 voices, and was last updated by Profile photo of charco charco 1 year, 9 months ago.

Viewing 14 posts - 1 through 14 (of 14 total)
  • Author
    Posts
  • #91964
    Profile photo of smoothmalik
    smoothmalik
    Participant

    The game the game is entirely broken it seems. It says insert coin / credit 00 at the bottom of the screen, but there are no graphics in the middle of the screen at the titlescreen, and if/when you get the game to start, everything is out of place/distorted. I dont know which character is actually being picked it very disjointed. Once I get to actual gameplay only thing I see is the background. I found some info on regarding this issue at but I wasnt able to post the link. Anybody have any info regarding this?

    Attachments:
    #92055
    Profile photo of neighbourhoodnerd
    neighbourhoodnerd
    Participant

    Most MAME games don’t work. The emulators on the Pi for MAME (including Neo Geo) require 0.375b ROMsets.

    #92068
    Profile photo of smoothmalik
    smoothmalik
    Participant

    im using fba for all my neo geo roms and they all play except for this one.. and they are all version FB Alpha v0.2.97.31 roms which I have put in romcenter and all show to be compatible. This is the only one that caused me a problem.

    #92072
    Profile photo of proxycell
    proxycell
    Participant

    hey smooth,
    just because the roms are for a recent version of FBA you should keep in mind that the FBA being used here is not as recent…

    i hate to ask, but do you have a raspberry pi 2 b? i will try this out shortly so reply back here and i will get a notification and update you on the status of mine

    #92076
    Profile photo of smoothmalik
    smoothmalik
    Participant

    Proxy,
    Thanks, and yea im using a RPI 2b

    #92089
    Profile photo of davejaca
    davejaca
    Participant

    just tried it out, and no issue, it must be your rom or bios, I am running mine on the pi2 with roms in the fba folder, as per vid below, can post some vids/screens if your interested.

    Send me a PM we can talk more.

    #92100
    Profile photo of proxycell
    proxycell
    Participant

    well there ya go, someone has tested it today before me 🙂

    #106646
    Profile photo of dishins
    dishins
    Participant

    all these games play on my PiFBA on Raspberry Pi Model B, but without sound…

    #106677
    Profile photo of kde9999
    kde9999
    Participant

    thank you very much for your help Gutossn what I get home I try the file thanks thanks thanks 🙂

    #106697
    Profile photo of epe9686518
    epe9686518
    Participant

    As stated before you need the m1_encrypted file to get the sound to work in the neogeo games that don’t have it. There are as noted above also a few other files some games require to run properly… Its a bit of work, but once you get all of these files every single game runs perfectly fine on PIFBA.

    #106733
    Profile photo of dishins
    dishins
    Participant

    can you explain which file is this m1_encrypted? it comes with the romsets?

    #106772
    Profile photo of epe9686518
    epe9686518
    Participant

    m1_encrypted was used back in the day with the old version of the emus to decrypt the sound for some of the neogeo roms. As time went on the emulators built in the ability to decrpt the sound within the emu it self and no longer needed the m1_encrypted file. Since retropie is using old emulators for PiFBA, you still need this file to decrypt the sound. The m1_encrypted file needs to be placed in your rom zip. Do a simple google search for the file + rom and you should find some further info on it.

    #106797
    Profile photo of Floob
    Floob
    Member

    For reference, you can see the romset versions (along with dat files) here:
    https://github.com/RetroPie/RetroPie-Setup/wiki/Managing-ROMs

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #106821
    Profile photo of charco
    charco
    Participant

    I have the same issue with KoF 2003 using the Libretro FBA emulator on my RPi2, even though it is the same rom version as all of the other working Neo Geo roms and the same rom works on both the Windows and Wii versions of RetroArch.

Viewing 14 posts - 1 through 14 (of 14 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar