Keyboard and Controllers not found/working on fresh installation

Welcome Page Forums RetroPie Project Everything else related to the RetroPie Project Keyboard and Controllers not found/working on fresh installation

This topic contains 12 replies, has 2 voices, and was last updated by  mors3 2 years, 5 months ago.

Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
  • #99144


    Hi guys,

    I’ve run up RetroPie a few times now, enough to know my way around setting up controllers, setting permissions of the config files but I’d by no means class myself as an expert.
    However I’m having the oddest problem.

    Short story is I’m using the latest available version of Raspbian straight off the main raspi site, and installing RetroPie using the github hosted setup script, but for reasons I cannot fathom when emulationstation strats up it says there’s no controller found and F4 on the keyboard (to quit back to commandline) doesn’t work!?

    If I ssh to the pi and kill the retropie process then the keyboard works fine again, I can type as normally!

    ..very odd

    I’ve had quite an extensive look around the net and the best I can come up with is on emulationstations installation guide they say that if SDL isn’t already installed when it gets installed it can cause the keyboard to mysteriously not work.

    I originally thought this might be an issue with the image of raspbian I pulled down and applied to the pi, so I grabbed another copy from the site, re-applied the image as normal (the full works, wiped partitions and applied the image).
    I then went through the normal process but the same result, first run always shows me the initial controller configuration with no controllers found (there is one plugged in that has successfully worked on retropie previously) and pressing F4 on the keyboard has no effect.

    I’ve tried setting the permissions of the various retropie/emulationstation config locations to pi:pi and 777, but it has no effect.

    Any ideas?



    Have you tried using the SD image?
    Its built on raspbian so its effectually the same (that way you can rule out if its your method of installing)



    Hmn, that might work.. I previously used the beta 3 image, but I also need access to the full gui desktop (it’s going to be a beast of many things for my son) so when I (on the beta 3 image) quit out to commandline and startx, it didn’t include the x desktop environment.

    Does the standard RetroPie 2 image have the full x desktop?



    Lxde isn’t there by default but I have a video showing how to get it back:

    It may be easier to install lxde on top of retropie than it would be to try and sort out which config of retropie isn’t working.



    🙂 Awesome, thank you very much, I shall give that a crack.



    …ok, well that hasn’t quite to plan, just finished wiping the drive and putting beta3 retro pie onto it, and same issue.

    Full info:
    used gparted on my ubuntu laptop to wipe partitions on the USBHDD and create a new flat ntfs partition (not sure this is necc as I think when you apply an image to a device it goes over all the partition info, but safer>sorry)

    downloaded a fresh version of the beta3 image to ubuntu

    used dd through ubuntu to apply the beta 3 image to the USBHDD

    booted the pi2 using the USBHDD

    first screen when retropie finishes loading is:
    no gamepads connected
    hold a button..
    press f4 to quit

    pressing f4 has no effect, using a ssh terminal I then find and kill the retropie process which quits me back to commandline, where the keyboard works as expected.



    So holding down a button doesn’t register your controller or keyboard? Are you trying to install retropie on your desktop or your raspberry pi- your post wasn’t very clear- is the usbhdd a USB drive or your SD card?



    …wow, I clearly didn’t explain this very well at all! Apologies :S
    I really appreciate your help on this, I’ll try and explain as best as possible.

    Ok, so to avoid burning out a sdcard, (and also to give me a lot more space) my raspi2 is going to be running RetroPie from an external usb hdd.

    It’s most definitely being used on a raspi (a raspi2 specifically), I’m only using ubuntu purely to write the image onto the external usb hdd.

    RetroPie is essentially completely unresponsive when the first Welcome screen appears (after the RetroPie splash loader screen), in the text on the welcome screen it specifically says ‘no controllers found’ and just to check I held down a couple of the buttons on the usb game controller for a couple of seconds to ensure it didn’t then start the normal assign buttons (up, down, left, right, start, select etc).
    Also, pressing F4 on the keyboard doesn’t then quit out of RetroPie back to the command prompt, the only way I’ve found to actually quit RetroPie back to commandline is to ssh into the Pi and ‘ps -ef | grep retropie’ to find the PID (Process Id) and then ‘kill X’ (where X is the Process Id of RetroPie).
    This then returns me back to the commandline prompt on the Pi where the keyboard works perfectly normally.

    Incidentally (but quite importantly), I’ve checked my usb devices by running ‘lsusb’ and it shows my usb keyboard and my usb game controller (along with the usb hub, the mouse on my usb hub and the usb mass storage device used by the external usb hard drive).

    Finally, in case it was something to do with the way the raspberry pi’s usb hub was working with the actual usb hub I’ve plugged into it, I’ve also tested the usb keyboard and the usb game controller plugged directly into the raspi and separately the usb hub, same result both times, the keyboard and the game controller remain unresponsive with the welcome screen when RetroPie starts up.

    This isn’t a issue with (somehow) assigning devices too quickly either, as I’ve run up RetroPie, ssh’ed into the pi, quit out of RetroPie and then started it up again by running ’emulationstation’ and the retropie welcome screen still is unresponsive to my keyboard and game controller.

    What is confusing me is that this is has been a project of mine for quite a while, I’ve been prototyping this for the last few months using an old IDE 2.5″ hard drive on a different USB mass storage interface (the current hard drive is SATA using a different USB mass storage interface) and for my initial prototyping test I imaged the drive with the standard raspbian image, then downloaded and used the github hosted script and everything went perfectly, with absolutely no problems like this I assigned the controller, copied some psx roms (and a bios) onto the pi and even played some games on it! (it’s currently carefully laid out all over my workbench in my garage, and there’s a quiet satisfaction with playing Tony Hawks Pro Skater amidst woodshavings and blobs of solder)

    The only thing that’s different between then and now is the USB mass storage adapter, the actual 2.5″ hard drive it’s plugged into and the timescale between then and now (somewhere between 4-8 weeks between the retropie setup script I’ve been running over the last week and the first time around where everything worked smoothly).

    Any ideas, any thoughts or suggestions at all would be greatly appreciated.
    It’s so close to being finished it’s galling.



    That is really odd- you have baffled as well. The only other thing I could think of is maybe just writing the retropie SD image directly to the SD card- that way you can at least rule out your hardware (harddrive or USB hub or adapter) I’ve never done anything with external harddrives or mounting them for a raspberry pi so I’m afraid I’m not much help when it comes to custom setups (you could also wait for the latest build in the next couple weeks because the controller module for emulationstation has changed so it might also affect how your controllers and keyboard respond.)



    Think I might have gotten to the bottom of it, doesn’t make a great deal of sense, but there’s little else left that it can be.

    So, I downloaded the image of RetroPie 2 (the raspi2 flavour) and applied it to my sdcard, booted to that (rather than the USB HDD) keeping only the keyboard and game controller on the USB ports and the keyboard and game controller were still unresponsive.

    This has previously worked perfectly with all the same things, the game controller, the pi2, the same tfs sdcard, the keyboard, all of it, which leads me to suspect there’s actually a fault with the USB Bus on the pi itself, which although it’s initial lookup works fine, actually binding at a deeper level is failing.

    The keyboard is likely to be seen as a simple HID device (or whatever the flavour is on linux, I’m speaking from windows knowledge) which as I recall doesn’t require any deep interrogation, whereas when I run retroarch-joyconfig (I think that’s what it’s called) it says it cannot find the device (yet it’s shown when I run lsusb).

    So, I’ve thrown £30 at amazon for a new pi2 and I’ll test again when the new one comes in.

    Cheers loads for the help on this. It’s been properly odd.



    New pi arrived today and made no difference.

    Guess the keyboard and game controller must be squiffy, I’ve spares of both so will test those.

    Think I’ve tripped over something really weird, here.




    ok. I’ve worked it out. Took some seriously sideways thinking though.

    I’m making some assumptions here, so please correct me if I’m wrong but there is some significant difference between what I believe is held in /boot/ for a standard installation of Raspbian and RetroPie.

    Reason I say that is this is how I was trying to get my setup working:

    SDCARD ¬
    RetroPie Image ¬
    RetroPie Beta 3 image (NOT installed using the script, literally the flat downloadable image)

    On first boot with the new RaspPi2 (I’ll check if this setup works on the old one in due course, just glad to have it working right now!) the keyboard and the game controller respond as they should.

    I then do the usual raspi-config to open up SSH, increase the GPU memory and overclock.

    Then I shutdown and plug in the External USB drive.

    USB HDD `
    Raspbian Image ¬
    Flat Raspbian image downloaded from ‘’

    I then use Fdisk to increase the SDA2 partition on the extUsb in readiness of using the extUsb as the main partition, with that done I change my /boot/cmdline.txt to reference the /dev/sda2 rather than the mmc(blah blah) sdcard partition.


    Now, at this point, what’s happening is the Pi initially fires up using the sdcard just enough to pick up the extUsb drive as the primary location and then runs up Raspbian, all good, I have a working keyboard and probably game controller (I’m currently on Raspbian right now).

    So I then go git’ (see what I did there) the from github and run the installation, which ADDS retropie to my raspbian setup on the extUsb drive. controller doesn’t work, neither does the keyboard..

    So, here’s what I think is happening.

    Something on the flat RetroPie Beta3 is assigning devices some how/where and storing that default config in it’s /boot info (or similar scope) and that’s fine as long as the rest of the RetroPie distro is the same version, but it’s not, its the version installed using the from github distro and something in that is looking elsewhere for device information

    I think this cos I’ve just wiped the extUsb and slapped RetroPie Beta3 image directly onto it, booted the pi with the boot section on the sdcard being RetroPie Beta3 and the extUsb being RetroPie Beta3 and BOOM, keyboard works, game controller works.

    TFFT! Bloody hate it when I can’t understand something.

    I’ll use your earlier post to install X back over the top of the RetroPie Beta3 on the extUsb now. 🙂



    …and LDXE is installed with a entry in Retropie menu to go to startx.

    🙂 happy bloke am I!

Viewing 13 posts - 1 through 13 (of 13 total)

Forums are currently read only - please visit the new RetroPie forums at