Keep your roms on and play from network share.

Welcome Page Forums RetroPie Project Everything else related to the RetroPie Project Keep your roms on and play from network share.

Tagged: , ,

This topic contains 24 replies, has 10 voices, and was last updated by  ashmck73 1 year, 7 months ago.

Viewing 25 posts - 1 through 25 (of 25 total)
  • Author
    Posts
  • #101513

    lordasshat
    Participant

    Keep your roms on and play from network share.

    I didn’t see this any where in the forums and thought it may be useful to any one who has more roms than space on their SD card.
    This is how i have mine set up, and it works well havent noticed any major issues. I am using a raspberry PI II and running psx isos through the share.

    1.) Create a windows share/Samba share on a computer/server in your house preferably hard wired. My share requires a username and password, you may skip step 3 if yours setup does not use them.

    2.) make a folder in your home dir
    mkdir ~/games

    3.) create the .smbcredentials file and set username and password
    nano ~/.smbcredentials

    
    username=smb-user
    password=smb-password
    

    press ctrl+x, Y, and enter

    chmod 600 ~/.smbcredentials
    4.) We now need to Edit the fstab so are PI will mount this share on boot. We need this to point to your server you can use the IP of your server or its Host name depending on your set up.

    sudo nano /etc/fstab

    past and edit
    //YOUR-SMB-Server/Path/To/Share /home/pi/games cifs credentials=/home/pi/.smbcredentials,iocharset=utf8,sec=ntlm 0 0

    Press ctrl+x, Y, and enter

    If your share has no username and password then use this fstab entry.
    //YOUR-SMB-Server/Path/To/Share /home/pi/games cifs guest,uid=1000,iocharset=utf8 0 0

    5.) To test that are share is working without rebooting we will now run a couple commands.

    sudo mount -a
    ls -al ~/games

    If all went well you should see the files & folders listed on your smb share.

    6.)Now for the last bit, run these commands to make a copy of your es_systems.cfg and edit to tune it to your setup.
    sudo cp /etc/es_systems.cfg /home/pi/.emulationstation/es_systems.cfg
    nano /home/pi/.emulationstation/es_systems.cfg

    Find the emulator that you want to use your new network share of infinite storage.
    I like to just comment out the path from the default set up like this.

    
    <!--    <path>~/RetroPie/roms/psx</path> -->
        <path>~/games/psx</path>
    

    Repeat for all emulators you are going to use with the network share.
    Press ctrl+x, Y, enter.

    You now can reboot your PI and verify that your roms show up and work.

    #101534

    tank
    Participant

    it’s not just ‘infinite’ space, it’s also more secure than keeping the games on the SD. just think about the savegames that would be lost, if your SD crashes! an SD crash is more likely than a HDD crash.
    also it’s centralized and 2 or more raspberry pis with retropie can access the same roms/savegames.
    you just need a NAS or a server

    RECOMMENDED – should be pinned 😉

    #101571

    petrockblog
    Keymaster

    you could just mount the network driver over the roms folder btw, that way you don’t need to adjust the emulationstation configuration.

    #101579

    lawbag
    Participant

    Great work.
    I personally would like to see this as a key feature of the next RetroPie build.

    I do have 2 Raspberry Pis running different versions of the emulators and would benefit from having all the ROMs and save states being in the same place.

    #101848

    mayki
    Participant

    Please help with the creation of a shared folder on Synology NAS.
    1) create share folder my NAS Synology “games”
    2) make a folder in your home dir mkdir ~/games OK
    3) create the .smbcredentials file and set username and password OK
    4) Edit the fstab PROBLEM

    proc            /proc           proc    defaults          0       0
    /dev/mmcblk0p1  /boot           vfat    defaults          0       2
    /dev/mmcblk0p2  /               ext4    defaults,noatime  0       1
    # a swapfile is not a swap partition, so no using swapon|off from here on, use  dphys-swapfile swap[on|off]  for that
    //192.168.0.101:/volume1/games /home/pi/games/ cifs credentials=/home/pi/.smbcredentials,iocharset=utf8,sec=ntlm 0 0 

    5) run commands sudo mount -a

    pi@retropie ~ $ sudo mount -a
    mount error: could not resolve address for 192.168.0.101:: Unknown error

    IP adres my NAS is 192.168.0.101.
    Where is the problem? Please help. Excuse my bad English, I’m from Czech Republic …

    #101855

    lordasshat
    Participant

    change //192.168.0.101:/volume1/games /home/pi/games/ cifs credentials=/home/pi/.smbcredentials,iocharset=utf8,sec=ntlm 0 0

    to

    //192.168.0.101/volume1/games /home/pi/games/ cifs credentials=/home/pi/.smbcredentials,iocharset=utf8,sec=ntlm 0 0

    Let me know if you have any other issues, I am glad to help. ^_^

    #101873

    mayki
    Participant

    After changing addresses:

    mount error(13): Permission denied
    Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)

    NAS Synology :

    DiskStation> cat /etc/exports
    
    /volume1/Video  *(rw,async,no_wdelay,crossmnt,insecure,no_root_squash,sec=sys,anonuid=1025,anongid=100)
    /volume1/Backup *(rw,async,no_wdelay,crossmnt,insecure,no_root_squash,sec=sys,anonuid=1025,anongid=100)
    /volume1/games  *(rw,async,no_wdelay,crossmnt,insecure,no_root_squash,sec=sys,anonuid=1025,anongid=100)

    Thank you for your help.

    #101879

    mayki
    Participant

    Change:

    username=smb-user
    password=smb-password

    To:

    username=user
    password=password

    Result:

    pi@retropie ~ $ sudo mount -a
    Retrying with upper case share name
    mount error(6): No such device or address
    Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)
    #101881

    lordasshat
    Participant

    I am guessing that your are trying to mount an NFS Share.

    sudo apt-get install nfs-common

    192.168.0.101:/etc/export/volume1/games on /home/pi/games type nfs rw,intr,tcp,nfsvers=3,rsize=16384,wsize=16384

    Remove nfsvers if server is running NFS V4 set to 2 if running NFS V2.

    sudo mount -a

    I do not have NFS mount points set up on my PI and am guessing from man pages and ubuntu documentation. it has been over a year and a half since i last set NFS up. That being said, I am willing to help if you would like.

    Please let me know if it works for you.

    #101888

    mayki
    Participant

    That’s what I put in fstab?
    192.168.0.101:/etc/export/volume1/games on /home/pi/games type nfs rw,intr,tcp,nfsvers=3,rsize=16384,wsize=16384
    If I do it:

    pi@retropie ~ $ sudo mount -a
    [mntent]: line 5 in /etc/fstab is bad
    #101889

    lordasshat
    Participant

    I set NFS up on my pi and have it working try this.

    192.168.0.101:/volume1/games /home/pi/games nfs _netdev,nfsvers=4,auto 0 0

    if that doesnt work try.

    192.168.0.101:/export/volume1/games /home/pi/games nfs _netdev,nfsvers=3,auto 0 0

    #101893

    mayki
    Participant

    Set as follows:
    192.168.0.101:/volume1/games /home/pi/games nfs _netdev,nfsvers=4,auto 0 0
    Error: mount.nfs: Protocol not supported

    Adjusted for:
    192.168.0.101:/volume1/games /home/pi/games nfs _netdev,nfsvers=3,auto 0 0
    mount OK however:

    pi@retropie ~ $ ls -al ~/games
    ls: cannot open directory /home/pi/games: Permission denied

    After logging in as root to see the game in your games using WinSCP.
    Only half a success … 🙂

    #101894

    lordasshat
    Participant

    try
    192.168.0.101:/volume1/games /home/pi/games nfs _netdev,rw,nfsvers=3 0 0

    i am using NFS4 on my server

    My cat /etc/exports

    /var/server     (sync,no_subtree_check,rw)
    
    #101895

    mayki
    Participant

    Set permission to folder “games” and now it works great.
    Thank you very much for your time and help. Children would be happy… 🙂

    #101896

    lordasshat
    Participant

    No problem.

    Set permission to folder “games” and now it works great.
    Thank you very much for your time and help. Children would be happy… :-)

    #111156

    simillarian
    Participant

    Is this supposed to work with CD games also? Regular games are working for me but CD games are not. I am trying it with turbografx cd games. Both my computer and pi are hard wired.

    #111159

    lordasshat
    Participant

    I havent tried to get turbografx cd games working, I do however have PlayStation games working as well as sega cd games. As far as i can tell it should work for the turbografx games. I had a problem with file extensions on the psx in my config once.

    #111161

    simillarian
    Participant

    I havent tried to get turbografx cd games working, I do however have PlayStation games working as well as sega cd games. As far as i can tell it should work for the turbografx games. I had a problem with file extensions on the psx in my config once.

    I just tested ps1 and segacd games. They work perfectly, so it’s just turbografx cd games. I will have the turbografx CD games on my SD card and they will run. I then procede to delete them from my SD card and edit es_systems.cfg to point to the shared directory and reboot. The turbografx CD games show up on ES, but they will not run.

    I will triple check my config file, but I am 99% sure it is correct. The only thing different with the turbografx from the other 2 systems is that it needs syscard3.pce hucard file in the rom folder to run cd games.

    Hopefully this will be the last edit lol. The error in my log is..
    Value too large for defined data typeError opening CD.
    The file sizes are the same as the ps1 and segacd files. I’ll do some research on this.

    #111175

    simillarian
    Participant

    FIXED IT!!! 🙂

    I had to add two options to /etc/fstab

    ,nounix,noserverino

    So, my file reads as…
    //YOUR-SMB-Server/Path/To/Share /home/pi/games cifs credentials=/home/pi/.smbcredentials,iocharset=utf8,nounix,noserverino,sec=ntlm 0 0

    Thank you for taking the time to write all of this. It’s much appreciated.

    #111198

    lordasshat
    Participant

    Thank You for posting the solution to your problem. I am glad every thing is working for you.

    #111418

    Robert Wilson
    Participant

    I too would like to see a way to do this built into the retropie software. I would love to put all the Roms on my NAS but I’m not very comfortable editing the files on the pi. Mainly for one when you go down to the command line on the pi the text is so darn small on my 47 inch tv. Which makes it even harder to work with.

    #111457

    rdhanded2
    Participant

    I can’t answer your question but you can remote log into your pi through putty or something similar and you can read the text on your pc much easier. You can even log in with a smart phone.

    Sent from my A0001 using Tapatalk

    #113003

    justinlarsen
    Participant

    Thanks for all the help in this thread. I was able to successfully get NFS working with my setup. One small thing to note is the games folder has changed in the newest version of RetroPie.

    For synology users here is the correct path:

    192.168.0.101:/volume1/games /home/pi/RetroPie/roms nfs _netdev,nfsvers=3,auto 0 0

    #122138

    lordasshat
    Participant

    Keep your roms on and play from network share.

    I didn’t see this any where in the forums and thought it may be useful to any one who has more roms than space on their SD card.
    This is how i have mine set up, and it works well havent noticed any major issues. I am using a raspberry PI II and running psx isos through the share.

    1.) Create a windows share/Samba share on a computer/server in your house preferably hard wired. My share requires a username and password, you may skip step 3 if yours setup does not use them.

    2.) make a folder in your home dir
    mkdir ~/games

    3.) create the .smbcredentials file and set username and password
    nano ~/.smbcredentials

    
    username=smb-user
    password=smb-password
    

    press ctrl+x, Y, and enter

    chmod 600 ~/.smbcredentials
    4.) We now need to Edit the fstab so are PI will mount this share on boot. We need this to point to your server you can use the IP of your server or its Host name depending on your set up.

    sudo nano /etc/fstab

    past and edit
    //YOUR-SMB-Server/Path/To/Share /home/pi/games cifs credentials=/home/pi/.smbcredentials,iocharset=utf8,sec=ntlm 0 0

    Press ctrl+x, Y, and enter

    If your share has no username and password then use this fstab entry.
    //YOUR-SMB-Server/Path/To/Share /home/pi/games cifs guest,uid=1000,iocharset=utf8 0 0

    5.) To test that are share is working without rebooting we will now run a couple commands.

    sudo mount -a
    ls -al ~/games

    If all went well you should see the files & folders listed on your smb share.

    6.)Now for the last bit, run these commands to make a copy of your es_systems.cfg and edit to tune it to your setup. (Updated 3/31/2016)
    sudo cp /etc/emulationstation/es_systems.cfg /home/pi/.emulationstation/es_systems.cfg
    nano /home/pi/.emulationstation/es_systems.cfg

    Find the emulator that you want to use your new network share of infinite storage.
    I like to just comment out the path from the default set up like this.

    
    <!--    <path>~/RetroPie/roms/psx</path> -->
        <path>~/games/psx</path>
    

    Repeat for all emulators you are going to use with the network share.
    Press ctrl+x, Y, enter.

    You now can reboot your PI and verify that your roms show up and work.

    #122142

    ashmck73
    Participant

    Great work – don’t know why I didn’t see this thread earlier. Off to try it myself on my Synology NAS.

Viewing 25 posts - 1 through 25 (of 25 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/