Just cant get RetroPie to work properly

Welcome Page Forums RetroPie Project Everything else related to the RetroPie Project Just cant get RetroPie to work properly

This topic contains 4 replies, has 2 voices, and was last updated by  ryux 3 years ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
  • #84911


    Hey guys

    I am giving up now.. i tried almost everything i can to get this thing working.

    On my first try i installed the 2.3 SD Card Image.. set everything up.. put it never found SDL, Sound didnt work, and Controls didnt work

    On second try i installed raspbian and compiled everything (letting it run for over 24 hours).
    Now SDL worked, but everything was crashing all the time (even though i didnt overclock)

    On third try i did the same with the Binary Install.
    I could get SDL working and the sound was ok.. But when starting a NeoGeo Game in FBA only the buttons worked, i was reading through endless forum topics because i couldnt find how to get my AXIS working (because my Controller Handles Left/Right/Up/Down as a Button).
    I also tried jstest which gave me unlogical results on the Axis (Left Axis 6, Right No Axis, Up Axis 9, Down Axis 10).

    I then tried another 3-4 times with different types of handling/installing/configuring stuff..

    I tried to manually edit the Retroarch.cfg with the correct settings

    input_device = "Sony PLAYSTATION(R)3 Controller"
    input_driver = "udev"
    input_b_btn = "14"
    input_y_btn = "15"
    input_select_btn = "0"
    input_start_btn = "3"
    input_up_btn = "4"
    input_down_btn = "6"
    input_left_btn = "7"
    input_right_btn = "5"
    input_a_btn = "13"
    input_x_btn = "12"
    input_l_btn = "10"
    input_r_btn = "11"
    input_l2_btn = "8"
    input_r2_btn = "9"
    input_l3_btn = "1"
    input_r3_btn = "2"
    input_l_x_plus_axis = "+0"
    input_l_x_minus_axis = "-0"
    input_l_y_plus_axis = "+1"
    input_l_y_minus_axis = "-1"
    input_r_x_plus_axis = "+2"
    input_r_x_minus_axis = "-2"
    input_r_y_plus_axis = "+3"
    input_r_y_minus_axis = "-3"

    And i tried these settings in fba2x.cfg

    # Get codes from "jstest /dev/input/js0"
    # from package "joystick"
    #Joystick axis

    It is a Arcade Stick for PS3 (also working on USB PC) but in theory it only has D-PADs, no real analog stick (i think)

    So now i am formatting everything again (which is always a pain because i have to make a modified “interfaces” file to get my WLAN Stick working before i can even connect with SSH).

    Anyone know how i can get FBA to make my Joystick work ? i remember having it working once (or maybe i was hallucinating because i was trying around for 2 days nonstop).

    I also tried the RetroArch Joystick Registration Script on RetroPieSetup.sh
    Also no luck

    I tried to have a customized RetroArch.cfg in the FBA Configs folder – no luck
    I tried to modify fba2x.cfg in every different way (on the joystick axis part).
    With some numbers i atleast got it to move by its own 😛

    I dont know what i should do
    Are there any alternatives similar to RetroPie Project i could check out ?
    Are there any alternatives to FBA which doesnt need an Axis Configuration for UP/DOWN/LEFT/RIGHT ?

    Any other hints on how to get my Arcade Stick working ?

    I got the feeling that with this Raspberry Pi Stuff you just make one wrong step and you fuck everything up and can start again from scratch, that sucks..

    Thanks guys for everyone who is willing to help 🙁



    erm, you may not need to reformat your card every time. i have been doing this too and i think you can just delete all of the folders/files and then start over again

    i would also recommend that you SSH over ethernet if you can, it would be a lot easier

    get yourself the FBA-libretro, not the regular FBA. this one will read the controller config file that you “Register RetroArch Controller” with

    EDIT: i would like to mention that i have gotten FBA (both versions) to work with multiple controllers so it is possible. just give it another go



    Hello, first of all thanks for the answer.

    I can tell the following now.

    The Controls are working with FBA-libretro, but its damn slow, even with high overclocking (arm 1100, gpu 440, sdram 600, core 550)

    The normal FBA works, not with all roms, but still i cannot move because it NEEDs Axis for UP/DOWN LEFT/RIGHT.. so i cannot use this one either

    Gngeo Pi – Best Performance – No sound issues, good framerate, but Buttons Lag and after some seconds of playing get stuck (so i move right and it will continue moving right and not take any new controls).

    In the past hours i tried every different driver combination known to mankind (input / video and audio driver in all different combinations because i thought it would make a difference).. But as far as i can tell, the issues remain, and stay the same.

    I also can only choose SDL2 in audio and video (maybe SDL2 is not so good because i got laggy audio on FBA-libretro). I reinstalled the SDL 1.2 but it still is not showing in the RetroArch Features List (do i have to uninstall SDL 2 ?)

    So for now i would be the happiest guy if FBA-libretro wasnt so slow (i like the shaders, the Controls are working, but the Audio is lagging and the Framerate as well)

    I also tried different Modes and Audio Rates, turning Video Threading ON/OFF, all sorts of Options inside the Retroarch.cfg without any luck.

    I am slowly losing faith that my project of building a nice Arcade Station will burst into flames.

    Any other suggestions 🙁 ?



    Hey guys.. some nows from the front..

    Still have performance issues with the Libretro version of FBA, i would really love to get this one to work, could it be that i only can use SDL2 instead of normal SDL ?

    I also took the time today to use an older USB Gamepad i had layin’ around and test if it uses Axis.
    I used jstest and saw that this one should work, so i took it all apart, figured out the wiring and installed the PCB in my Arcade stick.
    Now my Arcade stick is working perfectly (also i have faster response on the buttons) yay 😀



    So another update for today

    Performance got a little better.. i applied some of the tweaks from this homepage and free’d up more RAM that way


    The Controller that i rebuild with another PCB is working really really well now, so i am happy with that.

    I have a heatsink and a small fan on my Raspberry Pi B+ and run with the following settings in config.txt (i found that force_turbo improved performance)


    So i will keep you updated on any progress i make. But At least i could play the games in gngeo pi, but to be honest, i enjoy the shaders in FBA-Libretro and really would love to have everything running on that specific emulator.


Viewing 5 posts - 1 through 5 (of 5 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

PLEASE NOTE: All orders that are placed between January 14th and January 28th will be shipped on January 29th. Dismiss