jstest: command not found

This topic contains 5 replies, has 3 voices, and was last updated by Profile photo of herbfargus herbfargus 1 year, 8 months ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #107618
    Profile photo of ezeitgeist
    ezeitgeist
    Participant

    I am trying to re-config my specific emulators and keep running into some snags. Specifically, I have 2 joypads setup on an arcade style space and Player 2 (right side) registers as Player 1 and I am trying to switch them.

    I tried to run:
    jstest /dev/input/js0

    but got a “jstest: command not found” response.

    Tried with /js1 and got same response. Am I missing something?

    I don’t know if it will solve the problem of switching the controllers (both joystick and 6-buttons are the same (1 for each) “DragonRise Inc. Generic USB Joystick” device, but at the least it would get me a step closer to figuring out what is going on.

    Any help would be greatly appreciated.

    #107620
    Profile photo of petrockblog
    petrockblog
    Keymaster

    you don’t have jstest installed. It’s in the Debian “joystick” package.

    #107621
    Profile photo of ezeitgeist
    ezeitgeist
    Participant

    (1) How do I install it?

    (2) Any advice on switching P1 and P2 in games (either universally or individually)?

    #107622
    Profile photo of herbfargus
    herbfargus
    Member

    1.: https://www.raspberrypi.org/forums/viewtopic.php?t=19900&p=450651

    2.: switch the usb port or swap hands?

    #107709
    Profile photo of ezeitgeist
    ezeitgeist
    Participant

    Thank you! I swear I tried switching the USB multiple times, to no avail, but of course, when you type it and I try, it works.

    Much appreciated!

    #107715
    Profile photo of herbfargus
    herbfargus
    Member
Viewing 6 posts - 1 through 6 (of 6 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar