Issues with starting EmulationStation

Welcome Page Forums RetroPie Project Everything else related to the RetroPie Project Issues with starting EmulationStation

This topic contains 4 replies, has 2 voices, and was last updated by Profile photo of shyo shyo 3 years, 2 months ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #6173
    Profile photo of shyo
    shyo
    Participant

    So, after a couple of attempts at getting raspbian + emulationstation up and running, plus RetroArch and all the other Emulators that I want to use configured, everything checks out and is good to go. GBA was working smooth, SNES was running at ~25 fps. So I figured I need to overclock a bit and change my memorysplit – overclocked it to the “modest” setting, split memory to 192 (it was not overclocked and on 128 before), but now all I get when starting ES is a black screen with a white dot. I understand this means that SDL is initialized and good to go, but ES just stays there and doesnt boot.
    I had it sitting on there for 15 minutes before I tried to kill ES – none of the combinations that I could think of work (ctrl+c, F10, F4, ESC, …..), so I just unplugged my pi, changed back my OC and memsplit settings, but nothing changes.
    I checked es_log.txt, and the last line is “lvl2: Loading system config file…”. Thats it. I’m clueless as to what to do now, short of reinstalling everything (I compiled it from sources and I dont want to spend another 8 hours waiting for it :/) The only change I made to existing scripts is that I changed the ROM folder for all emulators (except the ES interface one) to my USB stick and all my configuration was done through the EmulationStation and RGUI interfaces.

    My other issue is that on mupen64plus I didnt get any video, just a ton of RSP errors that scrolled so fast it was hard to read what the exact error is before it terminated.

    I hope this made sense, I’m new to the whole *nix and pi thing. Any help is appreciated!

    #6176
    Profile photo of trimmtrabb
    trimmtrabb
    Participant

    did you edit es_systems to the new rom paths?

    If you have found the solution to your problem please mark the topic as resolved.

    #6179
    Profile photo of shyo
    shyo
    Participant

    Yeah – it was working fine before, running the ROMs off of the USB, i didnt unplug or change anything in it, all I changed were settings in raspi-config

    #6187
    Profile photo of trimmtrabb
    trimmtrabb
    Participant

    It could be Emulation Station isn’t picking up any roms where it expects to find them, so it’s not displaying any emulator pages, check the paths match in es_systems. You could also try putting a couple of roms on the SD card to see if ES picks them up. Also there might not be enough video ram allocated, double check your config.txt incase you have made a mistake.

    If you have found the solution to your problem please mark the topic as resolved.

    #6196
    Profile photo of shyo
    shyo
    Participant

    So .. its still happening. I have no clue what causes it – if I delete/reset my es_systems.cfg, it works just fine, until the next reboot.

    this is the content of my es_log.txt :

    lvl2:   Created surface successfully!
    lvl1:   Could not find unconfigured joystick named "Sony PLAYSTATION(R)3 Controller"! Skipping it.
    
    lvl1:   Could not find unconfigured joystick named "PLAYSTATION(R)3 Controller (00:06:F5:D4:97:13)"! Skipping it.
    
    lvl2:   Loaded InputConfig data for 1 devices.
    lvl2:   Created font "/usr/share/fonts/truetype/ttf-dejavu/DejaVuSerif.ttf" with size 35. textureID: 1
    lvl2:   Created font "/usr/share/fonts/truetype/ttf-dejavu/DejaVuSerif.ttf" with size 46. textureID: 2
    lvl2:   Created font "/usr/share/fonts/truetype/ttf-dejavu/DejaVuSerif.ttf" with size 102. textureID: 3
    lvl2:   Loading system config file...
    

    this of my es_systems.cfg:
    http://pastebin.com/imFCkwXr

    its always from the same USB stick – is there a different/better way to load roms from an USB stick that might not cause these problems?

    edit:
    reformatted usb, rebuild the entire image + retropie from scratch, still, same problems. after editing es_systems.cfg, it will only boot the first time and lock up every subsequent attempt (until es_systems.cfg gets reset)

    edit2:

    so .. im at a total loss here. basically, if I change permissions for /media/usb/roms in the desktop environment, log out, start es, everything works fine. but i cant seem to figure out how to make this a permanent change

    edit3:

    in case anyone ever runs in the same problem, I fixed it – created a specific mounting point with default permissions in /etc/fstab.

Viewing 5 posts - 1 through 5 (of 5 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar