Issues setting up Retropie/EmulationStation

Home Forums RetroPie Project Everything else related to the RetroPie Project Issues setting up Retropie/EmulationStation

This topic contains 4 replies, has 2 voices, and was last updated by Profile photo of herbfargus herbfargus 2 years, 2 months ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #93391
    Profile photo of jeffersonlam
    jeffersonlam
    Participant

    I discovered the Retropie project recently on Lifehacker (http://lifehacker.com/how-to-turn-your-raspberry-pi-into-a-retro-game-console-498561192) and have been trying to get it set up. I’ve been looking at a number of resources and I haven’t been able to figure this out.

    I’m trying to get EmulationStation to run.

    So far, I’ve:

    1. Installed the RetroPie image onto my formatted SD card
    2. Expanded the filesystem
    3. Attempted to configure my controllers (https://github.com/retropie/RetroPie-Setup/wiki/RetroArch-Configuration) (I don’t know if it worked and I don’t have a way it testing it.)
    4. Successfully transferred a ROM to the Pi using a USB stick

    I’m trying to play the game now, and am having trouble getting EmulationStation running. How do you run it? Is there a command? From what I’ve read it looks like it should run automatically when you reboot the Pi. When I reboot it, I see the RetroPie splash screen, and then it spits me back out on the command line.

    In short: How do I run EmulationStation?

    #93429
    Profile photo of herbfargus
    herbfargus
    Member

    you can type “emulationstation” (without quotation marks) into the terminal and it should open up. it should boot directly into emulationstation, if it doesn’t you can go into the set up script under the setup option and change emulationstation to start on boot.

    #93495
    Profile photo of jeffersonlam
    jeffersonlam
    Participant

    Ahh ok, made some headway on this problem. Running ’emulation station’ returns this error:

    /usr/bin/emulationstation: line 11: 2500 Illegal instruction $es_bin "$@"

    I did some googling and it turns out that this error comes up if you’ve installed the RetroPie Raspberry Pi 2 image on a Raspberry Pi 1. I thought I had a Raspberry Pi 2 but I was mistaken: I have a Raspberry Pi B+ v1.2 (RPi1 basically), and I have the Retropie Raspberry Pi 2 image installed.

    I’ll reinstall everything with the Retropie Raspberry Pi 1 image and see if it works.

    #93583
    Profile photo of jeffersonlam
    jeffersonlam
    Participant

    It’s all working! Thanks for the help 😀 I’m now successfully playing SNES games on the big screen with the RPi

    #93586
    Profile photo of herbfargus
    herbfargus
    Member

    Good job! Its always the simplest things that get you :p

Viewing 5 posts - 1 through 5 (of 5 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar