Issue with NES/SNES RetroKit and player 2

Welcome Page Forums RetroPie Project Controller Configuration in RetroPie Issue with NES/SNES RetroKit and player 2

This topic contains 5 replies, has 3 voices, and was last updated by Profile photo of rdhanded2 rdhanded2 2 years ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #92183
    Profile photo of rdhanded2
    rdhanded2
    Participant

    http://www.retrousb.com/product_info.php?cPath=21&products_id=44

    I purchased 2 of the above kits for my NES build. I have both solderd up correctly. I can run a jstest on js0 and js1 and all buttons function correctly and display as the same between the 2 separate controllers I have installed. The issues I have is all buttons work on either controller in the emulation station menu. I can use start and select for settings from either controller. My issue is that when in a game only select and start work on the player 1 controller, they will not work on player 2. I don’t mean hotkeys, I know hotkeys won’t work on the player 2 controller. I mean select and start will not work at all. It does not matter if I remove the joystick I have plugged into player 1 or not, it is the same issue. I am using the following settings.

    input_device = “RetroUSB.com RetroPad”
    input_driver = “udev”

    input_b_btn = “0”
    input_a_btn = “1”

    input_select_btn = “2”
    input_start_btn = “3”

    input_up_axis = “-1”
    input_down_axis = “+1”
    input_left_axis = “-0”
    input_right_axis = “+0”

    input_enable_hotkey_btn = “2”
    input_exit_emulator_btn = “3”

    input_save_state_btn = “1”
    input_load_state_btn = “0”

    I have tried recognizing it as a usb, and adding them to the retroarch.cfg file but both have the same outcome. Anyone have any ideas as to why this might be happening?

    #92198
    Profile photo of alegeobla
    alegeobla
    Participant

    I’m using two NES USB controllers and am having the same issue. In emulationstation the second controllers start and select buttons work, but in roms only the first controllers work. I have mapped both controllers and cant find the issue, but its the same problem youre having. Hopefully someone can explain

    #92221
    Profile photo of rdhanded2
    rdhanded2
    Participant

    Ya, it is weird. Hopefully someone smarter than me comes along. lol

    #93815
    Profile photo of hobo
    hobo
    Participant

    I’m having the exact same problem, but with two of these controllers:
    http://www.amazon.com/Gtron-Retro-USB-Super-Classic-Controller/dp/B00FFL7WRS

    They work absolutely fine other than this one specific problem. This ONLY affects NES for some odd reason, as I’ve tested both controllers and identical configs for both SNES and Genesis/Megadrive emulators, and Player 2’s start button works just fine in those. For NES emulators, Player 1 works flawlessly, both select and start are fine. However, Player 2’s select and start buttons will not register during gameplay, no matter what. They can be bound in the RetroArch menu, the button press is recognized, but then fails to work in-game. Changing the buttons used for Player 2 select and start buttons doesn’t work (bound to L/R triggers, for instance), switching the controllers doesn’t fix it, resetting the config to default didn’t help, changing cores does nothing, and I even reimaged my microSD and started completely over, still doesn’t work. This is an extremely frustrating problem, as there’s seemingly no cause for it that could be attributed to user error. It’s some kind of as-of-yet unknown compatibility issue or bug in the software. If anyone has any idea what this could be, PLEASE help. I’m desperate and out of solutions.

    #95955
    Profile photo of rdhanded2
    rdhanded2
    Participant

    Bump in case anyone has any ideas.

    #100596
    Profile photo of rdhanded2
    rdhanded2
    Participant

    This issue is fixed now. It started working in all emulators other than nes for me recently, not sure which update. I swapped nes emulator to nestopia and player 2 select and start works in there now as well.

Viewing 6 posts - 1 through 6 (of 6 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar