Issue with keyboard layout not changing

Welcome Page Forums RetroPie Project New to RetroPie? Start Here! Issue with keyboard layout not changing

This topic contains 1 reply, has 2 voices, and was last updated by Profile photo of phubar phubar 1 year, 8 months ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #107357
    Profile photo of xion824
    xion824
    Participant

    New to Raspberry Pi and RetroPie. So sorry for the noob questions.

    Making changes for US keyboard layout is not working for me. I get UK keyboard layout. I have tried the Internationalization menu changes, timezone/keyboard/country of origin changes. I have tried from command line with the “setxkbmap us” command. Also tried the “dpkg-reconfigure keyboard-configuration” command. I have manually updated the /etc/default/keyboard file. Tried generic 102/104 US keyboard layout. Rebooted numerous times. Every window shows US for keyboard type. Command line changes made with sudo (I even redid the changes directly as root – yes, root. I know. I’m a RHCE, so I understand). Are there any other configurations I should look at?

    #107603
    Profile photo of phubar
    phubar
    Participant

    I downloaded and installed a fresh 3.1 image and have run into the same or similar issue.
    I changed locales and keyboard via:
    sudo raspi-config

    I am using a generic keyboard and the @ and ” keys are interchanged. None of the other keys are incorrectly mapped which would be typical of GB vs US locale.

    I’ll let you know if I find a resolution.

Viewing 2 posts - 1 through 2 (of 2 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar