Is imame4all-libretro = mame4all?

This topic contains 6 replies, has 3 voices, and was last updated by  dkcdocdos 3 years, 2 months ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #81772

    dkcdocdos
    Participant

    So after running into the commonly known mame-issues, i’ve read one should use mame4all instead of the preset mame, but it has to be installed manually (i’m running the 2.3 image).

    Before i tried, i found the directory

    /opt/retropie/emulators/mame4all-pi

    obviously containing mame4all already (right?).

    Then, i even discovered (feeling like indy by the time) in

    /etc/emulationstation/es_systems.cfg

    the line

    <!-- alternatively: <command>/opt/retropie/emulators/RetroArch/installdir/bin/retroarch -L /opt/retropie/emulatorcores/imame4all-libretro/libretro.so --config /opt/retropie/configs/all/retroarch.cfg --appendconfig /opt/retropie/configs/mame/retroarch.cfg %ROM% </command> -->

    and used this one instead of the standard <command>.

    Something must have worked; when i run mame now it’s apparently a different emulator, since it renders differently.

    However, none of the roms that weren’t working before now do (which didn’t raise too much suspicion) BUT those that do (and did before) now run even more sloppy (@900 mhz) AND i can’t access the mame menu via tab.

    So is this the recommended mame4all or even another one and i still need to do the manual way?

    regards (and sry for the spelling :))

    #82146

    dkcdocdos
    Participant

    See, i hate bumping threads, but this one is real important to me, so *bump*

    tl;dr of my first post:
    #1: Is MAME4ALL already part of 2.3 (since there’s a folder already)?
    #2: Is using the alternative MAME <command> in es_systems the right way to make it work?

    sry for bumping :~

    #82147

    exonerated
    Participant

    Im not 100% on this but it looks like you switched to the alternative MAME emulator. By default, retropie uses MAME4ALL. The es_systems contains the alternative emulator (usually an alternative because it doesn’t run as well for most people as the default set emu). Looks like you switched to the alternative emulator which would explain your performance decrease.

    #82177

    RetroMarine
    Participant

    Use the original one…just make sure your MAME roms are of the right romset…I think it’s 0.37b5 rom sets. That’s what I have and most of them work.

    #82179

    exonerated
    Participant

    RetroMarine is correct. The correct romset is 0.37b5. I can confirm most games from that set are working fine with the default MAME from the 2.3 image.

    #82220

    dkcdocdos
    Participant

    Thx for the answers so far, great community here!

    The alternative’s performace is really poor, wonder why it’s in the image…

    As far i’ve understood, that romset-thing is like the “version” of the rom. I don’t have to do anything with MAME itself or some config, but only *cough* 😉 find the “correct” rom for M4A.

    Right?

    #82424

    dkcdocdos
    Participant

    Follow up question: how do i tell which romset a rom is? Try and error? Or is there a way to tell beforehand?

Viewing 7 posts - 1 through 7 (of 7 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

PLEASE NOTE: All orders that are placed between January 14th and January 28th will be shipped on January 29th. Dismiss