IPAC-2 Keyboard control issues

This topic contains 12 replies, has 6 voices, and was last updated by Profile photo of jimblas jimblas 2 years, 1 month ago.

Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
    Posts
  • #3587
    Profile photo of Tomas
    Tomas
    Participant

    Hey all! New member here (long time reader tho) with lots of love for this wonderful project! I have built this arcade cabinet for a dear friend and the final part is to get the controls set up for the only emulator I’m running on the Retropie – the Picodrive.

    I have installed the IPAC-2 along with 2 arcade joysticks start buttons and action buttons, testing it’s functionality in various text editors and programming tools (downloadable from Ultimarc.com) and it’s working flawlessly. Setting up the Emulationstation controls works without problems too.

    BUT

    Since a week or so I’ve been trying to get the retroarch config file correct – all with various but all more or less catastrophic results =(. Nothing I do in the Retroarch config file seems to have any effect whatsoever and I’m getting really frustrated. I’ve been reading these forums trying out all kinds of things without success:

    1. Updated pretty much everything
    2. Tried to disable SNESDev
    3. Installed a powered USB-hub
    4. Reprogrammed the IPAC-2 controller to use the exact keys understood by Retroarch

    Any hints, tips, suggestions or advice would be really appreciated since this cabinet will soon have to be wrapped up in christmas paper! =)

    ps. English is not my native language so please ask me to clarify if some things doesn’t make sense ds.

    Cheers and many thanks in advance!
    Tomas

    #3752
    Profile photo of nraygun
    nraygun
    Participant

    Did you get a response from anyone?

    I’m trying to do the same thing. It seems that the RetroPie frontend can take the keyboard commands, but the emulator doesn’t.

    It might have something to do with the fact that the Ultrimarc is keyboard #2.

    I’d be interested in any answers you get.

    #3753
    Profile photo of newsworthy
    newsworthy
    Participant

    Hi guys, I’m having the exact same issue. First, it started when the Start and Coin buttons wouldn’t respond in any emualtors (And pressing Start would also hit SW8, randomly), and after avoiding using the start input and changing it to Switch 1A and remapping inputs via the ES config tool, now, pressing left on the joystick causes button one to fire as well as jump. Weirdly.

    I also am very interested in hearing workarounds, or solutions. I’ll keep tinkering myself and try and post my results.

    Retropie Beginner/Tinkerer

    #3754
    Profile photo of newsworthy
    newsworthy
    Participant

    I just found this actually, and I might try running it from the Pi at some point. It’s a Linux based iPac utility for programming.

    http://www.zumbrovalley.net/readpost.php?artid=6

    Retropie Beginner/Tinkerer

    #3757
    Profile photo of Tomas
    Tomas
    Participant

    Hi,

    Nothing yet, sadly. Perhaps getting Retroarch to team up with an IPAC is trickier than I initially thought.

    Since the cabinet was a christmas gift I had to get creative and went for a customized PC running Maximus Arcade on Win 7 =(

    I will however give this another try on the next cabinet coming up! If this could be set up properly it will be the Shangri-La of cost efficiency =) The Pi is just a wonderful little thing!

    Thanks!
    Tomas

    #3758
    Profile photo of nraygun
    nraygun
    Participant

    Well, I had to abandon ship and went with a different MAME implementation on my cocktail table machine. It also has a nice front end. It’s called MAME4ALL.

    My prior frontend that I wrote was having some problems since I re-imaged my machine so I’ve been looking for a replacement.

    MAME4ALL seems to work well but now I need to find some old ROMs. I just don’t get why MAME emulators change the way they handle ROM files. Seems to me that once a ROM is dumped, it should be the same forever. Whatever.

    I can code a little, so maybe at some point I’ll take a look at RetroPie.

    #83565
    Profile photo of caldiniho
    caldiniho
    Participant

    The problem is that the i-PAC come standard with stupid left alt and right alt and all that rubbish.

    Solution:

    Download win ipac for your pc, plug in the i-PAC 2 run the program and change each button including the start and coin buttons to a letter on your keyboard. Be careful not to double use the letters that are also used for player 2’s joystick.

    Once you have done this, plug the I-PAC back into the pi and boot. Head into esconfig and map your keys, they should all work from here.

    The problem i now have is that every button is coming up as player 1? Nothing is recognised as player 2 and i have no idea how to do it?

    Help

    Thanks in advance.

    #93912
    Profile photo of jimblas
    jimblas
    Participant

    I am a total newbie to this, but thought I was a little versed in getting the raspberry pi configured so I could play some games on a stand up arcade that I built from scratch. However…..I am having major issue with getting anything to work with my IPAC2. I have my raspberry pi with a downloaded image of retropie v2.3, a standard keyboard, my IPAC2 wired with standard arcade buttons and two joysticks. I can get the joystick to move left and right in es to maneuver thru emulators, but I cannot get it to select the game at all, much less play anything.

    I simply went into /opt/retropie/configs/all and uncommented the lines for keyboard controls. Then made sure that my IPAC 2 was configured accordingly with the same values. But nothing works at all.

    I am attaching my retroarch.cfg file in the hopes that someone can help this DA get his crap together. It has been very frustrating.

    Thanks for any and all help.

    #93915
    Profile photo of jimblas
    jimblas
    Participant

    I have been able to get the retroarch.cfg configured so that I can play mame and only mame games. Nothing responds in other emulators. Gives me the reply that the lshift, 5,2, etc keys aren’t found. I am attaching a screen shot of that.

    I tried replacing the lshift, ralt, etc with letters from keyboard, making sure that I didn’t duplicate one. But when I tried to run configuration within es, each time I pressed what it was asking for, it timed out, like it wasn’t registering my buttons.

    After looking through all these posts and spending a couple of hours, I am beginning to think there’s no one real solution. It is still very frustrating.

    Is there anyone out there with enough experience and patience to help an old man out!! LOL

    Jimblas

    Attachments:
    #93993
    Profile photo of chdez77076
    chdez77076
    Participant

    I had problems with mine but its fixed!!!
    If it helps out i downloaded the recent firmware for it on the ultimarc page.

    Then i configured each retroarch.cfg for every system.

    i setup a hot key and i changed all the keyboard presses for all keyboard options (fast-forward, volume up, etc etc etc) to “nul” without the “”.
    Then i just adjusted each player control with a push of the buttons!

    A lil tip is to not use the ALT or CTRL or SHIFT buttons.
    for some strange reason retroarch hates them 🙂

    You can change which keyboard key is setup for which button using the winipac program on the ultimarc page.

    Hope that helps!

    #93994
    Profile photo of chdez77076
    chdez77076
    Participant

    i Would also start with Retropie 3.0

    #97816
    Profile photo of jimblas
    jimblas
    Participant

    Hey there chdez77076,

    Would you be willing to share the config file settings you used to get things working? I am in the midst of starting over with latest image (3) and would like to have some success this time.

    I would appreciate it so very much as I am sure others struggling with this issue would as well.

    PLEASE

    #98567
    Profile photo of jimblas
    jimblas
    Participant

    How about attaching your control file (retroarch.cfg)? May have to send it as a .txt file so that it is allowed.

    PLEASE!!!!

Viewing 13 posts - 1 through 13 (of 13 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar