Input stops registering

Tagged: 

This topic contains 9 replies, has 3 voices, and was last updated by  paptorts 2 years, 9 months ago.

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #93846

    paptorts
    Participant

    hi, sometimes the input will stop registering midgame.
    Pi Model: 2
    RetroPie Version Used: 2.6.0
    Built From: SD Image
    USB Devices connected: iBuffalo retro controller
    Controller used: iBuffalo retro controller
    Error messages received: none! just stops working
    How to replicate the problem: play any GBA game for a few minutes, or go through the menu for a few minutes.

    #93847

    herbfargus
    Member

    Could be a power issue: do you have a power supply that is at least 1 amp? I use a 5v 2amp power supply and it seems to work fine, if it is a power issue you could look into getting a powered USB hub.

    It also could be a faulty controller.

    Or it could be wonky config files.

    Does it do it for all games and emulators as well as in emulation station or is it just GBA?

    #93848

    paptorts
    Participant

    it says the output is 5v 2000mA

    I thought it might be the controller too, but when I have a keyboard plugged it that won’t work either.

    I used the configuration files provided by the howchoo retro gaming rig set up

    it happens for all emulators, but it seems to happen to the GBA one the quickest.

    #93852

    herbfargus
    Member

    well then that rules out the power supply. The only thing I can think of if you are using manual configurations is to change the line in

    opt/retropie/configs/all/retroarch.cfg

    input_autodetect_enable = true
    to
    input_autodetect_enable = false

    There are a bunch of videos linked on this page from Floob who has the same controller as you, so it might lead you in the right direction of what configurations will work for your controller:

    https://github.com/retropie/RetroPie-Setup/wiki/RetroArch-Configuration

    #93854

    paptorts
    Participant

    it’s happening so soon now that I can barely go through the menus.

    #93856

    herbfargus
    Member

    yeah, it’s not super ideal- a new method of key input is currently being developed that will be hopefully incorporated in the next release of RetroPie- it will just be a one time input with the same interface as emulationstation- it will vastly simplify things.

    #93859

    Floob
    Member

    The iBuffalo should work fine out of the box with 2.6.0

    So on the tutorial you followed:
    http://howchoo.com/g/n2qyzdk5zdm/build-your-own-raspberry-pi-retro-gaming-rig

    Go to step 11 and undo that. Then try again.

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #93861

    paptorts
    Participant

    I’ve tried that as well, nothing seems to help. I want to get two controllers working so my cfg is exactly this http://blog.petrockblock.com/wp-content/uploads/2014/11/retroarch.txt

    #93864

    Floob
    Member

    A stock version of /opt/retropie/configs/all/retroarch.cfg should be fine.
    Yours seems tweaked.

    Try making these changes
    xinput_player1_a = x
    to
    input_player1_a = x

    Put a hash # at the start of these lines

    input_player1_l2 =
    input_player1_r2 =
    input_player1_l3 =
    input_player1_r2 =

    Remove these lines (as your setup is pulling them from the auto config anyway)

    input_enable_hotkey_btn = 8
    input_exit_emulator_btn = 9
    input_menu_toggle_btn = 5

    Check this for multiple controllers:
    http://dai.ly/x2i0lsy

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #93879

    paptorts
    Participant

    it might be a faulty controller? I got a second one and it hasn’t been problematic.

Viewing 10 posts - 1 through 10 (of 10 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

PLEASE NOTE: All orders that are placed between January 14th and January 28th will be shipped on January 29th. Dismiss