InfiniteNESLives SNES gamepad help?

Welcome Page Forums RetroPie Project Everything else related to the RetroPie Project InfiniteNESLives SNES gamepad help?

This topic contains 6 replies, has 2 voices, and was last updated by Profile photo of kinget kinget 2 years, 11 months ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #14964
    Profile photo of kinget
    kinget
    Participant

    Hi guys!
    I had some cheap SNES usb controllers working quite good for a few months, but I decided to investigate in a more genuine feeling-pad.
    So I bought 2 SNES usb pads from InfiniteNESLives. Very nice quality!

    I was hoping that my current cfg’s would work, but no such luck!

    Previously, my cheap controllers was used in the Emulation Station menu, and also working flawless in all of the emulators Im running (nes, snes, genesis, mastersystem, gb etc).

    I successfully configured the InfiniteNESLives controller to run properly in the menu (Emulation Station), and I also ran the RetroArch-Joyconfig to configure it properly, just as I did with my previous controllers!
    The config went fine, however when I try to start a SNES game from within emulationstation, the controls are messed up inside the game.
    Start is acting as the Y button, R1 acting as the start button etc.

    Does someone own a infiniteNESlives snes usb controller? Would that someone be kind and post the ~/RetroPie/configs/all/retroarch.cfg to me? 😉

    I would be very happy and thankful!

    Oh, I also had the select + L1 to save state, and select + R2 to load state.
    And select + start taking me back to emulation station..

    All I really care about is getting the SNES games running as intended with correct buttons, as I found that these controller settings worked great with the other emulators as well!

    Again, thanks in advance! I’ve been struggling with this for hours and hours now…

    #15020
    Profile photo of smatticus
    smatticus
    Participant

    i had an issue with my 360 pad where i had run retroarch too many times, so i had to delete the controller settings listed in my retroarch.cfg and run the joyconfig one more time. another thing you can do is bring up the retorach menu in-game (usually a combination of button presses like select + X, or F1 on your keyboard) and run the controller setup in there, that’s worked well for me

    #15186
    Profile photo of kinget
    kinget
    Participant

    Sorry, I’ve already tried that!..
    I need to sneakpeak on The cfg from somebody who owns the exact same controller who managed get it to work!..

    #15242
    Profile photo of kinget
    kinget
    Participant

    Update! I actually followed your advice again, and suddenly it worked!
    however.. now im experiencing the emulators to crash whenever I press certain key combinations, such as b + a…
    I’ve only seen the crashes in NES so far..

    Anyone got an idea about that?

    #15257
    Profile photo of kinget
    kinget
    Participant

    After investigating further, I realized that the crashes only occur in the other emulators – not SNES, SNES works fine!

    Also, I cannot trigger the crashes, they happen randomly when I have several buttons pressed at once, as described in the previous post.

    This must have something to do with the lack of buttons for the other emulators?
    I tried to copy the retroarch.cfg from emulators/all into the nes folder to see what happened, but sadly the same issue..

    Please, someone help me out here!
    As it looks now, I can maybe play 5 seconds to 2 minutes until a NES game crashes.

    #15282
    Profile photo of smatticus
    smatticus
    Participant

    You probably have a “quit emulator” hotkey set. This is usually done when pressing multiple buttons (for example I have mine set to be select+start) these settings are set by retroarch automatically in most cases. could you post your retroarch.cfg file from /opt/retropie/configs/all?

    #15286
    Profile photo of kinget
    kinget
    Participant

    Yep, I have a “quit emulator” hotkey, which is set to select+start.
    While running the SNES emulator, it doesn’t crash?
    Just all other emulators (which use less buttons)

    Posting the retroarch.cfg file, however, my path isnt “opt”.
    Mine is from: home/pi/RetroPie/configs/all

    input_player1_joypad_index = “0”
    input_player1_b_btn = “0”
    input_player1_y_btn = “1”
    input_player1_select_btn = “2”
    input_player1_start_btn = “3”
    input_player1_up_axis = “-1”
    input_player1_down_axis = “+1”
    input_player1_left_axis = “-0”
    input_player1_right_axis = “+0”
    input_player1_a_btn = “4”
    input_player1_x_btn = “5”
    input_player1_l_btn = “6”
    input_player1_r_btn = “7”
    input_player2_joypad_index = “1”
    input_player2_b_btn = “0”
    input_player2_y_btn = “1”
    input_player2_select_btn = “2”
    input_player2_start_btn = “3”
    input_player2_up_axis = “-1”
    input_player2_down_axis = “+1”
    input_player2_left_axis = “-0”
    input_player2_right_axis = “+0”
    input_player2_a_btn = “4”
    input_player2_x_btn = “5”
    input_player2_l_btn = “6”
    input_player2_r_btn = “7”
    input_enable_hotkey_btn = “2”
    input_exit_emulator_btn = “3”
    input_save_state_btn = “6”

Viewing 7 posts - 1 through 7 (of 7 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar