Impossible to change to 4:3 ratio ! ARGH!"#€

Home Forums RetroPie Project Video Output on RetroPie Impossible to change to 4:3 ratio ! ARGH!"#€

This topic contains 1 reply, has 2 voices, and was last updated by Profile photo of patrickm patrickm 2 years, 1 month ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #97830
    Profile photo of fiddan
    fiddan
    Participant

    Hello!
    I am new to Retropie so all this is alien for me.
    My problem is that i cant change my resolution for my snes games i have an 720p widescreen computer monitor.

    I have tried to push down X at start up when i load games.
    “1 Select default video mode for emulator/port”
    I have tried to change to almost every DTM-xx whit 4:3 ratio.
    Also the ntcs and pal 4:3 options at the bottom.

    /opt/RetroPie/configs/all/retroarch.cfg
    I have changed to this

    video_aspect_ratio = 1.33
    #1.333333 (4:3) Traditional SDTV
    #1.56 (14:9) 4:3/16:9 Compromise aspect ratio
    #1.6667 (5:3 Super 16mm)
    #1.77 (16:9) HDTV US standard 
    #1.78 (16:9) HDTV US standard alternate
    #1.6 (16:10) Common computer screen ratio
    #1.6667 (5:3) Common European widescreen standard
    #1.85 Common US widescreen cinema
    #2.39 Current widescreen cinema alternate
    #2.40 Current widescreen cinema alternate

    And the /opt/retropie/configs/snes

    # All settings made here will override the global settings for the current emulator core
    
    video_shader = /opt/retropie/emulators/retroarch/shader/snes_phosphor.glslp
    video_shader_enable = false
    video_smooth = false
    video_aspect_ratio = 1.33
    #1.333333 (4:3) Traditional SDTV
    #1.56 (14:9) 4:3/16:9 Compromise aspect ratio
    #1.6667 (5:3 Super 16mm)
    #1.77 (16:9) HDTV US standard 
    #1.78 (16:9) HDTV US standard alternate
    #1.6 (16:10) Common computer screen ratio
    #1.6667 (5:3) Common European widescreen standard
    #1.85 Common US widescreen cinema
    #2.39 Current widescreen cinema alternate
    #2.40 Current widescreen cinema alternate
    input_enable_hotkey = nul
    aspect_ratio_index = "6"
    video_scale_integer = true
    rgui_show_start_screen = false

    I have been working at this problem for many days right now and i have been done many changes in different files, i have done almost every tip from my google searches :/

    One more problem is that form some guides from google i my folder index do not look like others sometime. i have installed the RetroPie SD-card Image, but i don’t know the version number, only Emulationstation v2.0.0-rc1.

    Thanx for the help!
    /Fredrik

    #97834
    Profile photo of patrickm
    patrickm
    Participant

    Hello!
    I am new to Retropie so all this is alien for me.
    My problem is that i cant change my resolution for my snes games i have an 720p widescreen computer monitor.

    I have tried to push down X at start up when i load games.
    “1 Select default video mode for emulator/port”
    I have tried to change to almost every DTM-xx whit 4:3 ratio.
    Also the ntcs and pal 4:3 options at the bottom.

    /opt/RetroPie/configs/all/retroarch.cfg
    I have changed to this

    video_aspect_ratio = 1.33
    #1.333333 (4:3) Traditional SDTV
    #1.56 (14:9) 4:3/16:9 Compromise aspect ratio
    #1.6667 (5:3 Super 16mm)
    #1.77 (16:9) HDTV US standard 
    #1.78 (16:9) HDTV US standard alternate
    #1.6 (16:10) Common computer screen ratio
    #1.6667 (5:3) Common European widescreen standard
    #1.85 Common US widescreen cinema
    #2.39 Current widescreen cinema alternate
    #2.40 Current widescreen cinema alternate

    And the /opt/retropie/configs/snes

    # All settings made here will override the global settings for the current emulator core
    
    video_shader = /opt/retropie/emulators/retroarch/shader/snes_phosphor.glslp
    video_shader_enable = false
    video_smooth = false
    video_aspect_ratio = 1.33
    #1.333333 (4:3) Traditional SDTV
    #1.56 (14:9) 4:3/16:9 Compromise aspect ratio
    #1.6667 (5:3 Super 16mm)
    #1.77 (16:9) HDTV US standard 
    #1.78 (16:9) HDTV US standard alternate
    #1.6 (16:10) Common computer screen ratio
    #1.6667 (5:3) Common European widescreen standard
    #1.85 Common US widescreen cinema
    #2.39 Current widescreen cinema alternate
    #2.40 Current widescreen cinema alternate
    input_enable_hotkey = nul
    aspect_ratio_index = "6"
    video_scale_integer = true
    rgui_show_start_screen = false

    I have been working at this problem for many days right now and i have been done many changes in different files, i have done almost every tip from my google searches :/

    One more problem is that form some guides from google i my folder index do not look like others sometime. i have installed the RetroPie SD-card Image, but i don’t know the version number, only Emulationstation v2.0.0-rc1.

    Thanx for the help!
    /Fredrik

    You have to choose your monitor’s native resolution as the video output resolution. Retroarch render resolution should match this. The native res is the maximum res your display is capable of.

    You cannot get a perfect 4:3 aspect ratio without scaling artifacts using a fixed-pixel display. Well, there are some exceptions, but SNES isn’t one of them. Your best bet is to use 5x integer scaling on the Y axis and set the X axis accordingly. This will result in a slightly wider than 4:3 aspect with the top and bottom cropped off, but with the original pixel aspect preserved. See “how to get perfect video scaling”

    It is highly recommended that you not set video output to anything other than your native res, as this will cause input lag and scaling problems.

    EDIT : I see you are using a 720p display. In that case, just follow the instructions for setting integer scale. You can usually get close to a 4:3 aspect ratio. I think 4×3 integer scale gets you close to a 4:3 aspect ratio with NES for example.

Viewing 2 posts - 1 through 2 (of 2 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar