Image too big

This topic contains 9 replies, has 5 voices, and was last updated by  spaceinvader 1 year, 4 months ago.

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #120072

    spaceinvader
    Participant

    I don’t know what has happened, but suddenly my retropie boots with the image too big and out of the limits of my tv.

    I thought I’d changed some configuration, so I started again with a fresh sd image and the same.

    I’ve also tried in a different TV and the same.

    What has happened?

    Attachments:
    #120203

    mydriaze
    Participant

    Have you check your HDMI cable? Pretty sure it’s not the right answer, but who knows, give it a try.

    #120207

    herbfargus
    Member

    There are overscan values you can play with in /boot/config.txt

    #120264

    spaceinvader
    Participant

    Tried with a brand new hdmi cable and the same.

    I know I can try changing the overscan values, but I don’t understand why before with a new sd imagen it always took the right resolution itself and now it does not…

    Anyway, thanks.

    #120268

    dankcushions
    Participant

    My suspicion is that later firmware updates have changed how overscan works on the pi. i had to change my overscan configuration with the pi3 and 3.6, but the GPU is the same so there shouldn’t be a hardware reason for that (?). so i think maybe the firmware is different in this regard.

    #120269

    spaceinvader
    Participant

    I forgot to say that the same problem occurs with older images, such as 3.5, 3.4, …

    So I don’t relieve it is because of the firmware.

    Anyway I’ll try another hdmi_mode…

    #120341

    mydriaze
    Participant

    Even with a fresh 3.6 install? That’s not possible, theorically.

    #121244

    spaceinvader
    Participant

    Sorry mydriaze. I hadn’t seeen tour response.

    Yes, even with a fresh image. It seems like before my tv’s resolution was correctly detected and automaticly put on the config.txt file and now it is not…

    #122100

    shakz
    Participant

    I think there are a couple things you can try.
    You will need to edit your /boot/config.txt file
    The default settings are as follows.

    # uncomment if hdmi display is not detected and composite is being output
    #hdmi_force_hotplug=1
    
    # uncomment to force a specific HDMI mode (this will force VGA)
    #hdmi_group=1
    #hdmi_mode=1
    

    It sounds like you may need to uncomment force_hotplug. If you dont know how to use vi or edit files in linux just run this.
    sudo perl -p -i -e 's/#hdmi_force_hotplug=1/hdmi_force_hotplug=1/g' /boot/config.txt
    That just turns this.
    #hdmi_force_hotplug=1
    into this
    hdmi_force_hotplug=1
    so the pie will read it after bootup.
    Reboot and see if this works.
    If not reverse it running the following command.
    sudo perl -p -i -e 's/hdmi_force_hotplug=1/#hdmi_force_hotplug=1/g' /boot/config.txt

    Next you can try forcing the pie into 1080p mode. With the following commands. Again they are just uncommenting the variables so your machine will read them on the next boot.
    Not sure where you are from so here are the NA and EU setups.

    for NTSC (North American TVs 60Hz)
    1080p

    sudo perl -p -i -e 's/#hdmi_group=1/hdmi_group=1/g' /boot/config.txt
    sudo perl -p -i -e 's/#hdmi_mode=1/hdmi_mode=16/g' /boot/config.txt

    to switch back tp default from NTSC settings.

    sudo perl -p -i -e 's/hdmi_group=1/#hdmi_group=1/g' /boot/config.txt
    sudo perl -p -i -e 's/hdmi_mode=16/#hdmi_mode=1/g' /boot/config.txt

    for PAL (European TVs 50Hz)

    sudo perl -p -i -e 's/#hdmi_group=1/hdmi_group=1/g' /boot/config.txt
    sudo perl -p -i -e 's/#hdmi_mode=1/hdmi_mode=31/g' /boot/config.txt

    To go back to default from pal settings

    sudo perl -p -i -e 's/hdmi_group=1/#hdmi_group=1/g' /boot/config.txt
    sudo perl -p -i -e 's/hdmi_mode=31/#hdmi_mode=1/g' /boot/config.txt

    You can see the values here.
    https://www.raspberrypi.org/documentation/configuration/config-txt.md

    Hope this helps you!

    #122113

    spaceinvader
    Participant

    Yes, I solved the problema editting config.txt and changing hdmi mode to 16, but I don’t understand why before I didn’t need to change it, it seemed like on first boot the correct resolution was detected and now it doesn’t…

    Anyway many thanks for the help!

Viewing 10 posts - 1 through 10 (of 10 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/