I love Retropie, but

This topic contains 10 replies, has 4 voices, and was last updated by Profile photo of lain lain 2 years, 5 months ago.

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #84891
    Profile photo of lain
    lain
    Participant

    When I heard about Retropie I just had to get my hands on a Raspberry pi. I own a NES and a PSX and have owned a SEGA. I love the idea of a mini multi game machine but I have ran into some problems that have made me want to put the pi back on the shelve for $.

    I purchased a B+ and used SDFormatter for the format and DiskImager for the Retropie 2.3 and it booted nicely. I even used sudo apt-get update which worked the first couple of times. It wasn’t until I used sudo apt-get upgrade when I started getting ext4-fs error (device mmcblk0p2 (I let it go to about 6000 and over an hour before I figured something was wrong)

    After many, many form reads, youtube videos, and voices from the wall I thought lets format and get only “update” and hook up the SNES controller. I have read about nightmares with controllers trying to get RetroArch to work and it’s one for me too so far. It works for the menus but once in game 0%. I even used Putty but couldn’t find the retroarch.cfg as it was not there after I log into the ip. I did manage to find it through retropie going through folders but then had permission problems trying to open it. I then proceeded to find videos on password/login issues but nothing has worked so far. I even tried retroarch-joyconfig -o and nothing seems to work in game.

    Eventually even sudo apt-get update gave me an ext4-fs error after a fresh format. and EmulationStation failed to work. I use a hdmi cable, and a phone charger for power. I also have no trouble transferring ROMS.

    I have now done a fresh format with 2.3 with no updates of any kind, not even expanding my micro sd card for ROMS. I’m really at a loss for words and forgive this second draft as for some reason it seems that my original post was deleted somehow…I really would like to get this to work as it is a surprise project for my brother and I thought I could do it. 🙂 But not I am ready to give up. I’m not sure if I could explain it better as I have not touched Linux, but I’m very careful with the code I put in. I would appreciate any guidance.

    Thanks

    pictures
    http://postimg.org/gallery/27o0gpnfu/

    #84894
    Profile photo of lolerzz
    lolerzz
    Participant

    Sorry, but what you wrote is kinda chaotic so let me confirm some things:
    You got the retropie image on SD card
    You expanded filesystem using raspi-config
    You then started “sudo ./retropie_setup.sh”
    After that you did either binary or source code installation, followed by a SETUP
    If you did all of this then I don’t see any problems? ext4 error probably is connected to the SD card, maybe it’s corrupted or poorly prepared/written? Will monitor this thread and try to help you.

    #84895
    Profile photo of lain
    lain
    Participant

    Yes it’s kinda got me into a chaotic mode so I’ll try to be shorter and more to the point. I’ve gone through so many setups and commands that it’s hard to remember what I tried during which format at the moment.
    You are right I got it on a micro sd card
    I started “sudo ./retropie_setup.sh”
    I selected option 4 and 5 (I’m thinking those are setups or updates as I just have them written down as steps.)
    Then I searched for the ip in order the transfer the ROMS which I did.
    I think at that point I started trying to configure the controller.
    I’m not sure if I always did the steps you just said in order. Should I always do them after a format or should I continue with trying the sudo apt-get “”? If so I can at least try to get that far and stop until it’s figured out.

    #84905
    Profile photo of Floob
    Floob
    Member

    I’d be tempted to keep it simple to start with, something like
    – Write clean image to sd card
    – Dont update or upgrade anything (maybe expand the filesize with raspi-config)
    – Put one rom in the snes or megadrive rom folder

    (At the very least I’m assuming you can boot this into EmulationStation where it shows the games to choose)

    – Configure your controller for games

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #84906
    Profile photo of lolerzz
    lolerzz
    Participant

    Okay so things you do bad are at running retropie_setup, lemme go step by step with you, to the point where you set up your sontroller, okay?
    Before you do retropie_setup, do sudo raspi-config and expand the filesystem.
    Then reboot the RPi (this is important)
    THEN you actually can go sudo ./retropie_setup.sh
    There, you select Update Binaries and Update Setup
    After that’s done, select the first option which is BINARY based installation
    Then select “SETUP (only if you already did one of the installations above)” (this should be 3rd option if I remember correctly).
    It’ll all install and reboot.
    Now go back to raspi-config
    Here (or in retropie_setup I can’t remember) there should be advanced options that allow setting up the controller. You’ll be asked to press correct buttons/analogs. Then after you do that the pad should be configured for almost all emulators. I dunno about the rest and second player – I think you’ll have to edit some cfg files to get second controller to work. If you’re using snes controllers through GPIO there is a setting for that in raspi-config or retropie_setup too. Hope this helps you a little… If you have more specific questions go on, I’ll try to help you more.

    #84943
    Profile photo of lain
    lain
    Participant

    The good news, it works! Bad news, some games still have no effect on the controller. I followed your instructions lolerzz and everything was working smoothly until I hit the binary based installation. Lot of text and a
    ======
    Fatal Error
    ======

    Oh boy. So I decided to just run it again, and three hours later, installed all kinds of archive and dependencies and who knows what. But in the no fatal errors and I continued through the advanced options and worked the controller which is the first time I got it to work on any game 🙂 and I’m grateful for that. However the controller doesn’t register with the game super mario all stars. Is there a list of games where the controller has problems? I know I could always get each one individually, but I was curious. I have also noticed some games require pressing select instead of start! There is a way to open the text file to the controller and delete non used buttons or change current ones yes?

    BTW I even got it to work on an analog TV and I got all this finish when my brother was walking into the door. Needless to say he’s thrilled!

    Back the the Fatal Error it said something about no module ‘127’ found on platform rpi and my controller saved as USB, 2-axis8-buttongamepad.cfg

    I am also assuming I need custom bios for psx emulator and I tried some games like Quest 64 and Crash Team Racing which I think is too much for the raspberry to handle, or at least from my experience. I do still have RPG maker on it so I still like messing around with it and it works 🙂

    The control panel also told me I had to install Neogeo bios and others but I won’t be using those so it’s OK.

    Thanks a lot and I hope to be able to tweak just a couple more things, but in the end it works right now and we are quite happy!

    Thanks

    #84950
    Profile photo of lolerzz
    lolerzz
    Participant

    You can setup keybindings for each game.
    BIOS for PSX is needed to prevent various glitches. I dunno about games you’ve tried, but I tested Final Fantasy Tactics, Armored Core and Castlevania SotN, all worked fine, with slight stutters on armored core but it was all acceptable.
    Neogeo setup is a pain in the ass, and I won’t be much of a help there. Glad you got it working though. Have fun and if you have more questions feel free to ask here or in PM.

    #84974
    Profile photo of lain
    lain
    Participant

    I’m happy to report that I did manage to get Mario All Stars to work with the Euro version and I had the use the Jap version of Double Dragon to get it to work. I was also happy to get Dig Dug II to work as well. Even though I have not been able to figure out how to open my controller again to change or edit buttons (tried to just redo the setup but buttons didn’t change) it could be a text file but I have no idea where it is. I found a list of PSX games that will work but the games I want to play are not in there so no problem. All I really care about is nes snes and gen and that’s working so ty.

    I’d say this is resolved for now.

    #85029
    Profile photo of lolerzz
    lolerzz
    Participant

    Uh, with snes you’ll have a hard time. While video on snes games is okay, music is HORRIBLE.

    #85035
    Profile photo of petrockblog
    petrockblog
    Keymaster

    If you got a Fatal Error it’s possible not everything installed correctly. The project has been going through heavy development, and it’s possible there were some bugs when you ran it. Please do sudo ./retropie_setup.sh – update the script – exit and run it again and do the first option (btw there is no need to run update binaries before doing that – the first options also updates the binaries).

    If you get any errors please post me a log.

    #85055
    Profile photo of lain
    lain
    Participant

    The genesis, snes and nes games work in both video and audio. I am not touching anything until something messes up. Thanks for your concern and I may post more here when something does happen.

Viewing 11 posts - 1 through 11 (of 11 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar